Contribute
Register

GA-Z77X-UD5H, fresh 10.10 yosemite, "OS X could not be installed on your system"

Joined
Dec 29, 2010
Messages
8
Motherboard
GA-Z77X-UD5H rev 1.1 BIOS:F14
CPU
i7-3770
Graphics
Radeon 5770
Mac
Mac Pro
Classic Mac
Mobile Phone
I'm having trouble getting a fresh Yosemite installation to complete successfully. I'm following the unibeast guide to the letter, and when i get to Step4 #7 (the installation) i get the error "OS X could not be installed on your computer" "Request failed to initialize" "Quit the installer to restart your computer and try again". and then i'm sunk. any ideas on what i'm missing? This system (except new HD) has been running 10.8.2 Mtn Lion for over a year without a hiccup.

the only anomaly I can notice between my system and the unibeast instructions are that I can't locate the settings for the following items in my BIOS:

If your system has CFG-Lock, disable it
If your system has Secure Boot Mode, disable it
Set OS Type to Other OS

BIOS settings:
Load Optimized Defaults
VT-d = disabled

System:
GA-Z77X-UD5H rev 1.1 BIOS:F14
CPU: i7-3770
Graphics: Radeon 5770
HD: Samsung 840 Pro plugged into a Sata3 Intel Z77 port

Thanks!
 
Joined
Jul 22, 2013
Messages
53
Motherboard
Gigabyte GA-Z77X-UD5H
CPU
i7-3770
Graphics
RX 590
Mac
MacBook Pro
Mobile Phone
iOS
Hmm... I have the same motherboard and a similar BIOS settings, but my installation worked fine on the first try. I'm really only struggling with post-installation now... haha.

I'm far from an expert, but I can think of a few things to try:

-Use a different USB stick to load the installer on with Unibeast
-Reformat the hard drive you're installing to just before installation (you can access disk utility when booting from the installer USB drive). Make sure to use Mac Journaled, of course.

Dunno if you have already tried those, but they seem worth a shot.
 
Joined
Dec 29, 2010
Messages
8
Motherboard
GA-Z77X-UD5H rev 1.1 BIOS:F14
CPU
i7-3770
Graphics
Radeon 5770
Mac
Mac Pro
Classic Mac
Mobile Phone
Thanks for the comments Bhuij!

I'll try to make the USB stick again. I hadn't been re-formatting the HD on every attempt, but I will try that again--I was using Journaled as noted in the instructions. Correct me if I'm wrong, but those optional boot flags are only if there are problems REACHING the installer, not for problems within the installer itself, correct?
 
Joined
Jul 22, 2013
Messages
53
Motherboard
Gigabyte GA-Z77X-UD5H
CPU
i7-3770
Graphics
RX 590
Mac
MacBook Pro
Mobile Phone
iOS
Regarding the bootflags, I understood the same thing from reading the tutorial - that you only need them if you can't get to the installer from the USB stick. I didn't have that problem though so I never had to mess with them.
 
Joined
Dec 29, 2010
Messages
8
Motherboard
GA-Z77X-UD5H rev 1.1 BIOS:F14
CPU
i7-3770
Graphics
Radeon 5770
Mac
Mac Pro
Classic Mac
Mobile Phone
Turned out to be a dud of a USB drive--which is weird because it said it completed successfully. I re-made it and now i'm getting through the installation just fine.
 
Joined
Jul 22, 2013
Messages
53
Motherboard
Gigabyte GA-Z77X-UD5H
CPU
i7-3770
Graphics
RX 590
Mac
MacBook Pro
Mobile Phone
iOS
Happy to hear it! That's the second time I've seen a bad USB stick ruin a good installation :D
 
Top