Contribute
Register

GA-X58A-UD3R (rev. 2.0) Mojave

Joined
Mar 25, 2011
Messages
9
Motherboard
GA-x58a-UD3R
CPU
i7-980
Graphics
gtx 770
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Plus
  2. Power Mac
  3. PowerBook
I was having some trouble with Mojave install on a GA-X58A-UD3R (rev. 2.0, FF), i7 980, gtx 770 rig. Halting on "waiting for root device". I realized I had a clone of vanilla install on a SSD kicking around, all updated and everything. Hmmm. I put it in the computer, booted with my Unibeast USB and I was in. Downloaded Multibeast and installed (Legacy, Realtek 8111 v2.2.2) and rebooted. Happy happy! Keplar card came up accelerated Metal, but the computer was sluggish. I realized the default device id was iMac14,2 so I switched it to Mac Pro 5,1... reboot, faster happy. Wake/sleep/reboot all seem to work thought it is early days. I have yet to address the Realtek 889 sound but I suspect Multibeast can handle that. I've done many hackintosh installs but I don't recall ever using a cloned vanilla with Uni and multibeast. Again, thanks to the folks who do the development of these tools. So great!
 
Last edited:

JJG

Joined
Nov 30, 2010
Messages
22
Motherboard
GA-X58A-UD3R v2.0
CPU
intel i7
Graphics
GTX670
you mention "clone of vanilla install" what is it? How is the mojave os working? did you figure out how to get sound? do you have WiFi and Bluetooth? I'm looking to update my machine to something that is stable to run adobe LR PS and PR, is there a guide to instal mojave on this motherboard? thanks!
I got a GA-X58A-UD3R rev 2.0 intel i7 3.1, 12GB of memory and a Nvidia gtx 670
 

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
23,240
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
you mention "clone of vanilla install" what is it? How is the mojave os working? did you figure out how to get sound? do you have WiFi and Bluetooth? I'm looking to update my machine to something that is stable to run adobe LR PS and PR, is there a guide to instal mojave on this motherboard? thanks!
I got a GA-X58A-UD3R rev 2.0 intel i7 3.1, 12GB of memory and a Nvidia gtx 670
A "clone of vanilla install is a clone made after installation of the OS, but before running MultiBeast and installing Chimera or Clover and adding kexts to support your hardware.
What version Mac OS are you running at this time?
If you are running with a fully edited DSDT with a MacPro5,1 system definition you can update to High Sierra with no problems. To update to Mojave or Catalina you will need to add some patches in your config.plist. Open Core is the way to go for the future instead of Clover.
 

JJG

Joined
Nov 30, 2010
Messages
22
Motherboard
GA-X58A-UD3R v2.0
CPU
intel i7
Graphics
GTX670
A "clone of vanilla install is a clone made after installation of the OS, but before running MultiBeast and installing Chimera or Clover and adding kexts to support your hardware.
What version Mac OS are you running at this time?
If you are running with a fully edited DSDT with a MacPro5,1 system definition you can update to High Sierra with no problems. To update to Mojave or Catalina you will need to add some patches in your config.plist. Open Core is the way to go for the future instead of Clover.

Im running mountain lion, i checked and I can not download high sierra from the mac store, i would be fine running high sierra, the problem i mainly have with mountain lion is that there is no browser support for many websites i moved to chrome but support for that ended too so i can not open a lot of websites
 

JJG

Joined
Nov 30, 2010
Messages
22
Motherboard
GA-X58A-UD3R v2.0
CPU
intel i7
Graphics
GTX670
Joined
Jan 23, 2014
Messages
44
Motherboard
Gigabyte X58A-UD3R-FH
CPU
X5650
Graphics
GT 710
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
  2. Other
I have similar components and i would like to instal Mojave from the scratch.
what tutorial should i follow? Thanx.


Gigabyte Technology Co. Ltd. X58A-UD3R (Socket 1366)
Intel Core i7 950 @ 3.07GHz
Bloomfield 45nm
12.0GB Triple-Channel DDR3
1023MB NVIDIA GeForce GT 710
SSD 223GB Crucial
 
Joined
Jan 23, 2014
Messages
44
Motherboard
Gigabyte X58A-UD3R-FH
CPU
X5650
Graphics
GT 710
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
  2. Other
I followed Open Core Guide and after a week of struggle i got trough the verbose part and now im stuck here almost at the end of this first part (almost 2 mins left). It goes into black screen and stays there.
I tried formating ssd to os extended journald and same haappend.

I also tried to change few SMBIOS versions. Every time the same happens.

MacPro5,1
MacPro6,1
iMac14,2
iMac18,1

What can i do?
 

Attachments

  • 139855116_10225186804123514_1118838136166815339_o.jpg
    139855116_10225186804123514_1118838136166815339_o.jpg
    111.1 KB · Views: 21
  • 139844586_10225186800843432_3922822863755059462_o.jpg
    139844586_10225186800843432_3922822863755059462_o.jpg
    306.3 KB · Views: 15
  • 139697228_10225186802563475_4245329434397067582_o.jpg
    139697228_10225186802563475_4245329434397067582_o.jpg
    244.1 KB · Views: 13
  • 139835905_10225186802203466_869666941618701306_o.jpg
    139835905_10225186802203466_869666941618701306_o.jpg
    444.8 KB · Views: 12
  • 139817205_10225186804443522_6131023130443142476_o.jpg
    139817205_10225186804443522_6131023130443142476_o.jpg
    397.8 KB · Views: 14
  • 139749065_10225186803923509_206192353608906405_o.jpg
    139749065_10225186803923509_206192353608906405_o.jpg
    343.6 KB · Views: 19
  • 139999353_10225186801923459_2307437877401316958_o.jpg
    139999353_10225186801923459_2307437877401316958_o.jpg
    612.6 KB · Views: 22
Joined
Oct 10, 2015
Messages
821
Motherboard
Z370 AORUS Gaming 3
CPU
i5-9600K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I followed Open Core Guide and after a week of struggle i got trough the verbose part and now im stuck here almost at the end of this first part (almost 2 mins left). It goes into black screen and stays there.
I tried formating ssd to os extended journald and same haappend.

I also tried to change few SMBIOS versions. Every time the same happens.

MacPro5,1
MacPro6,1
iMac14,2
iMac18,1

What can i do?
Unplug all disks except your target drive and then try again.
 
Top