Contribute
Register

Frequent NVidia related kernel panics and gpu restarts

Joined
Sep 14, 2012
Messages
4
Motherboard
10.8
CPU
3770
Graphics
660ti
Mac
Classic Mac
Mobile Phone
Put together a new hack based on Stork's MyHero Build. I made a few relatively minor hardware changes from his build:
I also followed the build's install guide with the exception of KextBeast and the Codec Commander kext, as I'm not using on board audio.

Everything was working fine the first couple days, then while playing a game I got a Kernel Panic, followed by a second about 30 minutes later in the same game. Everything was again fine for 4 days after this, but then I got another 3 Kernel Panics in about an hour. The first two of these 3 again were in game, but the third occurred on the subsequent restart.

At this point I started trying to figure out what might be wrong, and the common thread in all five panic reports was "com.nvidia.web.NVDAResmanWeb" in the backtrace of a Read Error. I started searching several forums, including this one, and found a few threads I thought might be helpful, specifically this one and a couple other similar ones that indicated I should check to make sure the card wasn't loose in the PCI Slot.

The Kingpin card is quite heavy (3.2 lbs), so I figured it might be sagging and slipping out. I turned the case on its side so that the GPU would be mounted vertically instead of horizontally, then pulled the GPU out, reinserted it into the PCI slot, and made sure that it had a secure connection. I also ordered an Atlas Graphics Card Brace. Until it arrived, yesterday, I had no panics.

As soon as the brace was delivered I installed it and returned my computer to the proper orientation. I was hopeful that my problem had been solved and that nothing else would go wrong, but since then I've had 10 kernel panics and 4 GPU restarts many of which have come without doing anything taxing graphically. Things I've tried since then:
  • Putting the computer back on its side
  • Removing the brace
  • Using the x8 PCI Express slot instead of the x16
  • Cleaning the GPU contacts
As far as I can tell everything else with the system is working fine. Temps look good and the 650 watt PSU should be sufficient for everything i'm running.

Here is the most recent Kernel Panic, the others look similar:

Code:
Anonymous UUID:       D72A00F5-7D4E-D6E5-CCD5-F1CD88FA0A3E

Mon Jan 16 01:13:54 2017

*** Panic Report ***
panic(cpu 2 caller 0xffffff7f8b95427e): NVRM[0/1:0:0]: Read Error 0x006100c0: CFG 0x17c810de 0x00100407 0xde000000, BAR0 0xde000000 0xffffff93bffb6000 0x120080a1, D0, P3/4
Backtrace (CPU 2), Frame : Return Address
0xffffff83bcb73bb0 : 0xffffff800a8f211c
0xffffff83bcb73c30 : 0xffffff7f8b95427e
0xffffff83bcb73cf0 : 0xffffff7f8ba2ee9d
0xffffff83bcb73d50 : 0xffffff7f8bcc4291
0xffffff83bcb73d60 : 0xffffff7f8b9cc7ab
0xffffff83bcb73d80 : 0xffffff7f8bad2214
0xffffff83bcb73df0 : 0xffffff7f8b926243
0xffffff83bcb73ec0 : 0xffffff7f8b8efdb0
0xffffff83bcb73f00 : 0xffffff800a92a28a
0xffffff83bcb73fb0 : 0xffffff800a8a0af7
      Kernel Extensions in backtrace:
         com.nvidia.web.NVDAResmanWeb(10.1.5)[EE27FF58-F17C-354B-AC5D-02F94D0B3841]@0xffffff7f8b8e8000->0xffffff7f8bc11fff
            dependency: com.apple.iokit.IOPCIFamily(2.9)[6F8D3ACB-27CB-3B57-9E06-53E377762F5C]@0xffffff7f8b04f000
            dependency: com.apple.iokit.IONDRVSupport(513.1)[07F97C14-C6EE-3577-9875-8BA38DDCBCCD]@0xffffff7f8b8cc000
            dependency: com.apple.iokit.IOGraphicsFamily(513.1)[578F9D07-96F4-3F09-A6A6-047F257CB3BA]@0xffffff7f8b885000
            dependency: com.apple.AppleGraphicsDeviceControl(3.13.78)[FD48FB7F-3F5F-38F1-A8C7-B82C80807726]@0xffffff7f8b8dc000
         com.nvidia.web.NVDAGM100HalWeb(10.1.5)[BEBAB721-B71D-3E29-8FE6-85C8215911B1]@0xffffff7f8bc24000->0xffffff7f8bec9fff
            dependency: com.nvidia.web.NVDAResmanWeb(10.1.5)[EE27FF58-F17C-354B-AC5D-02F94D0B3841]@0xffffff7f8b8e8000
            dependency: com.apple.iokit.IOPCIFamily(2.9)[6F8D3ACB-27CB-3B57-9E06-53E377762F5C]@0xffffff7f8b04f000

BSD process name corresponding to current thread: kernel_task
Boot args: dart=0 darkwake=0

Mac OS version:
16C67

Kernel version:
Darwin Kernel Version 16.3.0: Thu Nov 17 20:23:58 PST 2016; root:xnu-3789.31.2~1/RELEASE_X86_64
Kernel UUID: 8DF81F81-019F-348E-B47E-40A4484B9E21
Kernel slide:     0x000000000a600000
Kernel text base: 0xffffff800a800000
__HIB  text base: 0xffffff800a700000
System model name: iMac14,2 (Mac-27ADBB7B4CEE8E61)

System uptime in nanoseconds: 1136064075743
last loaded kext at 243815932062: com.apple.filesystems.msdosfs    1.10 (addr 0xffffff7f8d6da000, size 69632)
last unloaded kext at 347152072902: com.apple.filesystems.msdosfs    1.10 (addr 0xffffff7f8d6da000, size 61440)
loaded kexts:
com.paragon-software.filesystems.ntfs    318.3.14
com.logitech.driver.LogiGamingMouseFilter    1
com.nvidia.web.NVDAGM100HalWeb    10.1.5
com.nvidia.web.GeForceWeb    10.1.5
com.nvidia.web.NVDAResmanWeb    10.1.5
org.hwsensors.driver.GPUSensors    1723
org.hwsensors.driver.ACPISensors    1723
com.driver.LogJoystick    2.0
org.hwsensors.driver.CPUSensors    1723
com.insanelymac.IntelMausiEthernet    2.2.0
net.osx86.kexts.GenericUSBXHCI    1.2.11
org.netkas.driver.FakeSMC    1723
com.rehabman.driver.USBInjectAll    0.5.14
com.apple.driver.AGPM    110.23.14
com.apple.driver.ApplePlatformEnabler    2.7.0d0
com.apple.driver.X86PlatformShim    1.0.0
com.apple.filesystems.autofs    3.0
com.apple.driver.AudioAUUC    1.70
com.apple.driver.AppleHDA    278.56
com.apple.driver.AppleUpstreamUserClient    3.6.4
com.apple.driver.AppleMCCSControl    1.2.15
com.apple.driver.pmtelemetry    1
com.apple.iokit.IOUserEthernet    1.0.1
com.apple.iokit.IOBluetoothSerialManager    5.0.2f4
com.apple.Dont_Steal_Mac_OS_X    7.0.0
com.apple.driver.AppleHV    1
com.apple.driver.AppleOSXWatchdog    1
com.apple.driver.AppleIntelPCHPMC    1.1
com.apple.driver.AppleIntelSlowAdaptiveClocking    4.0.0
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless    1.0.0d1
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib    1.0.0
com.apple.BootCache    40
com.apple.filesystems.hfs.kext    366.30.3
com.apple.driver.AppleUSBLegacyHub    900.4.1
com.apple.iokit.IOAHCIBlockStorage    295.20.1
com.apple.driver.AirPort.Atheros40    700.74.5
com.apple.driver.AppleAHCIPort    326
com.apple.driver.AppleRTC    2.0
com.apple.driver.AppleACPIButtons    5.0
com.apple.driver.AppleHPET    1.8
com.apple.driver.AppleACPIEC    5.0
com.apple.driver.AppleSMBIOS    2.1
com.apple.driver.AppleAPIC    1.7
com.apple.nke.applicationfirewall    172
com.apple.security.quarantine    3
com.apple.security.TMSafetyNet    8
com.apple.kext.triggers    1.0
com.apple.driver.DspFuncLib    278.56
com.apple.kext.OSvKernDSPLib    525
com.apple.driver.AppleSMBusController    1.0.14d1
com.apple.iokit.IOSurface    153.3
com.apple.iokit.IOBluetoothFamily    5.0.2f4
com.apple.iokit.IOAcceleratorFamily2    289.27
com.apple.AppleGraphicsDeviceControl    3.13.78
com.apple.driver.AppleSSE    1.0
com.apple.iokit.IONDRVSupport    513.1
com.apple.driver.AppleHDAController    278.56
com.apple.iokit.IOGraphicsFamily    513.1
com.apple.iokit.IOHDAFamily    278.56
com.apple.iokit.IOSerialFamily    11
com.apple.iokit.IOSlowAdaptiveClockingFamily    1.0.0
com.apple.driver.X86PlatformPlugin    1.0.0
com.apple.driver.AppleSMC    3.1.9
com.apple.driver.IOPlatformPluginFamily    6.0.0d8
com.apple.iokit.IOSCSIArchitectureModelFamily    394.30.2
com.apple.driver.AppleHIDKeyboard    197
com.apple.driver.usb.IOUSBHostHIDDevice    1.1
com.apple.driver.AppleUSBAudio    307.7
com.apple.iokit.IOAudioFamily    205.11
com.apple.vecLib.kext    1.2.0
com.apple.driver.usb.networking    5.0.0
com.apple.driver.usb.AppleUSBHostCompositeDevice    1.1
com.apple.driver.AppleUSBHostMergeProperties    1.1
com.apple.driver.usb.AppleUSBHub    1.1
com.apple.filesystems.hfs.encodings.kext    1
com.apple.driver.usb.AppleUSBHostPacketFilter    1.0
com.apple.iokit.IO80211Family    1200.12.2
com.apple.driver.corecapture    1.0.4
com.apple.iokit.IONetworkingFamily    3.2
com.apple.iokit.IOAHCIFamily    288
com.apple.iokit.IOUSBFamily    900.4.1
com.apple.driver.usb.AppleUSBXHCIPCI    1.1
com.apple.driver.usb.AppleUSBXHCI    1.1
com.apple.driver.AppleEFINVRAM    2.1
com.apple.driver.AppleEFIRuntime    2.0
com.apple.iokit.IOHIDFamily    2.0.0
com.apple.iokit.IOSMBusFamily    1.1
com.apple.security.sandbox    300.0
com.apple.kext.AppleMatch    1.0.0d1
com.apple.driver.AppleKeyStore    2
com.apple.driver.AppleMobileFileIntegrity    1.0.5
com.apple.driver.AppleCredentialManager    1.0
com.apple.driver.KernelRelayHost    1
com.apple.iokit.IOUSBHostFamily    1.1
com.apple.driver.AppleBusPowerController    1.0
com.apple.driver.DiskImages    444.30.5
com.apple.iokit.IOStorageFamily    2.1
com.apple.iokit.IOReportFamily    31
com.apple.driver.AppleFDEKeyStore    28.30
com.apple.driver.AppleACPIPlatform    5.0
com.apple.iokit.IOPCIFamily    2.9
com.apple.iokit.IOACPIFamily    1.4
com.apple.kec.Libm    1
com.apple.kec.pthread    1
com.apple.kec.corecrypto    1.0

System Profile:
Network Service: Wi-Fi, AirPort, en1
Thunderbolt Bus:
Memory Module: BANK0/DIMM0, 16 GB, DDR4, 2132 MHz, G Skill Intl, F4-3200C16-16GVK
Memory Module: BANK0/DIMM1, 16 GB, DDR4, 2132 MHz, G Skill Intl, F4-3200C16-16GVK
USB Device: USB 3.0 Bus
USB Device: Gaming Mouse G600
USB Device: Keyboard Hub
USB Device: Apple Keyboard
USB Device: General Purpose USB Hub
USB Device: SteelSeries H Wireless
USB Device: SteelSeries H Wireless
Serial ATA Device: SAMSUNG SSD 830 Series, 256.06 GB
Serial ATA Device: Samsung SSD 840 Series, 250.06 GB
Serial ATA Device: SAMSUNG SSD 830 Series, 256.06 GB
Serial ATA Device: Samsung SSD 840 EVO 250GB, 250.06 GB
Model: iMac14,2, BootROM IM142.0118.B00, 4 processors, Intel Core i7, 4.01 GHz, 32 GB, SMC 2.15f2
Graphics: NVIDIA GeForce GTX 980 Ti, NVIDIA GeForce GTX 980 Ti, PCIe, 6143 MB
AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x3112), Atheros 9380: 4.0.74.0-P2P
Here is the most recent GPU restart:
Code:
Sun Jan 15 23:35:43 2017

Event:               GPU Reset
Date/Time:           Sun Jan 15 23:35:43 2017
Application:
Path:       
Tailspin:            /Library/Logs/DiagnosticReports/gpuRestart2017-01-15-233543.tailspin
GPUSubmission Trace ID: 0
OS Version:          Mac OS X Version 10.12.2 (Build 16C67)
Graphics Hardware:   NVIDIA Chip Model
Signature:           0

Report Data:

NVDA(Graphics): Channel timeout!
Channel Info: [0, 0x2, 0x3, 0x12c]
Version Info: [com.nvidia.web.GeForceWeb, 10.1.5, 0x4e554e, 21472304, 367.15.10.25f02, 1]



System Profile:
Network Service: Wi-Fi, AirPort, en1
Thunderbolt Bus:
Memory Module: BANK0/DIMM0, 16 GB, DDR4, 2132 MHz, G Skill Intl, F4-3200C16-16GVK
Memory Module: BANK0/DIMM1, 16 GB, DDR4, 2132 MHz, G Skill Intl, F4-3200C16-16GVK
USB Device: USB 3.0 Bus
USB Device: Gaming Mouse G600
USB Device: Keyboard Hub
USB Device: Apple Keyboard
USB Device: General Purpose USB Hub
USB Device: SteelSeries H Wireless
USB Device: SteelSeries H Wireless
Serial ATA Device: SAMSUNG SSD 830 Series, 256.06 GB
Serial ATA Device: Samsung SSD 840 Series, 250.06 GB
Serial ATA Device: SAMSUNG SSD 830 Series, 256.06 GB
Serial ATA Device: Samsung SSD 840 EVO 250GB, 250.06 GB
Model: iMac14,2, BootROM IM142.0118.B00, 4 processors, Intel Core i7, 4.01 GHz, 32 GB, SMC 2.15f2
Graphics: NVIDIA GeForce GTX 980 Ti, NVIDIA GeForce GTX 980 Ti, PCIe, 6143 MB
AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x3112), Atheros 9380: 4.0.74.0-P2P
I've seen a lot of threads about similar issues, a lot of potential solutions, and nothing that's looked like it might actually resolve things. On the plus side, the machine didn't die while I wrote this post. I'm really hoping that I didn't get a bad GPU, as it wasn't cheap to come by. Does anyone out there have any ideas?
 
Last edited:
Joined
Feb 12, 2013
Messages
58
Motherboard
GA-Z77X-UD5H rev. 1.1, BIOS F14
CPU
i7-3770K
Graphics
GTX 1050 TI
Mac
MacBook Pro, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
Hi,

Did you ever get this resolved?

I have a build of "Slugnet's Video editor" (in my sig.) and after years on 10.8.5 upgraded last summer to 10.12.6 and finally upgraded 2 months ago my GTX 580 3GB to a GTX 1050ti 4GB (best I could do at this crazy time for GPUs).

It worked fine for 6 weeks, then the random restarts started. It seemed GPU related as it would happen when I would have a lot of web pages open, and/or, rendering a video out (usually in H264).

All research pointed to the card not being seated correctly. I reseated the card, and then had issues in Premiere Pro with my video displaying inside the program going white, black or gray. I re-installed the drivers and it had become stable. BUT, I just had my 1st forced restart in a week. The culprit looks like the same as yours and the same as mine was, until I reseated the card last week. Damn, I thought this was behind me. I will try a different GPU from home (a GTX 670 4GB) tomorrow.

Forced restart happened while rendering a video in H264.

I did 8 successful renders in another codec (ProRes) prior to this. Could it be H264 related?

Any tips would be appreciated. I do hope it's not the 1050ti.

Thanks!



"Problem Report for MacOS":

(SNIP)

Kernel Extensions in backtrace:
com.nvidia.web.NVDAResmanWeb(10.1.8)[17922CF7-386B-3694-B462-94A367420A7C]@0xffffff7f876f1000->0xffffff7f87d28fff
dependency: com.apple.iokit.IOPCIFamily(2.9)[116F5E39-E2DA-3211-86A2-5F01E8B07E01]@0xffffff7f87131000
dependency: com.apple.iokit.IONDRVSupport(516.1)[91AC4707-DCD4-35D4-81AD-9C425B63F349]@0xffffff7f876d5000
dependency: com.apple.iokit.IOGraphicsFamily(515.3)[5EAC4E7C-6842-3DC0-A2D7-8A8BDA842179]@0xffffff7f8768d000
dependency: com.apple.AppleGraphicsDeviceControl(3.14.49)[FA94C7C0-04C2-3F83-9F96-0470C31E2AA3]@0xffffff7f876e5000
com.nvidia.web.NVDAGP100HalWeb(10.1.8)[E489B3EA-E302-33F7-B0A6-FF45CF2E60FA]@0xffffff7f87d3d000->0xffffff7f87ed6fff
dependency: com.nvidia.web.NVDAResmanWeb(10.1.8)[17922CF7-386B-3694-B462-94A367420A7C]@0xffffff7f876f1000
dependency: com.apple.iokit.IOPCIFamily(2.9)[116F5E39-E2DA-3211-86A2-5F01E8B07E01]@0xffffff7f87131000

(SNIP)
 
Joined
Sep 25, 2012
Messages
1,283
Motherboard
Asus Z270 Maximus IX HERO
CPU
i7 7700k
Graphics
EVGA GTX 1080 Ti FTW3
Mac
Mac Pro
Mobile Phone
iOS
We haven't heard from him for almost a year...

If you also activate the on-chip video you will get more H.264 goodness in your renders. Have a look in the Graphics section of this board.

p.s. - I've had TWO KingPin edition cards, first was returned and the second one sits in a drawer unused - I think they were both used cards that had been O.C.'d to death.
 
Top