Contribute
Register

For anyone who would like to help me with acpi hotpatch.

DimitrisG

Banned
Joined
Aug 5, 2018
Messages
523
Motherboard
Dell 5570-Clover
CPU
i5-8250U
Graphics
UHD 620, 1920x1080
Well , after a lot of tries here is the result.

Please , take a good look because I'm sure there are many errors to resolve.
Thanks in advance for your time.

Y.G. Keeping kexts at clover/other for now. Will install at l/e when finalise.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,974
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Well , after a lot of tries here is the result.

Please , take a good look because I'm sure there are many errors to resolve.
Thanks in advance for your time.

Y.G. Keeping kexts at clover/other for now. Will install at l/e when finalise.
What problem are you trying to address?
 

DimitrisG

Banned
Joined
Aug 5, 2018
Messages
523
Motherboard
Dell 5570-Clover
CPU
i5-8250U
Graphics
UHD 620, 1920x1080
I understand your question , but there is a catch ... actually two :
1) To not see a problem , doesn't mean that there isn't one. Especially if you are a noob like me. So , I'm asking the experts to see if there is something wrong with my configuration. I totally respect the fact that this requires more time and effort. And I'm more than lucky to have all here helping me.
2) Even if there is no problem , doesn't mean that the system works as well as it could. There is always room for correction and again that requires expert knowledge.

For example , something I noticed just now , there are two EC entries at my ioreg. I quess there should be only one...
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,974
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I noticed just now , there are two EC entries at my ioreg. I quess there should be only one...
I only see one EC entry in your ioreg.
Where do you see the second?
 

DimitrisG

Banned
Joined
Aug 5, 2018
Messages
523
Motherboard
Dell 5570-Clover
CPU
i5-8250U
Graphics
UHD 620, 1920x1080
Sorry , I mean two entries under EC.

And backlight doesn't work as it should. There is a slider which works but there is no automatic dim when on battery and full brightness when connecting power cord.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,974
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Sorry , I mean two entries under EC.
Normal/expected.

And backlight doesn't work as it should. There is a slider which works but there is no automatic dim when on battery and full brightness when connecting power cord.
Perhaps the system is not detecting AC properly due to incorrect ACPI patching.
One thing is obvious... you didn't patch for Mutex with non-zero SyncLevel.
Easy hotpatch way is to set config.plist/ACPI/Fixes/FixMutex=true
 

DimitrisG

Banned
Joined
Aug 5, 2018
Messages
523
Motherboard
Dell 5570-Clover
CPU
i5-8250U
Graphics
UHD 620, 1920x1080
No ,I have it already.
Will try with mutex option in clover.

Does anyone see anyting wrong (maybe something not needed) with my hotpatch ?

This is my first time I try acpi hotpatch and the guide is way too complicated (even more for someone not speaking native English). So , I need your help. Again ...
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,974
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
No ,I have it already.
Will try with mutex option in clover.

Does anyone see anyting wrong (maybe something not needed) with my hotpatch ?

This is my first time I try acpi hotpatch and the guide is way too complicated (even more for someone not speaking native English). So , I need your help. Again ...
It really depends on what bugs your testing has exposed.

As for hotpatch, novices should start with static patch, get everything working to satisfaction, then transition each patch to hotpatch one at a time.
 
Top