Contribute
Register

Focusrite Scarlett 18i20 Interface audio clicks & pops (7/8/9 Series Motherboards)

Joined
May 9, 2014
Messages
12
Motherboard
GA-Z87X-UD7 TH
CPU
i7-4770k
Graphics
GT 640
Mac
Classic Mac
Mobile Phone
Hello everyone.
A few days ago I bought a Scarlett 18i20 USB interface and start using it I noticed that problem of clicks and pops (every 12 seconds in my case) when recording, listening to music, Youtube videos ... anyway.
I did everything recommended in the manufacturer's support forums and even I contacted them via email, where they recommended me to a system upgrade (I have Mavericks 10.9.3)... But nothing worked.
Then I noticed that all my USB ports appear as USB 3.0, also my PCI card that is USB 2.0 ports. That was the problem...
I had installed the GenericUSBXHCI.kext because my computer freeze without it, but that kext caused a strange behavior in USB ports.

How to know if this is your case?
Connect any USB 2.0 device to a port of the same feature and go to: ()About This Mac> More Info...> System Report... > USB.
If your device appears in USB 3.0 Hub, you're probably in the same situation.

I don't want to extend more explanation ... I will show the procedure. But before all I want to tremendously thank all creators of www.tonymacx86.com because without them I could not have this. I also want to apologize if I gave misuse their installers (really had no choice and was the only thing that occurred to me to resolve my situation).

Process
<If you have the possibility to make a backup of your drive... do it (just in case)>
<Leaves OFF all the time your Scarlett interface>

1. Remove GenericUSBXHCI.kext:

-
Go to: /System/Library/Extensions and move to trash the GenericUSBXHCI.kext.
GenericUSB.png

- Show hidden files (if you don't know how to do that, look this link:
http://www.tonymacx86.com/threads/how-to-show-hidden-files-in-finder.104464/)

- Go to:
HD/usr/local/bin and move to trash the xhcdump file.

DumpFile.png

- Re-hide all hidden files.

2. Get the correct kext archieves:
<I did it that way because when I tried to install only the 7/8/9 USB Support from Multibeast it failed>:crazy:

- Download Multibeast - El Capitan 8.2.2 (http://www.tonymacx86.com/resources/multibeast-el-capitan-8-2-2.318/).

- Download any application that allows you to explore within installers or packages (I used Pacifist) and open it.

- Right click on Multibeast and select Show Package Contents.

Right click Multibeast.png

- Now inside go to: Contents/Resources/ and localize the FakePCIID-v1.2.4.pkg.

FakePCIID Localize.png

- Open that file with your App to explore inside it (if you're using Pacifist just drag it).

Drag FakePCIID PACIFIST.png

- Inside you'll see two
kext archieves that you have drag to your desktop (put your administrator password if is necessary).

Inside FakePCIID.png

- Then you have to do the same thing with FakeSMC-v6.18-313-g671f31c.1707.pkg (look in pkg and drag to desktop the FakeSMC.kext that it is inside).

FakeSMC-v6.png


... Now you have three kext to install (FakeSMC.kext, FakePCIID.kext and FakePCIID_XHCIMux.kext) ...
3. Install the three kext:

For this step you have to have a tool for put kext archieves correctly, like KextBeast <download it from: http://www.tonymacx86.com/resources/kextbeast-2-0-1.310/> (I did it with Kext Utility because I already had it installed in my computer).

- Go to: /System/Library/Extensions and localize the FakeSMC.kext (you will put the same kext but newer version in a moment) and move it to trash.

FakeSMC_DELETE.png

- Open your kext app, put your administrator password and let it work (in the case with Kext Utility... in the case with
KextBeast, please read the instructions).

- When it's done, drag the three kext obtained anteriorilly... let it work again and when it's done (again), click Quit.


KEXT DRAG.png

Finally and just in case, go to:
Applications/Utilities/ and open the Disk Utility. Then click on your system's partition(*1*), carefully and click Repair Disk Permissions(*2*). When finish it, reboot and be happy(*3*).:clap::D:headbang:

Disk U.png



Good health 2 all!!




<Excuse me for my bad English>
 

Attachments

Last edited:
Top