Contribute
Register

Flicker and lag in Intel HD2000 using el capitan

Joined
Feb 7, 2016
Messages
4
Motherboard
GA H61M-S2PV rev 2.2
CPU
intel core i3 2130 @ 3.4ghz
Graphics
onboard intel HD2000
Mac
Classic Mac
Mobile Phone
hi.

i installed el capitan with clover, after that i use multibeast uefi and add my audio and worked including my ethernet.
the problem is in video performance. after login screen and enter mac desktop, comes flickering in the graphics and disappear.
when i use launchpad is really laggy, in safari when i open website that includes many animation the display is flickering.

hope this explain my error.

thx

P.S
this is from system information in display section

Intel HD Graphics 2000:


Chipset Model: Intel HD Graphics 2000
Type: GPU
Bus: Built-In
VRAM (Dynamic, Max): 512 MB
Vendor: Intel (0x8086)
Device ID: 0x0126
Revision ID: 0x0009
Displays:
S19C170:
Resolution: 1366 x 768 @ 60 Hz
Pixel Depth: 32-Bit Color (ARGB8888)
Display Serial Number: HYCF301964
Main Display: Yes
Mirror: Off
Online: Yes
Rotation: Supported
Television: Yes

 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,929
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
hi.

i installed el capitan with clover, after that i use multibeast uefi and add my audio and worked including my ethernet.
the problem is in video performance. after login screen and enter mac desktop, comes flickering in the graphics and disappear.
when i use launchpad is really laggy, in safari when i open website that includes many animation the display is flickering.

hope this explain my error.

thx

P.S
this is from system information in display section

Intel HD Graphics 2000:


Chipset Model: Intel HD Graphics 2000
Type: GPU
Bus: Built-In
VRAM (Dynamic, Max): 512 MB
Vendor: Intel (0x8086)
Device ID: 0x0126
Revision ID: 0x0009
Displays:
S19C170:
Resolution: 1366 x 768 @ 60 Hz
Pixel Depth: 32-Bit Color (ARGB8888)
Display Serial Number: HYCF301964
Main Display: Yes
Mirror: Off
Online: Yes
Rotation: Supported
Television: Yes

What CPU do you have? Please fill out your profile as required by the rules.
 
Joined
Feb 7, 2016
Messages
4
Motherboard
GA H61M-S2PV rev 2.2
CPU
intel core i3 2130 @ 3.4ghz
Graphics
onboard intel HD2000
Mac
Classic Mac
Mobile Phone
sorry. done

its GA H61M-S2PV rev 2.2
intel core i3 2130 @ 3.4ghz
memory 8gb
 
Joined
Feb 7, 2016
Messages
4
Motherboard
GA H61M-S2PV rev 2.2
CPU
intel core i3 2130 @ 3.4ghz
Graphics
onboard intel HD2000
Mac
Classic Mac
Mobile Phone
which boot flags are you using?
  1. boot with clover with default bootflag dart=0, but failed to enter installation screen (fixed by using DVI-D port) and this solved.
  2. after installing el capitan and try to boot from flashdrive, stuck in the half loading in apple logo.solved by using bootlflag -s -v , and entering :
    1. mount -uw /
    2. cd /System/Library/Extensions
    3. mkdir Intel_back
    4. mv AppleIntelHD* AppleIntelF* Intel_back/
    5. touch ../Extensions
    6. reboot
  3. Now i can enter setup mac screen and successfully boot into the HD where the mac reside.
  4. After that i install clover EFI
  5. install costumac essential
  6. open clover configuration, choose SMBIOS mac 3,1 and grphics->inject intel
  7. My audio didnt run, using multibeast to enable that( in multibeast i'm using UEFI installation and choose proper audio driver)
  8. still my graphics still flicker when i open website that lot of flash, vlc didnt show video (only sound) and really laggy when browse launchpad.
  9. thats all. hope that's help

sakib, are u using intel hd 2000 too?
 
Joined
Feb 7, 2016
Messages
4
Motherboard
GA H61M-S2PV rev 2.2
CPU
intel core i3 2130 @ 3.4ghz
Graphics
onboard intel HD2000
Mac
Classic Mac
Mobile Phone
so there's no workaround for enabling the graphic accelerator (qe/ci) in intel HD 2000?
 
Joined
Jun 17, 2011
Messages
44
Motherboard
GA-Z370M-DS3H-F4
CPU
i5 8400 2.8 GHz
Graphics
Intel HD 630
Mobile Phone
iOS
  1. boot with clover with default bootflag dart=0, but failed to enter installation screen (fixed by using DVI-D port) and this solved.
  2. after installing el capitan and try to boot from flashdrive, stuck in the half loading in apple logo.solved by using bootlflag -s -v , and entering :
    1. mount -uw /
    2. cd /System/Library/Extensions
    3. mkdir Intel_back
    4. mv AppleIntelHD* AppleIntelF* Intel_back/
    5. touch ../Extensions
    6. reboot

Thanks! This really helped me. I had installed El Capitan on my Sandy Bridge build, then my video card died and I had to use only HD 2000 graphics. This got me back up and running. Some slow drawing but the machine is usable for now.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,929
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Could you point me towards a guide to do that? I searched a lot but only came up with a Chinese website that would emulate HD 3000 somehow to make 2000 (kinda) work
CI works with FakeID/IntelGFX=0x01168086. Still worthless without QE.
 
Top