Contribute
Register

Fixing iCloud Login Issues

Joined
Dec 11, 2012
Messages
8
Motherboard
Gigabyte Z97M-D3H
CPU
Core i7 4790K
Graphics
EVGA GeForce GTX 950
Mac
Classic Mac
Mobile Phone
Android
When I first got my build up and running last night I was unable to login to iCloud and would only receive the message "unable to login at this time".

So I saw many threads, most of which were 5 pages long with numerous fix options that worked for some and didn't for others. I thought it would be a good idea to explain the simple fix that worked for me that isn't buried in a 5 page thread so others might find this solution a bit easier than reading through those threads and that is tagged as being a more recent fix.

Thanks to ULI2000 and mochemenagen for your threads that helped me hunt down the problem. You guys kept me from pulling out what hair I have left.

For me the solution was simple.


1. I went into network under system preferences and deleted my all connections.

2. Rebooted and then reinstalled the network drivers from Multi-Beast.

3. Rebooted again and added the connections I wanted manually. (For me it was LAN and Wifi)

4. Rebooted again. Now all is working and I can login to iCloud.

As an FYI under System Information/Network, Ethernet is first with en0 and wifi is second with en1. Both are set to "automatic" in network settings.

This may or may not work for others but it's what worked for me. Below are my system specs incase you may have a similar build.

Mavericks 10.9.4
Gigabyte GA-H87M-HD3

Intel i7 4790
EVGA GeForce GT 740 2GB DDR3
TP-Link TL-WDN4800 Wireless Card
Crucial Ballistix Sport 8GB (4GB x2) DDR3 Memory
 
Top