Fixing HDMI Audio with GTX 1050

Discussion in 'HDMI Audio' started by cervinakuymc, Sep 23, 2017.

  1. cervinakuymc

    cervinakuymc

    Joined:
    Sep 2, 2017
    Messages:
    40
    CPU:
    Intel Pentium G4560 Kaby Lake
    Graphics:
    Gigabyte GTX 1050 TI
    Mac:
    MacBook Air, Mac mini
    Sep 23, 2017 at 8:18 AM #1
    cervinakuymc

    cervinakuymc

    Joined:
    Sep 2, 2017
    Messages:
    40
    CPU:
    Intel Pentium G4560 Kaby Lake
    Graphics:
    Gigabyte GTX 1050 TI
    Mac:
    MacBook Air, Mac mini
    Hello everyone,

    So I have a Gigabyte GTX 1050 for my Graphics, and I have the HDMI cable from my monitor into my GPU plugged in.

    In the section of "About my Mac", it does register the GPU, though.

    I have tried numerous different solutions from across the web, and none have worked for me. I have tried installing the Realtek ALC887 Audio Codec using MultiBeast, using various different Kext Utilities, and even trying Voodoo HDA at some point. Apparently, my motherboard is supposed to support the Realtek ALC887 Audio Codec, but it did not work.

    I am not sure if I should take a different approach based on my motherboard and/or graphics card.

    Any help would be appreciated, here is some relevant information regarding my build:

    Motherboard: ASRock H110M-HDS
    CPU: Pentium G4560 Kaby Lake
    GPU: GeForce Gigabyte GTX 1050

    Thanks,
    - Cervinakuy
     
  2. toleda

    toleda Moderator

    Joined:
    May 20, 2010
    Messages:
    21,196
    Mobo:
    Asus Maximus VII Impact
    CPU:
    Core i7-4770K
    Graphics:
    HD7750 + HD4600
    Mac:
    iMac, MacBook Pro, Mac mini
    Classic Mac:
    512K, LC, Power Mac
    Mobile Phone:
    iOS
    Sep 24, 2017 at 12:34 AM #2
    toleda

    toleda Moderator

    Joined:
    May 20, 2010
    Messages:
    21,196
    Mobo:
    Asus Maximus VII Impact
    CPU:
    Core i7-4770K
    Graphics:
    HD7750 + HD4600
    Mac:
    iMac, MacBook Pro, Mac mini
    Classic Mac:
    512K, LC, Power Mac
    Mobile Phone:
    iOS
    887: Realtek ALC AppleHDA/Post #1/Recommendations
    1050: HDMI Audio AppleHDA/cloverHDMI, note Nvidia/Pascal HDMI audio does not work on the HDMI connector with the current web driver; DP and/or DVI connector may work.
     
  3. cervinakuymc

    cervinakuymc

    Joined:
    Sep 2, 2017
    Messages:
    40
    CPU:
    Intel Pentium G4560 Kaby Lake
    Graphics:
    Gigabyte GTX 1050 TI
    Mac:
    MacBook Air, Mac mini
    Sep 24, 2017 at 1:11 AM #3
    cervinakuymc

    cervinakuymc

    Joined:
    Sep 2, 2017
    Messages:
    40
    CPU:
    Intel Pentium G4560 Kaby Lake
    Graphics:
    Gigabyte GTX 1050 TI
    Mac:
    MacBook Air, Mac mini
    On the ASRock page about my motherboard, it says the audio codec is ALC887, however MultiBeast displays only two of these that are similar:
    • ALC887/888b Legacy
    • ALC887/888b
    In my case, which would I select?


    As for your second method, I am given the following when using the command script:
    Code (Text):
    File: audio_cloverHDMI-120.command_v1.0d
    Release Mode
    EFI partition is mounted
    Error: no IOReg/HDEF; BIOS/audio/disabled or ACPI problem
    Continue without HDEF/onboard audio (y/n):

    Also, just as a side-note question, in my BIOS, should I enable/disable/auto High Definition audio?
     
  4. toleda

    toleda Moderator

    Joined:
    May 20, 2010
    Messages:
    21,196
    Mobo:
    Asus Maximus VII Impact
    CPU:
    Core i7-4770K
    Graphics:
    HD7750 + HD4600
    Mac:
    iMac, MacBook Pro, Mac mini
    Classic Mac:
    512K, LC, Power Mac
    Mobile Phone:
    iOS
    Sep 24, 2017 at 1:58 AM #4
    toleda

    toleda Moderator

    Joined:
    May 20, 2010
    Messages:
    21,196
    Mobo:
    Asus Maximus VII Impact
    CPU:
    Core i7-4770K
    Graphics:
    HD7750 + HD4600
    Mac:
    iMac, MacBook Pro, Mac mini
    Classic Mac:
    512K, LC, Power Mac
    Mobile Phone:
    iOS
    ALC887/888b
    No native macOS audio support on Kaby Lake, run MultiBeast:
    ALC887/888b
    100/200 Series Audio

    See Quick Fix: 200 Series/Kaby Lake Audio and install one method.

    Restart, verify 887 audio
    Run cloverHDMI
     
  5. cervinakuymc

    cervinakuymc

    Joined:
    Sep 2, 2017
    Messages:
    40
    CPU:
    Intel Pentium G4560 Kaby Lake
    Graphics:
    Gigabyte GTX 1050 TI
    Mac:
    MacBook Air, Mac mini
    Sep 24, 2017 at 3:01 AM #5
    cervinakuymc

    cervinakuymc

    Joined:
    Sep 2, 2017
    Messages:
    40
    CPU:
    Intel Pentium G4560 Kaby Lake
    Graphics:
    Gigabyte GTX 1050 TI
    Mac:
    MacBook Air, Mac mini
    Alright, I have done exactly as you have told me, and I have somewhat fixed the problem. Now, when I enter settings, three options appear under "Play sound effects through: ", whereas before I had none that showed up.

    These three options are Internal Speakers, Line Out, Digital Out. I have tried all three, however it doesn't seem like any sound is coming out.

    EDIT: It does kind of work actually. I plugged in some headphones, and then some external speakers, and those worked. However, I'm still trying to get the sound to come out of my monitor via the HDMI plugged into the GPU.
     
    Last edited: Sep 24, 2017
  6. toleda

    toleda Moderator

    Joined:
    May 20, 2010
    Messages:
    21,196
    Mobo:
    Asus Maximus VII Impact
    CPU:
    Core i7-4770K
    Graphics:
    HD7750 + HD4600
    Mac:
    iMac, MacBook Pro, Mac mini
    Classic Mac:
    512K, LC, Power Mac
    Mobile Phone:
    iOS
    Sep 24, 2017 at 3:42 AM #6
    toleda

    toleda Moderator

    Joined:
    May 20, 2010
    Messages:
    21,196
    Mobo:
    Asus Maximus VII Impact
    CPU:
    Core i7-4770K
    Graphics:
    HD7750 + HD4600
    Mac:
    iMac, MacBook Pro, Mac mini
    Classic Mac:
    512K, LC, Power Mac
    Mobile Phone:
    iOS
    cloverHDMI?????
    Attach ouput
     
  7. cervinakuymc

    cervinakuymc

    Joined:
    Sep 2, 2017
    Messages:
    40
    CPU:
    Intel Pentium G4560 Kaby Lake
    Graphics:
    Gigabyte GTX 1050 TI
    Mac:
    MacBook Air, Mac mini
    Sep 24, 2017 at 3:45 AM #7
    cervinakuymc

    cervinakuymc

    Joined:
    Sep 2, 2017
    Messages:
    40
    CPU:
    Intel Pentium G4560 Kaby Lake
    Graphics:
    Gigabyte GTX 1050 TI
    Mac:
    MacBook Air, Mac mini
    Last login: Sat Sep 23 18:55:08 on ttys001

    iMac:~ mich$ /Users/mich/Downloads/audio_cloverHDMI-120_v1.0d.command ; exit;


    Agreement

    The audio_cloverHDMI script is for personal use only. Do not distribute

    the patch, any or all of the files for any reason without permission.

    The audio_cloverHDMI script is provided as is and without any warranty.


    File: audio_cloverHDMI-120.command_v1.0d

    Release Mode

    EFI partition is mounted

    No HDMI audio codec(s) detected, continue (y/n): y

    HDMI audio codec(s)

    Integrated Graphics is not installed/enabled

    Install AMD/Nvidia HDMI audio (y/n): y

    Nvidia discrete graphics card 10de1c81 found on PEG0@1/PEGP@0

    Nvidia HDMI audio is not enabled

    Install Nvidia HDMI audio ssdt (y/n): y

    Download SSDT-HDMI-NVIDIA-PEG0 ...

    Password:

    % Total % Received % Xferd Average Speed Time Time Time Current

    Dload Upload Total Spent Left Speed

    100 44888 100 44888 0 0 203k 0 --:--:-- --:--:-- --:--:-- 204k

    /Volumes/EFI/EFI/CLOVER/ACPI/patched/SSDT-HDMI-NVIDIA-PEG0.aml installed



    Install finished, restart required.

    To save a Copy of this Terminal session: Terminal/Shell/Export Text As ...

    logout

    Saving session...

    ...copying shared history...

    ...saving history...truncating history files...

    ...completed.



    [Process completed]
     
  8. toleda

    toleda Moderator

    Joined:
    May 20, 2010
    Messages:
    21,196
    Mobo:
    Asus Maximus VII Impact
    CPU:
    Core i7-4770K
    Graphics:
    HD7750 + HD4600
    Mac:
    iMac, MacBook Pro, Mac mini
    Classic Mac:
    512K, LC, Power Mac
    Mobile Phone:
    iOS
    Sep 24, 2017 at 4:20 PM #8
    toleda

    toleda Moderator

    Joined:
    May 20, 2010
    Messages:
    21,196
    Mobo:
    Asus Maximus VII Impact
    CPU:
    Core i7-4770K
    Graphics:
    HD7750 + HD4600
    Mac:
    iMac, MacBook Pro, Mac mini
    Classic Mac:
    512K, LC, Power Mac
    Mobile Phone:
    iOS
    See Post #2/1050.
     
  9. cervinakuymc

    cervinakuymc

    Joined:
    Sep 2, 2017
    Messages:
    40
    CPU:
    Intel Pentium G4560 Kaby Lake
    Graphics:
    Gigabyte GTX 1050 TI
    Mac:
    MacBook Air, Mac mini
    Sep 24, 2017 at 6:43 PM #9
    cervinakuymc

    cervinakuymc

    Joined:
    Sep 2, 2017
    Messages:
    40
    CPU:
    Intel Pentium G4560 Kaby Lake
    Graphics:
    Gigabyte GTX 1050 TI
    Mac:
    MacBook Air, Mac mini
    I apologize for asking this if its a dumb question, but from what thread? So far 3 threads have been listed in this discussion.
     
  10. elliotcz97

    elliotcz97

    Joined:
    Aug 28, 2017
    Messages:
    8
    Mobo:
    GA-H270-Gaming 3
    CPU:
    Intel i5-7500
    Graphics:
    GTX 1060 3GB
    Mac:
    MacBook Pro
    Mobile Phone:
    iOS
    Sep 24, 2017 at 7:26 PM #10
    elliotcz97

    elliotcz97

    Joined:
    Aug 28, 2017
    Messages:
    8
    Mobo:
    GA-H270-Gaming 3
    CPU:
    Intel i5-7500
    Graphics:
    GTX 1060 3GB
    Mac:
    MacBook Pro
    Mobile Phone:
    iOS
    from this one ;)
     
    cervinakuymc likes this.

Share This Page