Contribute
Register

[Fix] Resolve boot screen garble

Joined
Sep 5, 2011
Messages
407
Motherboard
Lenovo T440s
CPU
i5-4200u
Graphics
HD4400
i see no HDMI Audio Patch applied(HDMI Audio Port) into Kernel and Kext Patches section,i assume that's where the issue is supposed to come from (if they are latest files uploaded) :

For example my L440 uses this patch:

Name: AppleIntelFramebufferAzul
Find: 01050900 00040000 87000000
Replace: 01051200 00080000 87000000
Comment: HDMI-audio, port 0105(12), 0x0a260005 0x0a260006, 0x0d220003, 0x0a2e000a, 0x0a26000a

You can find them/they are already present on @RehabMan Laptop Clover Config Files on his Github.
Check the HD4200_4400_4600_config.plist, you will find them there.
Well it's my understanding that we shouldn't need that, since my MiniDP port is already on 00 04 00 00.

What's odd is that the hot plug issue goes away when I toggle mirror/extend mode for the display. Then it will "remember" my last setting and it won't occur anymore.

I suppose I could try that patch, except exclude the override from HDMI to MiniDP.

@RehabMan , any thoughts? Also do I need to redo my SSDT files since they changed for some reason?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,408
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Well it's my understanding that we shouldn't need that, since my MiniDP port is already on 00 04 00 00.

What's odd is that the hot plug issue goes away when I toggle mirror/extend mode for the display. Then it will "remember" my last setting and it won't occur anymore.

I suppose I could try that patch, except exclude the override from HDMI to MiniDP.

@RehabMan , any thoughts? Also do I need to redo my SSDT files since they changed for some reason?
This discussion seems off-topic for this thread.
Open a separate thread.

Read FAQ, "Problem Reporting"
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Joined
Sep 5, 2011
Messages
407
Motherboard
Lenovo T440s
CPU
i5-4200u
Graphics
HD4400
This discussion seems off-topic for this thread.
Open a separate thread.

Read FAQ, "Problem Reporting"
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
I made a new thread about the SSDT discussion: https://www.tonymacx86.com/threads/ssdt-dump-change-from-el-capitan-to-sierra.229841/

In regards to the screen garble/glitch, am I correct in understanding that I do not need the frame buffer patch since my machine is already using the correct port by default? Audio and output works fine, it's just my internal display that appears to react oddly sometimes when I connect.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,408
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I made a new thread about the SSDT discussion: https://www.tonymacx86.com/threads/ssdt-dump-change-from-el-capitan-to-sierra.229841/

In regards to the screen garble/glitch, am I correct in understanding that I do not need the frame buffer patch since my machine is already using the correct port by default? Audio and output works fine, it's just my internal display that appears to react oddly sometimes when I connect.
This thread addresses only the short lived boot-time glitch.
 
Joined
Sep 5, 2011
Messages
407
Motherboard
Lenovo T440s
CPU
i5-4200u
Graphics
HD4400
This thread addresses only the short lived boot-time glitch.
I wasn't sure which thread made sense, since my HDMI audio is working perfectly. Maybe the HD4400 graphics thread?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,408
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I wasn't sure which thread made sense, since my HDMI audio is working perfectly. Maybe the HD4400 graphics thread?
Best to open a separate thread.
With "Problem Reporting" files.
And don't forget to fill out your profile as per FAQ.
 
Joined
Mar 24, 2016
Messages
67
Motherboard
Lenovo Ideapad 510-15ISK
CPU
i5-6200u
Graphics
Intel HD 520, Nvidia 940MX 1920x1080
Mac
MacBook Pro
Mobile Phone
Android
Is there an any solution for High Sierra boot graphics glitch? This patch stopped working on 10.13. I also tried patch from post 1 which is no luck.

Code:
Name:  Boot graphics glitch, 10.12.dp1
Find : 01000075 25
Replace : 010000eb 25
Match OS :10.12.x
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,408
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Top