Contribute
Register

[Fix] Resolve boot screen garble

Joined
Mar 10, 2017
Messages
184
Motherboard
Asus Laptop ASUS GL752VW-T4183D chipset 100/C230 series
CPU
Core i7-6700HQ
Graphics
Intel HD530 & Geforce GTX 960M (4GB)
Mac
MacBook Pro
Mobile Phone
Android
I getting same issue and I look in my BIOS and CMS enabled just then I add patch glitch is little bit better not so big but it is :/
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I getting same issue and I look in my BIOS and CMS enabled just then I add patch glitch is little bit better not so big but it is :/
It is quite clear in post #1.
The guide does not state that the glitch is eliminated entirely...

This patch, ... will lessen the severity.
Note: The comment you have attached to your patch is misleading (wrong version in comment).
 
Joined
Mar 24, 2017
Messages
55
Motherboard
Asus Z170-K
CPU
Intel Core i7-6700
Graphics
nVidia GeForce GTX 1060 6 GB
Mobile Phone
Android, iOS
I getting same issue and I look in my BIOS and CMS enabled just then I add patch glitch is little bit better not so big but it is :/
I fixed this issue using Clover Configurator: I opened Clover Configurator, Mounted EFI partion, open partizione and opened config.plist with clover configurator, I went in install Drivers and I clicked on CsmVideoDxe and rebooted
 
Joined
Mar 10, 2017
Messages
184
Motherboard
Asus Laptop ASUS GL752VW-T4183D chipset 100/C230 series
CPU
Core i7-6700HQ
Graphics
Intel HD530 & Geforce GTX 960M (4GB)
Mac
MacBook Pro
Mobile Phone
Android
I fixed this issue using Clover Configurator: I opened Clover Configurator, Mounted EFI partion, open partizione and opened config.plist with clover configurator, I went in install Drivers and I clicked on CsmVideoDxe and rebooted
thx man I try it more better but glitch is now in clover :D and then apple loading it 2 times comes black mirror without apple logo...
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I fixed this issue using Clover Configurator: I opened Clover Configurator, Mounted EFI partion, open partizione and opened config.plist with clover configurator, I went in install Drivers and I clicked on CsmVideoDxe and rebooted
thx man I try it more better but glitch is now in clover :D and then apple loading it 2 times comes black mirror without apple logo...
For most cases, CsmVideoDxe does not solve problems... mostly causes them.
 
Joined
Sep 5, 2011
Messages
432
Motherboard
Lenovo T440s
CPU
i5-4200u
Graphics
HD4400
@RehabMan - I've recently updated my machine (Lenovo T440s) to Sierra 10.12.6 without many issues. You've already helped me with one of my issues in another thread (brightness keys). Thanks for that.

However, I'm noticing a new issue that I'm wondering if there is a solution. When I plug in an external display with the Mini DisplayPort cable, the external display connects as expected (with audio, if supported) however my internal display turns into a garbled mess (the same garble I see for a second during boot). My internal display is normally in it's native resolution 1920x1080

I can fix this issue without shutting down my machine by switching my resolution to another 16:9 resolution that is LOWER than my native. i.e. if I switch to 1600x900, the display "comes back" I can even switch back to 1920x1080 at that point. For now, I keep RDM.app running since I'm able to carefully pick the resolution even when it's garbled.

Is this a side affect I'll have to just deal with, or is there a solution? I've uploaded my problem reporting files.
Code:
   13    2 0xffffff7f82f2c000 0x66000    0x66000    com.apple.driver.AppleACPIPlatform (5.0) 65E05472-6AE7-3308-8CC8-FA6CB0DB2AEE <12 11 7 6 5 4 3 1>
josh-lenovo:~ joshuaseltzer$ kextstat|grep -y appleintelcpu
josh-lenovo:~ joshuaseltzer$ kextstat|grep -y applelpc
   97    0 0xffffff7f829e7000 0x3000     0x3000     com.apple.driver.AppleLPC (3.1) F51595F0-F9B1-3B85-A1C3-F984DAD4107E <96 12 5 4 3>
Code:
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext VoodooPS2Trackpad.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext VoodooPS2Mouse.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext VoodooPS2Keyboard.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext VoodooPS2Controller.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext USBInjectAll.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext Shiki.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext Lilu.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext IntelMausiEthernet.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext IntelGraphicsFixup.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakeSMC.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakePCIID_Intel_HD_Graphics.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakePCIID_Broadcom_WiFi.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakePCIID.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext CPUSensors.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext CodecCommander.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext BrcmPatchRAM2.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext BrcmFirmwareRepo.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext AppleBacklightInjector.kext
kext-dev-mode allowing invalid signature -67030 0xFFFFFFFFFFFEFA2A for kext ALC292.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext ACPIBatteryManager.kext
KernelCache ID: 617887D228D1EC855A458D7C148023B2
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,259
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
@RehabMan - I've recently updated my machine (Lenovo T440s) to Sierra 10.12.6 without many issues. You've already helped me with one of my issues in another thread (brightness keys). Thanks for that.

However, I'm noticing a new issue that I'm wondering if there is a solution. When I plug in an external display with the Mini DisplayPort cable, the external display connects as expected (with audio, if supported) however my internal display turns into a garbled mess (the same garble I see for a second during boot). My internal display is normally in it's native resolution 1920x1080

I can fix this issue without shutting down my machine by switching my resolution to another 16:9 resolution that is LOWER than my native. i.e. if I switch to 1600x900, the display "comes back" I can even switch back to 1920x1080 at that point. For now, I keep RDM.app running since I'm able to carefully pick the resolution even when it's garbled.

Is this a side affect I'll have to just deal with, or is there a solution? I've uploaded my problem reporting files.
Code:
   13    2 0xffffff7f82f2c000 0x66000    0x66000    com.apple.driver.AppleACPIPlatform (5.0) 65E05472-6AE7-3308-8CC8-FA6CB0DB2AEE <12 11 7 6 5 4 3 1>
josh-lenovo:~ joshuaseltzer$ kextstat|grep -y appleintelcpu
josh-lenovo:~ joshuaseltzer$ kextstat|grep -y applelpc
   97    0 0xffffff7f829e7000 0x3000     0x3000     com.apple.driver.AppleLPC (3.1) F51595F0-F9B1-3B85-A1C3-F984DAD4107E <96 12 5 4 3>
Code:
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext VoodooPS2Trackpad.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext VoodooPS2Mouse.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext VoodooPS2Keyboard.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext VoodooPS2Controller.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext USBInjectAll.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext Shiki.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext Lilu.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext IntelMausiEthernet.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext IntelGraphicsFixup.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakeSMC.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakePCIID_Intel_HD_Graphics.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakePCIID_Broadcom_WiFi.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakePCIID.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext CPUSensors.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext CodecCommander.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext BrcmPatchRAM2.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext BrcmFirmwareRepo.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext AppleBacklightInjector.kext
kext-dev-mode allowing invalid signature -67030 0xFFFFFFFFFFFEFA2A for kext ALC292.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext ACPIBatteryManager.kext
KernelCache ID: 617887D228D1EC855A458D7C148023B2
ACPI/origin files are too old to compare against ACPI/patched.
You forgot to press F4 in Clover prior to collecting EFI/Clover.
 
Joined
Sep 5, 2011
Messages
432
Motherboard
Lenovo T440s
CPU
i5-4200u
Graphics
HD4400
ACPI/origin files are too old to compare against ACPI/patched.
You forgot to press F4 in Clover prior to collecting EFI/Clover.
They are from my El Capitan install, do they need to be re-collected (and recompiled) for Sierra?

I just re-collected them by pressing F4 and attached them here.
 

Attachments

Sniki

Moderator
Joined
Jan 5, 2016
Messages
1,593
Motherboard
Lenovo V330 - 15IKB
CPU
i5-8250U
Graphics
UHD 620 /1920x1080
Mobile Phone
iOS
i see no HDMI Audio Patch applied(HDMI Audio Port) into Kernel and Kext Patches section,i assume that's where the issue is supposed to come from (if they are latest files uploaded) :

For example my L440 uses this patch:

Name: AppleIntelFramebufferAzul
Find: 01050900 00040000 87000000
Replace: 01051200 00080000 87000000
Comment: HDMI-audio, port 0105(12), 0x0a260005 0x0a260006, 0x0d220003, 0x0a2e000a, 0x0a26000a

You can find them/they are already present on @RehabMan Laptop Clover Config Files on his Github.
Check the HD4200_4400_4600_config.plist, you will find them there.
 
Top