Contribute
Register

Fix incorrect time in Windows + OSX dual boot

Joined
Sep 23, 2016
Messages
42
Motherboard
Gigabyte Z170N Gaming 5
CPU
i7 6700k @ 4.5
Graphics
MSI 1080 Gaming X
it worked! thanks :)
 
Joined
Sep 1, 2016
Messages
334
Motherboard
GA-Z170N Gaming 5
CPU
i7-6700K
Graphics
RX 580
Thanks... I downloaded your zip file from Post #1 and ran it in Windows. It said that it was successful, but when I rebooted, the BIOS clock was once again four hours ahead. I reset it, booted into Windows, and the Windows clock was wrong. I synced it to the server, but still got the browser security certificate errors. Now I'm in a loop between resetting the BIOS clock and updating it in Windows. I also have to reset the clock in Sierra. Is there something I'm missing? I can't browse in either OS.
 
Joined
Apr 23, 2017
Messages
1
Motherboard
ASUS
CPU
Intel
Graphics
NVIDIA
I'm still having issues with my ASUS Z170-A with macOS / Windows 10 dual boot.

I'm gonna try to describe what is happening and what I have done.

- If I set my BIOS time to the correct time let's say 13:20 (1:20pm) and boot Windows everything works fine, Windows and the BIOS time are in sync and nothing change.
- If I boot macOS the system get the correct time 13:20 but change the BIOS time to 15:20 (3:20pm).
- If I reboot to Windows the will be wrong in Windows due to the BIOS time change.

I tried to fix the time applying @SwampFox82 solution with the registry and also I tried using the NetTime tool suggested by @slim.jim (separately) and these are the results:

- If I set my BIOS time to the correct time let's say 13:20 (1:20pm) and boot Windows everything works fine, Windows and the BIOS time are in sync and nothing change.
- If I boot macOS the system get the time as if were 9:20 (9:20am) so I have to reset the system time un-checking the checkbox to let macOS set the time using the Apple Time servers.
- If I reboot from macOS and check the BIOS' time this was set to 17:20 (5:20pm) by macOS making Windows to display the wrong time again if I'm using the registry fix or the correct time if I'm using the NetTool fix.

It seems this problem is being cause by macOS not Windows because the issue appears only when I boot macOS and is impossible to keep the BIOS time and the macOS time in sync.

Any help will be appreciated.
 
Joined
Apr 3, 2015
Messages
10
Motherboard
OSX Sierra
CPU
HP 6300 MT i5 3470
Graphics
Nvidia GT 1030
Mac
iMac
Mobile Phone
Android
Thankyou! You solve my problem :)
 
Joined
Oct 27, 2017
Messages
38
Motherboard
GA X99 SOC Champion
CPU
i7 6900K
Graphics
GTX 1080 Ti
Mobile Phone
Android
I've the problem with shutdown in my hackintosh, after shutdown system restart. I've applied alls fixes without fixed.
But I see now the time in bios is -1 hour than Sierra. If i put hour correctly in system macos sierra when i return in bios is -1hour. When i put correct hour in bios when i retourn in macos is +1 ! I can't fix that; this take me crazy!

Maybe this is the problem with my shutdowns - restart.....How to fix clock in bios and macos(synchronize)?

Tanks
 
Last edited:
Joined
Jan 6, 2013
Messages
113
Motherboard
GA-B75M-D3V
CPU
i7-3770
Graphics
GTX 1050 Ti
Mac
iMac
Classic Mac
Power Mac
Mobile Phone
Android
Thanks, SwampFox82. Your registry hack worked.
 
Joined
Dec 26, 2015
Messages
227
Motherboard
GA-Z97X-UD3H
CPU
i5-4690
Graphics
GTX 1050 Ti
Mobile Phone
Android
I just thought I'd give people an easy to find guide for this information. Hope the mods are alright with that, and that this doesn't violate any posting guidelines.

1. Why does this happen?


The simple explanation is; Windows uses Greenwhich time, and OSX uses Universal Time. It's as simple as that. Every time the other OS boots up - it changes around your BIOS settings in-order to 'correct' the CPU clock timer - which is essential for any computer to calculate things correctly.

2. What's the difference?

GMT


Windows is always defaulted to use GMT as the location to set the time and date. GMT stands for 'Greenwich Observatory'. This observatory broadcasts the current time of the world based on the calculations of where the Earth rotation is in relation to the prime meridian.

Because of the fact that GMT is outdated - it doesn't consider other factors that are important to calculating time - such as; where the earth is in relation to the sun. Because of this - GMT is pretty much an 'average' or an estimated guess as to what time it is where you live.

To quote the Greenwich website...


UTC

As more sophisticated time pieces became available to scientists, the need for a new international time standard became apparent. Atomic clocks did not need to keep time based on average solar time at a particular location because they were very, very accurate. In addition, it became understood that due to the irregularity of the earth and the sun's movements, the exact time needed to be modified occasionally through the use of leap seconds. With this precise accuracy of time, UTC was born.


UTC, while based on zero degrees longitude, which passes through the Greenwich Observatory, is based on atomic time and includes leap seconds as they are added to our clock every so often. UTC was used beginning in the mid-twentieth century but became the official standard of world time on January 1, 1972.


UTC is 24-hour time, which begins at 0:00 at midnight. 12:00 is noon, 13:00 is 1 p.m., 14:00 is 2 p.m. and so on until 23:59, which is 11:59 p.m.


Time zones today are a certain number of hours or hours and minutes behind or ahead of UTC. UTC is also known as Zulu time in the airforce. When European Summer Time is not in effect, UTC matches the time zone of the United Kingdom.


Today, it is most appropriate to use and refer to time based on UTC and not on GMT.

3. How do I fix this?

It's quite simple really. All you need to do is set Windows to use UTC instead of GMT. To do this - we need to perform a simple registry edit. Go perform this - hold down the 'Windows' button, and at the same time press R (Win + R) this will bring up a new window titled 'RUN'

In this window type the command 'regedit'. UAC will popup asking for admin permission. Click accept and the registry editor will open. Now that were in regedit, navigate to...



Left click on 'TimeZoneInformation' and on the left it will display all the current values attributed to this registry key. On the left right click anywhere and choose 'Create new D-WORD'. You will now see a new entry at the bottom of the list.

Right click on this new entry and choose 'Modify'. Rename the key 'RealTimeIsUniversal' and change it's value to '1'. Click save, and now the entry should say 'RealTimeIsUniversal - 0x0000001' If it looks like that - then you're all done!

Reboot, and sync the windows clock - now your time settings will be universal (no pun intended :p ).

EDIT:

If you don't like fooling around with your registry, I've created a .reg file that will do all the work for you. All you need to do is download the attachment, extract it to where ever you want, and double click on 'Windows Universal time On'

If you want to switch back to GMT. Do the same, but instead - double click on the reg file named 'Windows Universal time Off' and that will remove the registry edits we made. :thumbup:

Anyways, hope this guide helps someone! Thanks for reading everyone!! It's greatly appreciated! I'm definitely looking forward to a good tenure on this very helpful forum. :)

View attachment 94625

Worked. Thanks.
 
Joined
Sep 14, 2017
Messages
24
Motherboard
Gigabyte H270M-DS3H
CPU
Intel core i7 6700K
Graphics
PNY 1060 GTX 6Gb
Mac
MacBook Air
Mobile Phone
Android
Thanks Swampfox and Rehabman for sorting out the problem and doing the effort to make a reg file for windows.

But i'm also curious if there is a fix to be applied to macOS instead of Windows.
It would be more logical to me that my bios in my home shows me my local clock and not a GMT time.
Not that i'm hanging arround a lot in the bios but it could be confusing at some point showing the wrong time.

@swampfox, not sure what you mean with line spacing ?
But when you mean when hitting enter there is a blank line, try using shift+enter instead.
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Thanks Swampfox and Rehabman for sorting out the problem and doing the effort to make a reg file for windows.

But i'm also curious if there is a fix to be applied to macOS instead of Windows.
It would be more logical to me that my bios in my home shows me my local clock and not a GMT time.
Not that i'm hanging arround a lot in the bios but it could be confusing at some point showing the wrong time.

@swampfox, not sure what you mean with line spacing ?
But when you mean when hitting enter there is a blank line, try using shift+enter instead.
There were other hacks made for the OS X side, but they have issues.

Fixing it in Windows is the best option.
 
Top