Contribute
Register

[FIX] HD4200/HD4400/HD4600/HD5600 on 10.11+

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,061
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
This thread is pinned on that thread. It is the alternative solution link. And the title says 10.11+ so I thought it would be ok to post here.

There is already a thread/forum for 10.12 specific issues.
Let's not confuse this thread with problems that are specific to 10.12.
 
Joined
Jun 20, 2014
Messages
1,018
Motherboard
Gigabyte Aero 15X v8-BK4K4P
CPU
i7-8750H
Graphics
UHD 630 / GTX 1070
Why are you using Devices/FakeID/IntelGFX?
I only added it to see if it improved the situation. It doesn't seem to make a difference if it's there or not.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,061
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I only added it to see if it improved the situation. It doesn't seem to make a difference if it's there or not.

AFAIK, no need for FakeID with your hardware.
Purpose of FakeID is to inject a fake device-id to trick the framebuffer kext into loading...
No need when the native device-id is already in the kext Info.plist.
 
Joined
Mar 23, 2011
Messages
13
Motherboard
Dell 7737 Laptop
CPU
i7 4500U
Graphics
Intel 4400 + Nvidia 750M
Hi, I have follow the dell 7737 guide to try make this thing works but no luck for me, all works except graphics. I also try with the kexts and clover config.plist con in this thread, patching dsdt ssdt... I hope someone can help me, I attach the files, thank you in advance!

Edit: I forget my specs:


Laptop: Dell 7737
Processor: i7 at 1.8Ghz
Graphics: Intel 4400 + Nvidia 750M
 

Attachments

  • yardosioreg.ioreg
    6.3 MB · Views: 91
  • yardosclover.zip
    3.8 MB · Views: 77
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,061
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi, I have follow the dell 7737 guide to try make this thing works but no luck for me, all works except graphics. I also try with the kexts and clover config.plist con in this thread, patching dsdt ssdt... I hope someone can help me, I attach the files, thank you in advance!

Edit: I forget my specs:


Laptop: Dell 7737
Processor: i7 at 1.8Ghz
Graphics: Intel 4400 + Nvidia 750M

Your ACPI configuration is wrong.
Based on ACPI/origin, you should have in ACPI/patched:
DSDT.aml
SSDT.aml (ssdtPRgen.sh)
SSDT-0.aml
SSDT-1.aml
SSDT-2.aml
SSDT-3.aml
SSDT-7.aml
SSDT-8.aml
SSDT-9.aml

See ACPI guide linked from FAQ.
http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html
 
Joined
Mar 23, 2011
Messages
13
Motherboard
Dell 7737 Laptop
CPU
i7 4500U
Graphics
Intel 4400 + Nvidia 750M
Thanks Rehabman, but in the guide here in tonymac the post for my laptop is very confusing, I refer to this the section of DSDT patches :

Code:
Close Preferences window, click Patch button, paste the code then apply:
to_DSDT_dsl.txt.zip
click compile ;if no errors you can go to next steps ….(if not you have to fix them)
click patch again :
Rename GFX0 to IGPU
7/8-series USB
IRQ Fix
SMBUS Fix
RTC Fix
Shutdown Fix 2
HPET Fix
OS Check Fix(Windows 7/8 -test with both and choose best for you! )
AC Adapter Fix
Add MCHC
Fix _WAK arg0 2
Fix PNOT/PPNT
Add IMEI
Fix _WAK IAOE
Rename B0D3 to HDAU
USB3 _PRW(0x6D)—-to fix instant wake from sleep
Add MCHC
[battery]Dell-Inspiron-15-7xxx
may add if more…(depending on what need to be fixed/errors you have)
Click compile again, if no error you can proceed(otherwise have to fix).
Click patch again, and apply this patch(to fix brightness controlling issue ..)

All this patches goes only to DSDT.dsl? Or goes to the complete collection of files? Its tedious manual patching 10 files this way hehe
 
Joined
Mar 23, 2011
Messages
13
Motherboard
Dell 7737 Laptop
CPU
i7 4500U
Graphics
Intel 4400 + Nvidia 750M
Ok Rehabman, I do a repatching of all my patched section of ACPI, all the changes concerns igpu rename and battery of the dell in the ssdt-1 ssdt-2 and ssdt-3, and it continues give me no working ci/qe :(

I attach the new files, please, take a look, I can't understand how to solve or fix this
 

Attachments

  • yardosnewclover.zip
    3.8 MB · Views: 66
  • yardosioreg.zip
    453.6 KB · Views: 59
Joined
Mar 23, 2011
Messages
13
Motherboard
Dell 7737 Laptop
CPU
i7 4500U
Graphics
Intel 4400 + Nvidia 750M
Sh**! I thought all was working, now I connect my usb podxt soundcard and the usb doesn't work properly, I obtain 2 secs of sound and the card crashes. I think the problem is in the acpi extraction, only last one second, but clover doesn't throw any error when I tap F4 in the boot screen...

Anyone have any idea of what can be happening? :(
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,061
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Thanks Rehabman, but in the guide here in tonymac the post for my laptop is very confusing, I refer to this the section of DSDT patches :

Code:
Close Preferences window, click Patch button, paste the code then apply:
to_DSDT_dsl.txt.zip
click compile ;if no errors you can go to next steps ….(if not you have to fix them)
click patch again :
Rename GFX0 to IGPU
7/8-series USB
IRQ Fix
SMBUS Fix
RTC Fix
Shutdown Fix 2
HPET Fix
OS Check Fix(Windows 7/8 -test with both and choose best for you! )
AC Adapter Fix
Add MCHC
Fix _WAK arg0 2
Fix PNOT/PPNT
Add IMEI
Fix _WAK IAOE
Rename B0D3 to HDAU
USB3 _PRW(0x6D)—-to fix instant wake from sleep
Add MCHC
[battery]Dell-Inspiron-15-7xxx
may add if more…(depending on what need to be fixed/errors you have)
Click compile again, if no error you can proceed(otherwise have to fix).
Click patch again, and apply this patch(to fix brightness controlling issue ..)

All this patches goes only to DSDT.dsl? Or goes to the complete collection of files? Its tedious manual patching 10 files this way hehe

Renames must be applied equally to all DSDT+SSDTs that reference the symbol.
You can use 'patchmatic' to automate DSDT+SSDT static patching.

Ok Rehabman, I do a repatching of all my patched section of ACPI, all the changes concerns igpu rename and battery of the dell in the ssdt-1 ssdt-2 and ssdt-3, and it continues give me no working ci/qe :(

I attach the new files, please, take a look, I can't understand how to solve or fix this

You made a mistake...
The B1B2 patch should only be applied to DSDT.
For some unknown reason you applied it to other files.
It is very obvious if you attempt to disassemble your files in ACPI/patched: iasl -da -dl *.aml
 
Top