Contribute
Register

[FIX] HD4200/HD4400/HD4600/HD5600 on 10.11+

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,161
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Yup, this is set at 64mb and I've tried changing it and using different ig-platforms (w/clover patches) for other sizes with the same result. But I'll keep trying now that I've got the system re-done properly. Thanks for the suggestions!

Keep in mind that changing any BIOS option requires ACPI re-extract/re-patch.
 
Joined
Nov 25, 2010
Messages
35
Motherboard
Asus G771JM-DH71-CA
CPU
i7-4710HQ
Graphics
GTX 860M - HD4600
Yeah, guess I'll have to chalk it up to some issue with High Sierra and my machine; Tried everything I can think of and nothing resolves this blocky black **** on the login screen. Created an EDID directly from Windows, same issue. Tried using FixEDID with several different Displays and same thing.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,161
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Yeah, guess I'll have to chalk it up to some issue with High Sierra and my machine; Tried everything I can think of and nothing resolves this blocky black **** on the login screen. Created an EDID directly from Windows, same issue. Tried using FixEDID with several different Displays and same thing.

No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Jun 11, 2015
Messages
10
Motherboard
ASUS X550LN
CPU
i5 4210u
Graphics
HD4400 / GT 840M
Hi, my laptop HD4400 have 24 bits color on System Report. How I change to 32 bits? All work on my HD4400, but sometimes the screen flashes. Changing colour bits the problem will solve?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,161
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi, my laptop HD4400 have 24 bits color on System Report. How I change to 32 bits? All work on my HD4400, but sometimes the screen flashes. Changing colour bits the problem will solve?

24-bit vs. 32-bit is likely EDID related.

No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Jun 11, 2015
Messages
10
Motherboard
ASUS X550LN
CPU
i5 4210u
Graphics
HD4400 / GT 840M
24-bit vs. 32-bit is likely EDID related.

No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
I used this guide to get EDID: https://www.tonymacx86.com/threads/fixing-brightness-with-custom-edid.219413/
When I use the generated EDID keep same 24 bits.

My complete Clover folder is attached.
 

Attachments

  • CLOVER.zip
    4.1 MB · Views: 70

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,161
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I used this guide to get EDID: https://www.tonymacx86.com/threads/fixing-brightness-with-custom-edid.219413/
When I use the generated EDID keep same 24 bits.

My complete Clover folder is attached.

"Problem Reporting" files are incomplete.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Jun 11, 2015
Messages
10
Motherboard
ASUS X550LN
CPU
i5 4210u
Graphics
HD4400 / GT 840M

Attachments

  • debug_12865.zip
    3.9 MB · Views: 69

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,161
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I updated my laptop spec in profile. The files are attached.

Probably due to EDID which says 6-bits per primary color channel:
Code:
NUC6i7KYK:fakepciid.git rehabman$ pbpaste|xxd -r -p|~/Projects/edid-decode/edid-decode
Extracted contents:
header:          00 ff ff ff ff ff ff 00
serial number:   06 af ed 36 00 00 00 00 00 17
version:         01 04
basic params:    95 22 13 78 02
chroma info:     d1 15 9e 59 53 9b 27 1e 50 54
established:     00 00 00
standard:        01 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01
descriptor 1:    78 37 80 b4 70 38 2e 40 6c 30 aa 00 58 c1 10 00 00 18
descriptor 2:    00 00 00 0f 00 00 00 00 00 00 00 00 00 00 00 00 00 20
descriptor 3:    00 00 00 fe 00 41 55 4f 0a 20 20 20 20 20 20 20 20 20
descriptor 4:    00 00 00 fe 00 42 31 35 36 48 54 4e 30 33 2e 36 20 0a
extensions:      00
checksum:        97

Manufacturer: AUO Model 36ed Serial Number 0
Made week 0 of 2013
EDID version: 1.4
Digital display
6 bits per primary color channel
DisplayPort interface
Maximum image size: 34 cm x 19 cm
Gamma: 2.20
Supported color formats: RGB 4:4:4
First detailed timing is preferred timing
Established timings supported:
Standard timings supported:
Detailed mode: Clock 142.000 MHz, 344 mm x 193 mm
               1920 2028 2076 2100 hborder 0
               1080 1090 1100 1126 vborder 0
               -hsync -vsync 
Manufacturer-specified data, tag 15
ASCII string: AUO
ASCII string: B156HTN03.6
Checksum: 0x97 (valid)
EDID block does NOT conform to EDID 1.3!
    Missing name descriptor
    Missing monitor ranges
    Detailed block string not properly terminated
 
Joined
Jun 11, 2015
Messages
10
Motherboard
ASUS X550LN
CPU
i5 4210u
Graphics
HD4400 / GT 840M
Probably due to EDID which says 6-bits per primary color channel:
Code:
NUC6i7KYK:fakepciid.git rehabman$ pbpaste|xxd -r -p|~/Projects/edid-decode/edid-decode
Extracted contents:
header:          00 ff ff ff ff ff ff 00
serial number:   06 af ed 36 00 00 00 00 00 17
version:         01 04
basic params:    95 22 13 78 02
chroma info:     d1 15 9e 59 53 9b 27 1e 50 54
established:     00 00 00
standard:        01 01 01 01 01 01 01 01 01 01 01 01 01 01 01 01
descriptor 1:    78 37 80 b4 70 38 2e 40 6c 30 aa 00 58 c1 10 00 00 18
descriptor 2:    00 00 00 0f 00 00 00 00 00 00 00 00 00 00 00 00 00 20
descriptor 3:    00 00 00 fe 00 41 55 4f 0a 20 20 20 20 20 20 20 20 20
descriptor 4:    00 00 00 fe 00 42 31 35 36 48 54 4e 30 33 2e 36 20 0a
extensions:      00
checksum:        97

Manufacturer: AUO Model 36ed Serial Number 0
Made week 0 of 2013
EDID version: 1.4
Digital display
6 bits per primary color channel
DisplayPort interface
Maximum image size: 34 cm x 19 cm
Gamma: 2.20
Supported color formats: RGB 4:4:4
First detailed timing is preferred timing
Established timings supported:
Standard timings supported:
Detailed mode: Clock 142.000 MHz, 344 mm x 193 mm
               1920 2028 2076 2100 hborder 0
               1080 1090 1100 1126 vborder 0
               -hsync -vsync
Manufacturer-specified data, tag 15
ASCII string: AUO
ASCII string: B156HTN03.6
Checksum: 0x97 (valid)
EDID block does NOT conform to EDID 1.3!
    Missing name descriptor
    Missing monitor ranges
    Detailed block string not properly terminated
So it's not possible change the 24 bits value to 32 bits?

Sometimes my screen flashes in black color. How I solve this?


EDIT: I add darkwake=0 in config.plist and it seems flashes are solved.
 
Last edited:
Top