Contribute
Register

[FIX] HD4200/HD4400/HD4600/HD5600 on 10.11+

Joined
Aug 22, 2012
Messages
28
Motherboard
ASUS Z97I-Plus
CPU
Intel i3-4350T
Graphics
Intel GPU HD 4600
Mobile Phone
  1. Android
I have a DESKTOP i3-4350T that has a IGP HD 4600 running with Sierra. I injected the correct ID, and that seems to fix a few glitches. Do I still need to install the FakePCIID KEXT?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,093
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I have a DESKTOP i3-4350T that has a IGP HD 4600 running with Sierra. I injected the correct ID, and that seems to fix a few glitches. Do I still need to install the FakePCIID KEXT?

Desktop questions are off-topic in the laptop forum.
But HD4600 desktop is native, no need for FakePCIID or FakeID.
 
Joined
Sep 21, 2013
Messages
11
Mac
Classic Mac
Mobile Phone
I read about many cards, but in my desktop i have ATI hd4500 and now it's working good with El capitain.
The system read it as a hd4500.
Can i usate to high sierra?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,093
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I read about many cards, but in my desktop i have ATI hd4500 and now it's working good with El capitain.
The system read it as a hd4500.
Can i usate to high sierra?

Off-topic.
This thread is regarding Intel HD Graphics as per title of the thread.
 
Joined
Nov 21, 2017
Messages
18
Motherboard
Asus Z-370 A
CPU
Intel Core i5 8600k
Graphics
Intel UHD 630
hi all, i have a desktop core i3 4150 HD4400. keeps tearing and flickering, no idea

kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext realtekALC.kext

kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext GenericUSBXHCI.kext

kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakeSMC.kext

kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakePCIID_XHCIMux.kext

FakePCIID_Intel_HD_Graphics.kext has incorrect permissions; omitting.

kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakePCIID.kext

kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext AppleIntelE1000e.kext

kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext AHCI_Intel_Generic_SATA.kext

kext-dev-mode allowing invalid signature -67054 0xFFFFFFFFFFFEFA12 for kext AppleHDA.kext

KernelCache ID: CAC2E07F65B3ABD7F3C3B7F3C927F31D

symlink("/System/Library/PrelinkedKernels/prelinkedkernel", "/System/Library/Caches/com.apple.kext.caches/Startup/kernelcache") failed 17 (File exists) <createPrelinkedKernel 2795>
 
Joined
Nov 21, 2017
Messages
18
Motherboard
Asus Z-370 A
CPU
Intel Core i5 8600k
Graphics
Intel UHD 630
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/

is this any better? apologies for not being very useful. I've gone thru a lot till this point, and its getting on my nerves. thanks

Shanes-iMac:~ shane$ kextstat|grep -y acpiplat

13 1 0xffffff7f8239c000 0x66000 0x66000 com.apple.driver.AppleACPIPlatform (5.0) D748FA50-380C-3F0D-BAD9-EB7A15848EA8 <12 11 7 6 5 4 3 1>

Shanes-iMac:~ shane$ kextstat|grep -y appleintelcpu

Shanes-iMac:~ shane$ kextstat|grep -y applelpc

77 0 0xffffff7f81e5b000 0x3000 0x3000 com.apple.driver.AppleLPC (3.1) F51595F0-F9B1-3B85-A1C3-F984DAD4107E <76 12 5 4 3>

Shanes-iMac:~ shane$ kextstat|grep -y applehda

82 1 0xffffff7f8208d000 0x1d000 0x1d000 com.apple.driver.AppleHDAController (276.26) D0953002-6091-376F-8E0F-33B65F42CEF9 <81 80 79 12 7 6 5 4 3 1>

107 0 0xffffff7f8220f000 0xb4000 0xb4000 com.apple.driver.AppleHDA (276.26) 7611D43E-12FE-3228-A6D3-9C99A5D030CC <106 89 82 81 80 79 6 5 4 3 1>

Shanes-iMac:~ shane$ ls -l /System/Library/Extensions/AppleHDA.kext/Contents/Resources/*.zml*

-rw-r--r-- 1 root wheel 6289 Nov 6 2015 /System/Library/Extensions/AppleHDA.kext/Contents/Resources/Platforms.zml.zlib

-rw-r--r-- 1 root wheel 1224 Aug 3 2013 /System/Library/Extensions/AppleHDA.kext/Contents/Resources/layout1.zml.zlib

-rw-r--r-- 1 root wheel 1224 Aug 3 2013 /System/Library/Extensions/AppleHDA.kext/Contents/Resources/layout2.zml.zlib

-rw-r--r-- 1 root wheel 1227 Nov 6 2015 /System/Library/Extensions/AppleHDA.kext/Contents/Resources/layout3.zml.zlib

Shanes-iMac:~ shane$ pmset -g assertions

2017-11-21 21:09:56 -0500

Assertion status system-wide:

BackgroundTask 0

ApplePushServiceTask 0

UserIsActive 1

PreventUserIdleDisplaySleep 0

PreventSystemSleep 0

ExternalMedia 0

InternalPreventDisplaySleep 1

PreventUserIdleSystemSleep 1

NetworkClientActive 0

Listed by owning process:

pid 456(AddressBookSourceSync): [0x0000012e0001806d] 00:00:09 PreventUserIdleSystemSleep named: "Address Book Source Sync"

Timeout will fire in 1791 secs Action=TimeoutActionTurnOff

pid 94(hidd): [0x0000002c0009801a] 00:04:27 UserIsActive named: "com.apple.iohideventsystem.queue.tickle"

Timeout will fire in 600 secs Action=TimeoutActionRelease

pid 44(powerd): [0x000000ae00108065] 00:02:17 InternalPreventDisplaySleep named: "com.apple.powermanagement.delayDisplayOff"

Timeout will fire in 177 secs Action=TimeoutActionTurnOff

Kernel Assertions: 0x104=USB,MAGICWAKE

id=500 level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.1d100000 owner=IOUSBHostDevice

id=501 level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.1a100000 owner=IOUSBHostDevice

id=502 level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.1d140000 owner=IOUSBHostDevice

id=503 level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.1d160000 owner=USB Laser Mouse

id=504 level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.14300000 owner=ASM107x

id=505 level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.1d130000 owner=ASM107x

id=506 level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.1d131000 owner=USB2.0 Hub

id=507 level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.1d132000 owner=USB Trackball

id=508 level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.1d133000 owner=Gaming KB

id=509 level=255 0x4=USB mod=12/31/69, 7:00 PM description=com.apple.usb.externaldevice.14310000 owner=USB3.0 Hub

id=510 level=255 0x100=MAGICWAKE mod=12/31/69, 7:00 PM description=en1 owner=en1

Idle sleep preventers: IODisplayWrangler

System sleep preventers: .Display_boot

Shanes-iMac:~ shane$ pmset -g

Currently in use:

standby 0

Sleep On Power Button 1

womp 1

autorestart 0

hibernatefile /var/vm/sleepimage

powernap 0

networkoversleep 0

disksleep 10

sleep 1 (sleep prevented by AddressBookSourceSync)

autopoweroffdelay 14400

hibernatemode 0

autopoweroff 1

ttyskeepawake 1

displaysleep 10

standbydelay 10800
 

Attachments

  • CLOVER.zip
    1.7 MB · Views: 49

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,093
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
is this any better? apologies for not being very useful. I've gone thru a lot till this point, and its getting on my nerves. thanks

Your config.plist is wrong.

Desktop HD4400 requirements:
- config.plist/Graphics/Inject/Intel=true
- config.plist/Graphics/ig-platform-id=0x0d220003
- config.plist/Devices/FakeID/IntelGFX=0x04128086
- BIOS DVMT-prealloc 64mb
- digital connection to your monitor (VGA not supported)
- VT-d disabled or use dart=0
- FakePCIID.kext + FakePCIID_Intel_HD_Graphics.kext
 
Joined
Nov 21, 2017
Messages
18
Motherboard
Asus Z-370 A
CPU
Intel Core i5 8600k
Graphics
Intel UHD 630
Interesting. Clover says it had taken care of that? But it looks to me the config is alright? I have the pciid and hdGraph kexts too, or at least I think I do?
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Boot</key>
<dict>
<key>Arguments</key>
<string>-v npci=0x2000 kext-dev-mode=1 rootless=0</string>
</dict>
<key>Devices</key>
<dict>
<key>FakeID</key>
<dict>
<key>IntelGFX</key>
<string>0x04128086</string>
</dict>
</dict>
<key>GUI</key>
<dict>
<key>Theme</key>
<string>iclover</string>
</dict>
<key>Graphics</key>
<dict>
<key>Inject</key>
<dict>
<key>Intel</key>
<true/>
</dict>
<key>LoadVBios</key>
<true/>
<key>ig-platform-id</key>
<string>0x0d220003</string>
</dict>
<key>RtVariables</key>
<dict>
<key>BooterConfig</key>
<string>0x28</string>
<key>CsrActiveConfig</key>
<string>0x67</string>
</dict>
<key>SystemParameters</key>
<dict>
<key>InjectKexts</key>
<string>Yes</string>
</dict>
</dict>
</plist>

Not sure my Bios has anything on DVMT. It's an Asus z87.
Not sure about this "VT-d disabled or use dart=0". And I am using VGA...
 
Top