Contribute
Register

Fix for Firmware Update Required for Mac Pro 5,1

Joined
May 18, 2014
Messages
2
Mac
Classic Mac
Mobile Phone
1st Post!
I have a MacPro 5,1 and the firmware upgrade is preventing me from installing high sierra. Because I have a Non EFI graphics card (I have a RX480).

So I have read the posts of this thread and I need to download clover.

I need to install clover?

then I need to edit the clover config.plist *which is where?"

SMBIOS is a part of the config.plist?
-and I'll change those strings, and save it...

Then It should by pass the firmware check?

Thanks- and all apologies for needing the NooB handholding. If I know what and where these things are I can edit them all... I got my RX480 to work pre high Sierra. AND created a hackintosh years ago from knowledge gained from the good people like yourselves at this site-...

-Cheers

Apple during the High Sierra Beta released a firmware update for the Mac Pro 5,1 to allow it to boot APFS volumes. The installer checks for this version and will display a message like this:

View attachment 281079

To get around this you need to edit your Clover config.plist to contain the updated version information.

Under SMBIOS change BiosReleaseDate and BiosVersion to the following:

Code:
       <key>BiosReleaseDate</key>
       <string>08/08/17</string>
       <key>BiosVersion</key>
       <string>MP51.88Z.0084.B00.1708080528</string>
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
12,444
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
Joined
Jul 26, 2012
Messages
35
Motherboard
Asus P5Q Deluxe
CPU
Intel Core 2 Quad Q9550
Graphics
GeForce 9600 GT
Mac
Classic Mac
Mobile Phone
How did you manage to go to second stage of HS installation with MacPro5,1 system definition?
Now BaseSystem.dmg is not extracted and it's not possible to remove AppleTyMCEDriver.kext from installer.
I have been trying to use Clover to inject modified kext but with no luck.
 
Joined
May 18, 2014
Messages
2
Mac
Classic Mac
Mobile Phone
flymaus, NO! Don't use Clover on your Mac Pro 5,1!! It will brick it! Put your old graphics card back into your Mac Pro and reset PRAM. Then, install HS. HS has a firmware update and a non EFI graphics card will prevent the firmware update. Finally, replace the old graphics card with your RX 460 graphics card, reset PRAM and you're good to go.

Update: See https://forums.macrumors.com/threads/mac-pro-5-1-with-rx-480-upgrade-to-high-sierra.2090318/#post-25504150
GLAD I ASKED!!! LOL- bricking it would have been horrible. Sold the original Graphics card. Do you know the cheapest OEM Apple Card that will work? (used market is fine too since I'll likely not use it -I'll go get a used one.)

THANK YOU SO very much for your help!! If you get to Jupiter FL- West Palm Beach FL I will buy you a beer (or 2X)...
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
12,444
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
Joined
Feb 18, 2011
Messages
181
Motherboard
Sawtooth Build
CPU
i5 650 @ 3.3Ghz or 3.7Ghz
Graphics
MSI nVidia GeForce 610 2GB
Mac
iMac, MacBook Pro, Mac mini, Mac Pro
Classic Mac
128K, 512K, Apple, Centris, iMac, LC, Performa, Power Mac, PowerBook, Quadra
Mobile Phone
iOS
GLAD I ASKED!!! LOL- bricking it would have been horrible. Sold the original Graphics card. Do you know the cheapest OEM Apple Card that will work? (used market is fine too since I'll likely not use it -I'll go get a used one.)

THANK YOU SO very much for your help!! If you get to Jupiter FL- West Palm Beach FL I will buy you a beer (or 2X)...
You may be able to get away with a GT120 which was the OEM card on the 4,1 MacPro. Other than the firmware and lidded (5,1) vs. de-lidded (4,1) there wasn't much different between the quad 2.9 4,1 quad 2.8 the 5,1.
 
Top