Contribute
Register

[Fix] 10.12/10.13 Nvidia 2/3/4/5/6/7/9/10xx Series Black Screen

Joined
Oct 7, 2012
Messages
126
Motherboard
ROG Maximus XII Hero Wi-Fi
CPU
i9-10900K
Graphics
RX 6900XT Sapphire Nitro+
Mac
  1. MacBook
I'm glad to have helped you guys! The only thing I'm concerned about is the mismatch of the board-id and the system definition causing problems with iMessage in the future :thumbdown for now everything seems to work perfectly but we'll see...

Just so I can follow this verbatim.

You didn't touch the kexts? Only changed your board ID in clover? But left System definition as 12,2?
 
Joined
Sep 26, 2012
Messages
125
Motherboard
Gigabyte Z170
CPU
i5 6500
Graphics
Nvidia GTX 960
Just so I can follow this verbatim.

You didn't touch the kexts? Only changed your board ID in clover? But left System definition as 12,2?
Correct. I used the iMac 14,2 board-id with the iMac 12,2 SMBIOS

Let me know how it goes :)
 
Joined
Oct 7, 2012
Messages
126
Motherboard
ROG Maximus XII Hero Wi-Fi
CPU
i9-10900K
Graphics
RX 6900XT Sapphire Nitro+
Mac
  1. MacBook
No dice guys. Black screen. Interestingly if i use nvdr flag in clover it reboot loops.

I've tired 14,2 with a 14,2 board id. 12,2 with a 14,2 board id and 12,2 with a 14,2 board id. Left it at 12,2 and manually put the board id in the kext file, etc.

Don't know what else to try?
 
Joined
Sep 26, 2012
Messages
125
Motherboard
Gigabyte Z170
CPU
i5 6500
Graphics
Nvidia GTX 960
No dice guys. Black screen. Interestingly if i use nvdr flag in clover it reboot loops.

I've tired 14,2 with a 14,2 board id. 12,2 with a 14,2 board id and 12,2 with a 14,2 board id. Left it at 12,2 and manually put the board id in the kext file, etc.

Don't know what else to try?
Try toggling "Inject Nvidia" on and off in Clover. IIRC there's native drivers for that card, but some people online are saying they needed web drivers.

EDIT: I didn't read the full post; misunderstood the problem. You could try booting without caches?
 
Joined
Sep 26, 2012
Messages
125
Motherboard
Gigabyte Z170
CPU
i5 6500
Graphics
Nvidia GTX 960
No dice guys. Black screen. Interestingly if i use nvdr flag in clover it reboot loops.

I've tired 14,2 with a 14,2 board id. 12,2 with a 14,2 board id and 12,2 with a 14,2 board id. Left it at 12,2 and manually put the board id in the kext file, etc.

Don't know what else to try?
Could also try 13,2: Mac-FC02E91DDD3FA6A4

The Web Drivers may help. Even if you do manage to get the card working, remember that Fermi cards had freezing issues that were never solved. You'll have to download the FreezeFix.app. Remember to revert back to the stock AppleGraphicsDevicePolicy.kext!
 
Joined
Oct 7, 2012
Messages
126
Motherboard
ROG Maximus XII Hero Wi-Fi
CPU
i9-10900K
Graphics
RX 6900XT Sapphire Nitro+
Mac
  1. MacBook
Still no dice. Interesting, when i tried to boot up my other hard drive it was black screening also. Then i realised when i was messing around with it I changed the DVI port from 1 to the other. Surely this wouldn't do anything but lo and behold when i changed it back i could get back into my El Cap build. I might try dig up a HDMI cable tomorrow and keep experimenting.
 
Joined
Sep 26, 2012
Messages
125
Motherboard
Gigabyte Z170
CPU
i5 6500
Graphics
Nvidia GTX 960
Still no dice. Interesting, when i tried to boot up my other hard drive it was black screening also. Then i realised when i was messing around with it I changed the DVI port from 1 to the other. Surely this wouldn't do anything but lo and behold when i changed it back i could get back into my El Cap build. I might try dig up a HDMI cable tomorrow and keep experimenting.

That's really interesting. I believe I might have had a similar problem with a different card, only it was with DisplayPort. It could've just been the old card I was using (I pulled out the trusty Radeon 5870; came out when I was 9)

Within the latest version of Clover I believe there's an option to not reboot after kernel panic. If you boot into verbose mode, you might have some more info.

Good luck!
 
Joined
Sep 9, 2012
Messages
7
Motherboard
DG41RQ
CPU
CORE 2 DUO
Graphics
NVIDIA GT 610
Mac
  1. iMac
Mobile Phone
  1. iOS
Please Help me with gt 610 mac os sierra qe/ci accelaration .
 

slim.jim

Moderator
Joined
Dec 17, 2014
Messages
4,288
Motherboard
MSI Z97 Gaming 9 AC
CPU
i7-4790K
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Please Help me with gt 610 mac os sierra qe/ci accelaration .

As of right now, no one has been able to get that card working in Sierra.
 
Top