Contribute
Register

[Fix] 10.11.4 broken audio with AppleHDA injector (dummyHDA)

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,109
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
i have installed this, but the audio sometimes work after restart and somtimes not working.
i don't have any idea what to do.
What do you mean by "installed this"?
 
Joined
Oct 6, 2016
Messages
16
Motherboard
HP Elitebook 8470p (Clover)
CPU
i5-3320m/HM76
Graphics
HD4000, 1366x768
Mobile Phone
iOS
ok. my mistake sorry.
 
Joined
Feb 4, 2011
Messages
32
Motherboard
Gigabyte GA-Z170N-WiFi
CPU
i7 6700K
Graphics
GT 640
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android
I've got myself a new ASUS Zenbook UX330UA. Initially I've installed OsX Sierra but due to Intel HD 520 glitches I've reinstalled everything and made a dual boot EL Capitan/Sierra. In El Capitan everything is working (except i2c trackpad ... known issue) but the sound is not working while with the same Clover patch/DSDT hotpatches/HDA Injector (contains the bundles suggested in post #1) in Sierra is working.

Tried with kext cache disabled and with rebuilding kextcache and no change ins status.

El Capitan version 10.11.6

Attached are the files as requested for debug in #1 and the terminal outputs are :
Code:
$ kextstat|grep -y applehda
   92    1 0xffffff7f82155000 0x1e000    0x1e000    com.apple.driver.AppleHDAController (274.12) 5F94D8E3-B1E5-35D7-AB7A-6419C3AAC3B5 <91 90 66 12 7 6 5 4 3 1>
  111    0 0xffffff7f823f4000 0xb3000    0xb3000    com.apple.driver.AppleHDA (999.1.1fc1) 436B78B7-FA08-3C53-B97D-5C617CB7EB28 <110 92 91 90 71 66 12 11 6 5 4 3 1>
and

Code:
$ sudo touch /System/Library/Extensions && sudo kextcache -u /
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakeSMC.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext VoodooPS2Trackpad.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext VoodooPS2Mouse.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext VoodooPS2Keyboard.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext VoodooPS2Controller.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext SATA-100-series-unsupported.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext NullEthernet.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext IntelBacklight.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext AsusNBFnKeys.kext
kext-dev-mode allowing invalid signature -67030 0xFFFFFFFFFFFEFA2A for kext aDummyHDA.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext ACPIBatteryManager.kext
Any hints on what I'm overlooking or doing wrong are welcome.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,109
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I've got myself a new ASUS Zenbook UX330UA. Initially I've installed OsX Sierra but due to Intel HD 520 glitches I've reinstalled everything and made a dual boot EL Capitan/Sierra. In El Capitan everything is working (except i2c trackpad ... known issue) but the sound is not working while with the same Clover patch/DSDT hotpatches/HDA Injector (contains the bundles suggested in post #1) in Sierra is working.

Tried with kext cache disabled and with rebuilding kextcache and no change ins status.

El Capitan version 10.11.6

Attached are the files as requested for debug in #1 and the terminal outputs are :
Code:
$ kextstat|grep -y applehda
   92    1 0xffffff7f82155000 0x1e000    0x1e000    com.apple.driver.AppleHDAController (274.12) 5F94D8E3-B1E5-35D7-AB7A-6419C3AAC3B5 <91 90 66 12 7 6 5 4 3 1>
  111    0 0xffffff7f823f4000 0xb3000    0xb3000    com.apple.driver.AppleHDA (999.1.1fc1) 436B78B7-FA08-3C53-B97D-5C617CB7EB28 <110 92 91 90 71 66 12 11 6 5 4 3 1>
and

Code:
$ sudo touch /System/Library/Extensions && sudo kextcache -u /
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext FakeSMC.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext VoodooPS2Trackpad.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext VoodooPS2Mouse.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext VoodooPS2Keyboard.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext VoodooPS2Controller.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext SATA-100-series-unsupported.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext NullEthernet.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext IntelBacklight.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext AsusNBFnKeys.kext
kext-dev-mode allowing invalid signature -67030 0xFFFFFFFFFFFEFA2A for kext aDummyHDA.kext
kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext ACPIBatteryManager.kext
Any hints on what I'm overlooking or doing wrong are welcome.
Assuming your dummyHDA is for your codec and uses layout-id 3....

You need to boot without caches, then rebuild cache, then reboot.
 
Joined
Feb 4, 2011
Messages
32
Motherboard
Gigabyte GA-Z170N-WiFi
CPU
i7 6700K
Graphics
GT 640
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android
Assuming your dummyHDA is for your codec and uses layout-id 3....

You need to boot without caches, then rebuild cache, then reboot.
Yes my dummyHDA is set for layout-id 3. The same kext with the same EFI partition works in Sierra but not in El Capitan (dual boot).

I did booted without caches and rebuild cache but nothing changed.

This why I find it strange because I do not find the issue with it.

I've attached the DummyHDA I use. It is generated with Mirone's AppleHDAPatcher.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,109
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Yes my dummyHDA is set for layout-id 3. The same kext with the same EFI partition works in Sierra but not in El Capitan (dual boot).
All kexts should be installed to the system partition.

You should check that you have the required AppleHDA patches in your config.plist. There are additional codecs supported in 10.12, so often additional patches required.
 
Joined
Jul 16, 2010
Messages
396
Motherboard
OP-LP3 Laptop
CPU
i7-8750H
Graphics
UHD630 (1920 x 1080)
Mac
Mac Pro
Mobile Phone
iOS
Is this guide good up to Sierra 10.12.1? I'v encountered a slight issue in Sierra. System volume output control is mute/full on, slider fully functional, however apps like logic and/or Youtube as an example with there built in audio output controllers have full audio output range and independent of the System volume slider.

Headphone plugged in no issues at all. Only on internal speakers.

This is for an Asus G750JX Laptop with ALC282 audio, v2.1 audio subwoofer.
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,109
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Is this guide good up to Sierra 10.12.1? I'v encountered a slight issue in Sierra. System volume output control is mute/full on, slider fully functional, however apps like logic and/or Youtube as an example with there built in audio output controllers have full audio output range and independent of the System volume slider.

Headphone plugged in no issues at all. Only on internal speakers.

This is for an Asus G750JX Laptop with ALC282 audio, v2.1 audio subwoofer.
Off-topic.
 
Top