Contribute
Register

First G4 Cube almost complete.... except for loud GPU ground noise!

Status
Not open for further replies.
Joined
Sep 27, 2015
Messages
9
Motherboard
Gigabyte GA-Z97-D3H
CPU
Intel® Core™ i7-4790K
Graphics
GeForce GTX 750 Ti GPU
Mac
  1. iMac
  2. MacBook Air
  3. Mac Pro
Classic Mac
Mobile Phone
Hi guys,

Great forum, been reading up for a while, and a couple of months ago started by first ever PC mod build - a G4 Cube. Firstly, huge respect to everyone here who's made a successful build - I have discovered that its definitely not as easy as it might seem!

Here are my specs:

ASRock H97M-ITX/ac Motherboard [NOT recommended - other motherboards fit much better!]
https://www.amazon.co.uk/gp/product/B00KL7KY6M/?tag=tonymacx86-21

Intel Core i3 Processor 4130T [Great low powered CPU!]
https://www.amazon.co.uk/dp/B00EXKL0KC/?tag=tonymacx86-21

ZOTAC GeForce GTX 750Ti
https://www.amazon.co.uk/dp/B00IFYTNQ0/?tag=tonymacx86-21

HyperX FURY Series 8 GB DDR3 1600 MHz
https://www.amazon.co.uk/gp/product/B00J8E92M6/?tag=tonymacx86-21

LEICKE ULL PSU Power Supply 150W
https://www.amazon.co.uk/gp/product/B00YXXAG7C/?tag=tonymacx86-21

I might tell the full story of the build at another time (its been very educational!), but currently I have one more problem to solve before this build is complete:

After I installed the GPU, I discovered a very loud noise coming through the HDMI audio. The frequency of the noise was determined by the load (or framerate) of the GPU - high framerate, high pitched whine. After a lot of experimentation, I'm now pretty sure this is caused by insufficient grounding of the machine - just touching any kind of grounded cable onto the metal parts of the case will immediately stop the noise. I have also tried connecting a wire from a molex connector to ground the cube's chassis - didn't make any difference.

My question is: has anyone else encountered this problem, and if so, what solution did you find? Currently, I have an HDMI cable running from my old Mac Pro directly into the cube via motherboard HDMI - this solves the problem completely, but certainly isn't ideal.

Any help much appreciated!
 
Joined
Sep 27, 2015
Messages
9
Motherboard
Gigabyte GA-Z97-D3H
CPU
Intel® Core™ i7-4790K
Graphics
GeForce GTX 750 Ti GPU
Mac
  1. iMac
  2. MacBook Air
  3. Mac Pro
Classic Mac
Mobile Phone
No one had any experience of this kind of thing? Any recommendations for solving a ground loop noise problem?
 
Joined
Jun 16, 2013
Messages
75
Motherboard
PowerMac G4 MDD
CPU
i7 3930K @ 4.5ghz
Graphics
2x GTX 970 SLI
Mac
  1. MacBook Air
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
I have the same problem mate, if you solve it, please share your fix.
its not too bad on mine, but if i turn the volume up really high it can get quite annoying!
 
Joined
May 30, 2016
Messages
568
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac Pro
Classic Mac
  1. iMac
  2. SE/30
Mobile Phone
  1. iOS
maybe the PCIe extender you used? the cheap ones on amazon arent shielded.
 
Status
Not open for further replies.
Top