Contribute
Register
Joined
Jul 30, 2014
Messages
31
Motherboard
GIGABYTE GA-Z270M-D3H
CPU
Intel Core i5-6600K SkyLake 3.5 GHz
Graphics
EVGA GeForce GTX 1060 SC GAMING, ACX 2.0 (Single Fan), 06G-P4-6163-KR, 6GB GDDR5
Mac
  1. MacBook
Mobile Phone
  1. Android
Hello,
This is my first hackintosh build and I'm having some issues with the post configuration. Below is a list of hardware as well as the process I took for installing Sierra. Thanks for your time!

Hardware:
Case: Cooler Master HAF XB EVO
Motherboard: GIGABYTE GA-Z270M-D3H
-Audio: ACL892
-Ethernet: Intel® GbE LAN chip (10/100/1000 Mbit)
Processor: Intel Core i5-6600K SkyLake 3.5 GHz LGA 1151
Memory: Crucial Ballistix Sport LT 16GB 2 x 8GB DDR4-2400 PC4-19200
Power Supply: PowerSpec 650 Watt 80 Plus Bronze ATX Semi-Modular Power Supply

*Note: I don't have a GPU as of yet so I need the iGPU HD 530 to work if possible.
**Note: Both the motherboard and the case only have 3.0 USB ports. Not sure if that might be an issue as everything seems to install correctly.


Here are the steps that I took to install:
1) Used Unibeast to load Sierra 10.12.6 on to my 32gb USB
2) Copied over Multibeast, Clover Configurator, and Kext beast (Haven't used Kext Beast but have it if needed)
3) Booted to the USB from my GA-Z270M-D3H (rev. 1.0) boot menu (BIOS has been configured based on a guide found on a 3rd party site. Also, no boot arguments were used.
4) Successfully formatted my 120gb SanDisk SSD and installed OS X Sierra 10.12.6
5) Rebooted the computer when prompted and booted back onto the USB and used Clover to boot to the SSD
6) Once Successfully booted to the SSD finished the setup process and loaded the desktop
7) From the desktop I launched Multibeast and installed the following config:
-UEFI Boot Mode
-Drivers: ALC892, 100/200 Series Audio
-Network: IntelMausiEthernet v2.2.1d1
-USB: Increase Max USB Port Limit 200 Series
-Bootloaders: Clover v2.4k r4063 UEFI Boot Mode
-Graphics Configuration: Intel HD 5xx
-System Definitions: iMac 14,2 (Default)
-Installation successful, rebooted machine
8) Opened start up menu and selected the SSD, deleted args and booted into the system
9) Apple Loading screen gets stuck at 3/4 when booting (Around 10 minutes the screen went black, screen was black for 1 minute then computer shutdown)
10) Turned on the system and screen remained black with no BIOS screen shown - Let sit for 3 minutes then reset the system
11) Repeated step 8 with verbose mode enabled
12) Verbose mode got stuck with an graphics error (see screenshot)

IMG_20170729_233533.jpg

13) Reset the system and booted from the USB. Using Clover set arg to verbose mode and rebooted into the main SSD
14) System successfully booted however, the GPU issues still remained
15) Launched clover configurator and mounted the EFI partition, checked the kexts folder and not kexts are displayed in either the "Other" or "10.12" Folders.
16) Checked "About This Mac" and no definitions have been displayed. However, when I checked Clover congif the definition for iMac 14,2 is displayed. Also, my graphics are listed as Intel 7000 5 MB (See Screenshot)

IMG_20170730_000115.jpg IMG_20170730_000730.jpg

17) Went through the .plist file via clover config and checked boot args for verbose mode and unchecked dart=0. I also unchecked Inject Intel in the Graphics portion.
18) Rebooted system and let the system auto boot into the ssd. Got the same verbose error as before.


At this point of troubleshooting I have reached my 7 hour mark - I have searched online and found nothing that has helped me resolve my issue. I know there might be something out there but I am unable to find anything that is an exact match to my build and situation. If someone can please assist I would greatly appreciate it.
Thank you for taking the time to read all this and I look forward to some well needed professional help!

**UPDATE 7/31/17 - I was able to get the HD 530 graphics working from what I can tell. I followed the following guide https://www.tonymacx86.com/threads/macos-10-12-5-update.220866/#post-1504116 and from a fresh install I launched multibeast and configured the options to my settings. I then copied over the EFI folder onto the EFI partition of the SSD. Then using Kext Beast I installed Lilu.kext and IntelGraphicsFixUp.kext. I then rebooted and checked the proper graphics were being shown in the "About this Mac" menu. I still have an issue where the system definition is not being shown and when I tried adding the iMac 14,2 definition the system wouldn't boot. Rolled back to previous working EFI settings.

**UPDATE: Ethernet is working properly!
------------------------------------------------------------------------------------------------------------------------

Persistent issues:
-Audio (Either on-board or HDMI)
-YouTube videos are not playing - Tried Chrome and Safari
-(SOLVED) Unable to load the proper graphics as I continue to get graphical issues when logging in

Untested functions:
-Apple specific apps (iMessage, App Store, etc)
 
Last edited:
Top