Contribute
Register

First Build (Christmas Gift)

Status
Not open for further replies.
Joined
Jan 6, 2012
Messages
439
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000
Mobile Phone
  1. iOS
Put this together for about $400... closest thing to this in a mini (that I would never be able to expand) was $1,700 plus. I work for PCMall/MacMall and that is with my Apple EPP... No thank you. As I was saying I should be able to follow this guide (http://www.tonymacx86.com/61-unibeast-install-os-x-mountain-lion-any-supported-intel-based-pc.html) if I start on my 10.7 iMac and purchase the 10.8 upgrade? or will this only install as an upgrade?

When you buy/upgrade ML from the App store, it will start downloading the ML installation app to your applications folder. If you don't want to install it on that machine, just cancel the installation process that starts after the installation app finishes downloading (~4GB). With the ML installation app now in your applications folder, you can follow the Unibeast guide to make an installation USB stick that you can use on your 'new' machine. With that stick, you can upgrade a previous installation, or start a brand new one (e.g., no OS installed).

-bth
 

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
22,464
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
Put this together for about $400... closest thing to this in a mini (that I would never be able to expand) was $1,700 plus. I work for PCMall/MacMall and that is with my Apple EPP... No thank you. As I was saying I should be able to follow this guide (http://www.tonymacx86.com/61-unibeast-install-os-x-mountain-lion-any-supported-intel-based-pc.html) if I start on my 10.7 iMac and purchase the 10.8 upgrade? or will this only install as an upgrade?

Boot your 10.7 iMac, purchase and download the Mountain Lion install app from the App Store. Copy the app from the applications folder somewhere else so you don't have to download it again (if you lose it, no problem, you can download it again, just saves some time if you still have it saved somewhere). The app will stay in your app folder until you run it to upgrade your iMac. It will disappear from the app folder after you do the upgrade is why I say save it elsewhere.
Download UniBeast and prep your USB flash per the guide you linked and create your UniBeast installer. Eject your new USB UniBeast and go install on your assembled pc parts build.
It is that simple.
 
Joined
Oct 20, 2012
Messages
17
Motherboard
GA-Z77X-UD5H
CPU
i5-3570k
Graphics
Intel HD 4000
Mac
  1. iMac
Classic Mac
  1. Classic
  2. iBook
  3. iMac
  4. LC
  5. Plus
  6. Power Mac
  7. PowerBook
Mobile Phone
  1. Android
Boot your 10.7 iMac, purchase and download the Mountain Lion install app from the App Store. Copy the app from the applications folder somewhere else so you don't have to download it again (if you lose it, no problem, you can download it again, just saves some time if you still have it saved somewhere). The app will stay in your app folder until you run it to upgrade your iMac. It will disappear from the app folder after you do the upgrade is why I say save it elsewhere.
Download UniBeast and prep your USB flash per the guide you linked and create your UniBeast installer. Eject your new USB UniBeast and go install on your assembled pc parts build.
It is that simple.


I still need the flashed BIOS no? Or should I roll back to stock? Downloading ML from the app store now...
 
Joined
Oct 20, 2012
Messages
17
Motherboard
GA-Z77X-UD5H
CPU
i5-3570k
Graphics
Intel HD 4000
Mac
  1. iMac
Classic Mac
  1. Classic
  2. iBook
  3. iMac
  4. LC
  5. Plus
  6. Power Mac
  7. PowerBook
Mobile Phone
  1. Android
Boot your 10.7 iMac, purchase and download the Mountain Lion install app from the App Store. Copy the app from the applications folder somewhere else so you don't have to download it again (if you lose it, no problem, you can download it again, just saves some time if you still have it saved somewhere). The app will stay in your app folder until you run it to upgrade your iMac. It will disappear from the app folder after you do the upgrade is why I say save it elsewhere.
Download UniBeast and prep your USB flash per the guide you linked and create your UniBeast installer. Eject your new USB UniBeast and go install on your assembled pc parts build.
It is that simple.

So I got the install up and running... My MultiBeast install is not going as well now. I have run various combos of CW/MB with and without the standalone Chimera. They all result in a non bootable HDD (either still needs USB drive to boot or KP on boot) Do you have any details of what I should be selecting? I did re-flash the BIOS with... http://bios.zmac.net/msi/MSI-Z77A-G45-250_modified.zip...
 
Joined
Sep 20, 2011
Messages
414
Motherboard
Gigabyte B75M-DH3
CPU
i3 3240
Graphics
GT 710
Mac
  1. iMac
Mobile Phone
  1. iOS
So why are you here? >>

Really have nothing better to do but grief people? You sure aren't being very helpful for someone who seems to have done something similar.

I'm not trying to persuade you to not build a hack, they are great as is this website and all people here. I'm gently trying to say that if my mom, god rest her soul, was still alive, i would try to get her the real thing for a Christmas gift. If your mom is tech savvy then a hack is great, if not then maybe its not the best choice. You seem very knowledgeable at computer usage, i'm sure you will get it up and running. But we all love our moms and just want to give them the best.
 
Joined
Oct 20, 2012
Messages
17
Motherboard
GA-Z77X-UD5H
CPU
i5-3570k
Graphics
Intel HD 4000
Mac
  1. iMac
Classic Mac
  1. Classic
  2. iBook
  3. iMac
  4. LC
  5. Plus
  6. Power Mac
  7. PowerBook
Mobile Phone
  1. Android
http://www.tonymacx86.com/buying-advice/73558-z77-matx-motherboards-os-x.html
follow that guide
(not your board but settings/options should be similar)

This seems great for getting the HW to work. After my MB install all I get is (I.E. boot issue. Also after this MB install it doesn't boot even with the UB USB in... just get KP...

"boot0: GPT
boot0: test
boot0: test
boot0: GPT
boot0: test
boot0: test
boot0: error"



NVM found this http://www.tonymacx86.com/25-boot0-error-official-guide.html
 

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
22,464
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android


This seems great for getting the HW to work. After my MB install all I get is (I.E. boot issue. Also after this MB install it doesn't boot even with the UB USB in... just get KP...

It will KP if you haven't done one of 2 things - flash the BIOS with a patched one to allow native power management in OS X or select NullCPUPowerManagement Kext when you run MuntiBeast.

Glad you found the boot0 official guide.
 
Joined
Oct 20, 2012
Messages
17
Motherboard
GA-Z77X-UD5H
CPU
i5-3570k
Graphics
Intel HD 4000
Mac
  1. iMac
Classic Mac
  1. Classic
  2. iBook
  3. iMac
  4. LC
  5. Plus
  6. Power Mac
  7. PowerBook
Mobile Phone
  1. Android
I did patch the BIOS, (http://bios.zmac.net/msi/MSI-Z77A-G45-250_modified.zip correct no?), but still get the -v line about IntelCPUmgmt did not start properly. Should I have my BIOS set to OS pwr mgmt or BIOS? I got LAN running alright and think I got audio sorted.

Question #2 will the HD 4000 gfx only start right when using either the HDMI/DVI ports? I have been doing the build thus far on the VGA port and have yet to see it load properly in ASP.

It will KP if you haven't done one of 2 things - flash the BIOS with a patched one to allow native power management in OS X or select NullCPUPowerManagement Kext when you run MuntiBeast.

Glad you found the boot0 official guide.
 

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
22,464
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
I did patch the BIOS, (http://bios.zmac.net/msi/MSI-Z77A-G45-250_modified.zip correct no?), but still get the -v line about IntelCPUmgmt did not start properly. Should I have my BIOS set to OS pwr mgmt or BIOS? I got LAN running alright and think I got audio sorted.

Question #2 will the HD 4000 gfx only start right when using either the HDMI/DVI ports? I have been doing the build thus far on the VGA port and have yet to see it load properly in ASP.

1. not sure what the problem is there - can you post your BIOS settings?

2. OS X doesn't like VGA. If you have to, try a DVI->VGA adapter, but better to go with the DVI cable or HDMI.
 
Status
Not open for further replies.
Top