Contribute
Register

Final Cut Pro X Video Editing Hardware and Software on Z97X Motherboard and i7-4790K

Status
Not open for further replies.
Joined
Dec 30, 2015
Messages
87
Motherboard
Asus z97 Sabertooth Mark II
CPU
i7-4790k
Graphics
ASUS ROG STRIX 480x 8GB
I bought the xfx card you suggested but my system keeps freezing when I try to boot from it. Is there any other setup configurations that are required to make it work? Im plugging into the HDMI port on it.
It boots when I use internal graphics and disable the graphics card in the BIOS
 
Joined
Jun 18, 2011
Messages
21
Motherboard
MSI X99 Gaming 7
CPU
i7 5820K
Graphics
AMD R9 280X
Mac
  1. iMac
  2. MacBook Air
Classic Mac
Mobile Phone
  1. iOS
I installed dual R9 280x and got a high Lexmark score. However, sharing a 1080p movie to iTunes didn't reflect any speed advantage over using just one (1) 280x. I started with Yosemite and after updating El Capitan got better render and sharing times. Dual 280x' however are still the same as single 280x. The system sees both cards as HD 7xxx 3072 MB. Any suggestions or ideas on how I can make my render and sharing times faster would be greatly appreciated.
 
Joined
Mar 14, 2014
Messages
744
Motherboard
Z97X-UD5H
CPU
i7-4790K
Graphics
2 x R9 280X
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac Pro
I bought the xfx card you suggested but my system keeps freezing when I try to boot from it. Is there any other setup configurations that are required to make it work? Im plugging into the HDMI port on it.
It boots when I use internal graphics and disable the graphics card in the BIOS

Unsure who you are referring to, I have never suggested buying an XFX card, indeed every report I have seen has shown there may be issues with them. I actually suggest NOT buying an XFX card.

There are a quite a number of threads on XFX 280X cards elsewhere, I'd suggest taping into those as this sticky is specific to the topic.

Thanks

Rob
 
Joined
Mar 14, 2014
Messages
744
Motherboard
Z97X-UD5H
CPU
i7-4790K
Graphics
2 x R9 280X
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac Pro
I installed dual R9 280x and got a high Lexmark score. However, sharing a 1080p movie to iTunes didn't reflect any speed advantage over using just one (1) 280x. I started with Yosemite and after updating El Capitan got better render and sharing times. Dual 280x' however are still the same as single 280x. The system sees both cards as HD 7xxx 3072 MB. Any suggestions or ideas on how I can make my render and sharing times faster would be greatly appreciated.

Are your cards actually identical? Have you disabled internal graphics?

Rob
 
Joined
Mar 14, 2014
Messages
744
Motherboard
Z97X-UD5H
CPU
i7-4790K
Graphics
2 x R9 280X
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac Pro
They are exactly the same. My motherboard doesn't have a built-in graphics.

The Bruce X benchmark demonstrates the power of having dual 280X cards, try it and see what the time is. It may well be that your video is actually rendered and all the time is data transfer in which case the cards are immaterial.

If your dual 280X cards don't work, then thats the first time I've heard of this issue.

Rob
 
Joined
Dec 30, 2015
Messages
87
Motherboard
Asus z97 Sabertooth Mark II
CPU
i7-4790k
Graphics
ASUS ROG STRIX 480x 8GB
Unsure who you are referring to, I have never suggested buying an XFX card, indeed every report I have seen has shown there may be issues with them. I actually suggest NOT buying an XFX card.

There are a quite a number of threads on XFX 280X cards elsewhere, I'd suggest taping into those as this sticky is specific to the topic.

Thanks

Rob

It was the second amazon link in your first comment. I did want to let you know that I was able to get it to work relatively easy though. I set everything up using internal graphics, and while using internal graphics I downloaded asus's amd 280x Video BIOS. I used clover to inject this video BIOS (no flashing necessary) and it works! I just gave a quick flash in my screen every 2ish minutes but its manageable. Im still trying to find a fix for the flash. Refer to this link for a more in depth description of how I did it.
 
Joined
Feb 19, 2016
Messages
6
Motherboard
gigabyte gaming 3
CPU
i7 4790
Graphics
Gigabyte 7970 OC
Mac
Classic Mac
Mobile Phone
Hi, and thank you for this thread. I have a couple of questions:

If i use a dual gpu setup, does it need to be exactly the same or can i use one r9 280x from Sapphire and one from Asus?

I see that you (Rob) is using three displays. On what display ports please?

You mention 512gb of SSD, I´m thinking one 256gb for system, another as scratch. One 3tb HDD for media ingestion and another 2gb HDD for render export. Pro/cons for this setup?

This setup will be used for the sole purpose of video editing in FCPX and color grading in Resolve. Thanks!
 
Joined
Mar 14, 2014
Messages
744
Motherboard
Z97X-UD5H
CPU
i7-4790K
Graphics
2 x R9 280X
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac Pro
Hi, and thank you for this thread. I have a couple of questions:

If i use a dual gpu setup, does it need to be exactly the same or can i use one r9 280x from Sapphire and one from Asus?

I see that you (Rob) is using three displays. On what display ports please?

You mention 512gb of SSD, I´m thinking one 256gb for system, another as scratch. One 3tb HDD for media ingestion and another 2gb HDD for render export. Pro/cons for this setup?

This setup will be used for the sole purpose of video editing in FCPX and color grading in Resolve. Thanks!

I only have two identical 280X cards. I would assume (but have no way to verify it), that FCPX will check the GPU ID and if they are not the same, will treat them as different cards. My personal view would be to have two identical cards, if you already have the two different cards try them and see, if you only have one, buy an identical one to pair it with. Why create issues if you don't need to?

All my displays are DVI output. None of my monitors use HDMI or DP.

Your use of HDD's and SDD's seem OK. 256GB for system is OK. Not sure about how FCPX uses scratch disk. I use a single 512GB for OS X and Apps so never an issue. The rest is just storage.

Can't comment on Resolve as don't use it.

Rob
 
Joined
Mar 1, 2012
Messages
28
Motherboard
Maximus Rog X
CPU
8700k
Graphics
Radeon 580
Hello!

I am experiencing something strange with this build - and it happens (I think) since about 1 month. No idea what changed to be honest:

(Ga Z97x UD5H BK, I74770K 32GB RAM Dual R280x GPU)



After playing back HD or 4K (doesnt matter) - rendered or unrendered - (doesnt matter) the Playback STUTTERS for about 3-5 seconds after about 15-45 seconds. This can be reproduced with every timeline. Stuttering means dropped frames AND dropped audio. The playback then "catches up" - you can literally see this on my monitor (both via GPU and Decklink Mini SDI) and then it continues for about 15-45 secs again --- and so on.

I have a CPU workload graph running - and when the stuttering happens FCPX drops from 95% usage (1core) to 10% and then up to 140% and then to 95% again. When rendering it goes up to 700%.

Unworkable and unshowable :(

Any ideas??

Thank you


EDIT: I tried to disable throttling etc in BIOS, I even tried Overclocking - doesnt change anything.
 
Status
Not open for further replies.
Top