Contribute
Register

Final Cut Pro X (10.3.2) Crashes

Joined
Aug 9, 2011
Messages
18
Motherboard
GA-B250M-D3H
CPU
i5-6500
Graphics
Sapphire Pulse RX 580 (8GB)
My problem was a SSDT that undid my ig-platform-id in Clover.
Basically, enable iGPU in BIOS with the right settings, choose proper SMBIOS, inject Intel in Clover, add right platform-id for your iGPU and whatever else you need to get your discrete GPU working.
Hey Zipb, can you please share your config file? I'm in similar situation with similar hardware.

Thanks
 
Joined
Dec 4, 2014
Messages
156
Motherboard
GA-Z170X Ultra Gaming
CPU
i7-7700K
Graphics
Vega 56
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
Android
I will see if switching off the iGPU makes FCP behave, but I want Intel quicksync and I need the iGPU for that.
Did it work for you now? I want quick Sync with iGPU too.
But when I have both dGPU and iGPU enabled FCPX crashes.
(Mojave and FCPX 10.4.5)


I have the same question as
Torrijos
What are the correct parameters in Clover to make HD4000 Ivybridge desktop work alongside second gfx card. I can't seem to find anywhere working information. Setting only the ig-platformi-id doesn't do the trick.
Do you have iGFX and FCPX working along with dGPU??
 
Joined
Aug 25, 2012
Messages
685
Motherboard
Gigabyte Z390 Designare
CPU
i9 9900k
Graphics
RX480
Mac
MacBook Pro
Classic Mac
Performa, Power Mac, PowerBook
Mobile Phone
iOS
I am still on 10.13.1. Haven't used FCP in ages. I have not tested FCP in Mojave at all. Waiting for OSX10.14.4 and HEVC 10-bit support.
 
Joined
Dec 4, 2014
Messages
156
Motherboard
GA-Z170X Ultra Gaming
CPU
i7-7700K
Graphics
Vega 56
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
Android
I'm using 10.14.4 now. Why are you waiting exactly this version?

Now, my FCPX not crashes. I have small Intel QSync. But when export in FCPX CPU loads about 100% (not 560% like my i7-3770), and iGPU is not under load...
 
Top