Contribute
Register

Final Cut Pro Crash on Boot

Joined
Oct 16, 2013
Messages
13
Motherboard
GA-Z170X-Gaming 7
CPU
i7-7700K
Graphics
RX 580
Mac
MacBook Pro
I was able to run FCPX, Motion and Preview with iGFX enabled. The trick is to put the iGFX as the "Initial Display Port" in the BIOS.

Also, I changed the machine profile to "Macmini8,1"
Hey @techana , just checking in that this worked PERFECTLY for me. I just swapped my GTX 970 for a Sapphire Nitro+ RX 580 and couldn't get FCPX to launch, now I've got preview and FCPX working great. Thank you!

I am not using Lilu or Whatevergreen (my RX580 worked OOTB in 10.13.6), and am getting ready to go to 10.14 with my new GPU.

I also tested and was able to get FCPX to launch with iGPU disabled, but preview was very spotty and funky looking if it worked at all.

Current specs that this worked for:
MOBO: Gigabyte Z170X Gaming 7
CPU: i7-7700K
GPU: Sapphire Nitro+ RX 580
 
Joined
Nov 3, 2011
Messages
40
Motherboard
Gigabyte z170X Gaming 5
CPU
i7 6700K
Graphics
AMD 7950
Mac
iMac, Mac Pro
Classic Mac
iMac
Mobile Phone
iOS
Hi, i think i have the awnser for you : To Fix FCPX Crash When Using Intel and GPU AMD or NVIDIA Dual.
1) Install with the Last Multibeast (For 10.14.4, please use Multibeast 11.1.0)
2) Select in Graphics the Patch AKA WhatEvergreen and Only That !!!!
3) Open your Clover Config file with Clover Configurator
4) In Graphics section, you have to choose the IntelChipsetVGA for your Motherboard(CPU)
5) In the Menu Choose from ig-plateform-id (For me in example it's 19120001, i have a Skylake CPU HD530)
6) Now you have to Patch the GFX from Acpi section
7) In List of patch Select GFX0 to IGPU
8) Save and Reboot that All
I Run HD530 and AMD Saphire 580 in Dual, and Get FCPX and quicksync PERFECT and FAST.
 
Last edited:
Joined
May 5, 2019
Messages
1
Motherboard
Gigabyte GA-B85M-HD3
CPU
i3
Graphics
RX 580
Having the same problem. Both FCPX 10.4.4 and Motion 5.4.2 crash on run. Compressor 4.4.3 is running fine. I hope someone can find a solution for this.

Edit 1: using Mojave 10.14.2

Edit 2: I had to switch iGFX on in order to make Preview opens jpeg images. This causes FCPX and Motion to stop working! I switched the iGFX off in the bios and now both FCPX and Motion work but Preview does not :)
Thank you thank you thank you!!
 
Joined
Dec 4, 2014
Messages
156
Motherboard
GA-Z170X Ultra Gaming
CPU
i7-7700K
Graphics
Vega 56
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
Android
My FCPX stopped to run too. I solved it here:
 
Joined
Nov 21, 2013
Messages
55
Motherboard
Gigabyte GA-Z270X-Gaming 7
CPU
i7-7700K
Graphics
Titan X
Mobile Phone
iOS
Hi, i think i have the awnser for you : To Fix FCPX Crash When Using Intel and GPU AMD or NVIDIA Dual.
1) Install with the Last Multibeast (For 10.14.4, please use Multibeast 11.1.0)
2) Select in Graphics the Patch AKA WhatEvergreen and Only That !!!!
3) Open your Clover Config file with Clover Configurator
4) In Graphics section, you have to choose the IntelChipsetVGA for your Motherboard(CPU)
5) In the Menu Choose from ig-plateform-id (For me in example it's 19120001, i have a Skylake CPU HD530)
6) Now you have to Patch the GFX from Acpi section
7) In List of patch Select GFX0 to IGPU
8) Save and Reboot that All
I Run HD530 and AMD Saphire 580 in Dual, and Get FCPX and quicksync PERFECT and FAST.
This fixed it!
Thanks
 
Top