Contribute
Register

Final Cut Pro 10.x crashing every time

Status
Not open for further replies.
Joined
Oct 24, 2013
Messages
1
Motherboard
Built
CPU
AMD
Graphics
GFORCE
Mac
Classic Mac
Mobile Phone
Any time I attempt to load a project the app crashes with no sign of an error code. This problem seems to have come up since I installed my RX480 Here's my configuration:

gpu RX480
cpu 6700K
mobo GAZ170m

SIP is disabled
No NVIDIA Drivers left (former GPU)

Here is the only message from the console upon crash:

kernel : AMFI: allowing exception handler for 'Final Cut Pro' (49266) because SIP is disabled.

Here are the processes from launch to crash:

default 18:06:36.965608 -0400 Final Cut Pro subsystem: com.apple.SkyLight, category: default, enable_level: 0, persist_level: 0, default_ttl: 7, info_ttl: 0, debug_ttl: 0, generate_symptoms: 0, enable_oversize: 0, privacy_setting: 0, enable_private_data: 0
default 18:06:36.992945 -0400 Final Cut Pro Unhandled device string!
default 18:06:36.994317 -0400 Final Cut Pro Unhandled device string!
default 18:06:37.995330 -0400 Final Cut Pro subsystem: com.apple.coreaudio, category: audiocomp, enable_level: 0, persist_level: 0, default_ttl: 0, info_ttl: 0, debug_ttl: 0, generate_symptoms: 0, enable_oversize: 0, privacy_setting: 2, enable_private_data: 0
default 18:06:38.131427 -0400 Final Cut Pro subsystem: com.apple.coreaudio, category: compload, enable_level: 0, persist_level: 0, default_ttl: 0, info_ttl: 0, debug_ttl: 0, generate_symptoms: 0, enable_oversize: 0, privacy_setting: 2, enable_private_data: 0
default 18:06:38.146520 -0400 Final Cut Pro discovered extensions
default 18:06:38.146722 -0400 Final Cut Pro discovered extensions
default 18:06:38.146884 -0400 Final Cut Pro discovered extensions
default 18:06:38.585527 -0400 Final Cut Pro subsystem: com.apple.siri, category: Intents, enable_level: 1, persist_level: 1, default_ttl: 0, info_ttl: 0, debug_ttl: 0, generate_symptoms: 0, enable_oversize: 0, privacy_setting: 0, enable_private_data: 0
default 18:06:38.629057 -0400 Final Cut Pro subsystem: com.apple.clouddocs, category: default, enable_level: 0, persist_level: 0, default_ttl: 14, info_ttl: 0, debug_ttl: 0, generate_symptoms: 0, enable_oversize: 0, privacy_setting: 0, enable_private_data: 0
default 18:06:38.689777 -0400 Final Cut Pro Could not find image named 'AddToTimeline_Normal'.
default 18:06:38.966896 -0400 Final Cut Pro Set a breakpoint at SLSLogBreak to catch errors/faults as they are logged.
error 18:06:38.966931 -0400 Final Cut Pro 0 is not a valid connection ID.
error 18:06:39.068010 -0400 Final Cut Pro 0 is not a valid connection ID.
default 18:06:39.236295 -0400 Final Cut Pro WARNING: The Gestalt selector gestaltSystemVersion is returning 10.9.3 instead of 10.12.3. This is not a bug in Gestalt -- it is a documented limitation. Use NSProcessInfo's operatingSystemVersion property to get correct system version number.
Call location:
default 18:06:39.238155 -0400 Final Cut Pro 0 CarbonCore 0x00007fff973d21e1 ___Gestalt_SystemVersion_block_invoke + 121
default 18:06:39.238178 -0400 Final Cut Pro 1 libdispatch.dylib 0x00007fffab9db0b8 _dispatch_client_callout + 8
default 18:06:39.238190 -0400 Final Cut Pro 2 libdispatch.dylib 0x00007fffab9db075 dispatch_once_f + 38
default 18:06:39.238201 -0400 Final Cut Pro 3 CarbonCore 0x00007fff97360272 _Gestalt_SystemVersion + 976
default 18:06:39.238212 -0400 Final Cut Pro 4 CarbonCore 0x00007fff9735fa8d Gestalt + 139
default 18:06:39.238223 -0400 Final Cut Pro 5 AVCHD 0x000000011bac34cd _ZN13FDVDProcessor12FCDVDManagerC2Ev + 141
default 18:06:39.238236 -0400 Final Cut Pro 6 AVCHD 0x000000011bac8f57 _ZN13FDVDProcessor12FCDVDManager13GetDVDManagerEhhPFvvE + 87
default 18:06:39.239797 -0400 Final Cut Pro The Volume Observer SPI is no longer supported
default 18:06:39.267117 -0400 Final Cut Pro #ICInfo - 209:{ICCommandCenter.m} (Initializing ICCommandCenter)
default 18:06:39.454255 -0400 WindowServer UI updates were finally reenabled by application "<private>" after 1.10 seconds [0.91fps] (server forcibly re-enabled them after 1.00 seconds [1.00fps])
default 18:06:39.575040 -0400 Final Cut Pro subsystem: com.apple.coreaudio, category: AudioHAL_Client, enable_level: 0, persist_level: 0, default_ttl: 0, info_ttl: 0, debug_ttl: 0, generate_symptoms: 0, enable_oversize: 0, privacy_setting: 2, enable_private_data: 0
default 18:06:39.664007 -0400 Final Cut Pro subsystem: com.apple.libsqlite3, category: logging, enable_level: 0, persist_level: 0, default_ttl: 0, info_ttl: 0, debug_ttl: 0, generate_symptoms: 0, enable_oversize: 1, privacy_setting: 2, enable_private_data: 0
default 18:06:39.843011 -0400 Codec32BitTool subsystem: com.apple.SkyLight, category: default, enable_level: 0, persist_level: 0, default_ttl: 7, info_ttl: 0, debug_ttl: 0, generate_symptoms: 0, enable_oversize: 0, privacy_setting: 0, enable_private_data: 0
 

Attachments

  • ezgif-4-2d9bc8644a.gif
    ezgif-4-2d9bc8644a.gif
    727.5 KB · Views: 249
Joined
Dec 12, 2015
Messages
1
Mac
Classic Mac
Mobile Phone
I disabled motherboard integrated graphics in the bios and it fixed the same issue for me. Hope this is helpful.
 
Joined
Jan 17, 2013
Messages
5
Motherboard
PC
CPU
INTEL 4.2 7700k
Graphics
EVGA GTX 980 ti
hey man do you have any problems with compressor? I can't get mines working every time I open the program it opens but everything is white and I can't click anything or see anything.
 
Status
Not open for further replies.
Top