Contribute
Register

Final Cut crash with Vega 64 & fans always at high speed

Joined
Feb 4, 2013
Messages
10
Motherboard
Gigabyte z170X
CPU
Intel i7 7700K
Graphics
NVIDIA GTX 980Ti
Mac
  1. iMac
Hello, I have the following 100% working build:

Intel i7-7700K
Sapphire AMD Vega 64
16GB DDR4 RAM
Corsair H60i Cooler
macOS High Sierra 10.13.2 (17C88)

Since I use this machine as a professional Final Cut editing station, I also enabled Intel's QuickSync using shikigva=12 boot-arg and Shiki.kext + Lilu.kext.

As I read online, AMD Vega 64 is working out of the box with High Sierra, but there's one major problem: as soon as I create a new project on Final Cut Pro 10.3.4, the whole app crashes (if there are some projects created previously in the library, it crashes right after its opening).

It's not a matter of EFI folder because I tried EVERY configuration with Clover (even tried the iMac Pro iMac19,1 SMBIOS, but had no clue).

After hours of trying I found and renamed four drivers inside /System/Library/Extensions:
AppleIntelKBLGraphics.kext --> bAppleIntelKBLGraphics.kext
AppleIntelKBLGraphicsFramebuffer.kext --> bAppleIntelKBLGraphicsFramebuffer.kext
AppleIntelKBLGraphicsGLDriver.bundle --> bAppleIntelKBLGraphicsGLDriver.bundle
AppleIntelKBLGraphicsMTLDriver.bundle --> bAppleIntelKBLGraphicsMTLDriver.bundle

After I renamed these 4 files, Final Cut worked without any issue!
Actually only one driver is causing the crash: AppleIntelKBLGraphicsGLDriver.bundle, but if I rename only that one and leave the other 3 untouched, the whole macOS system becomes unstable (some Metal related issues).
I'm glad to have found this workaround, but I'd prefer to figure out a proper fix for this (maybe a Clover patch to AppleIntelKBLGraphicsGLDriver) in order to keep my system Vanilla (that would allow me to do future updates).

One additional problem that I'm facing the GPU fan running at a high speed even in idle (I have installed HWMonitor + plugins to let the system recognize all the sensors).

I'm sure that it's a Vega 64 issue because as soon as I plug my 980Ti instead, Final Cut works without needing to rename anything and fans are back to normal speed.

Here I'm leaving my Clover configuration, hope it helps.. but as I said, it's not a matter of EFI folder.
 

Attachments

  • EFI.zip
    17.2 MB · Views: 76
Last edited:
Joined
Aug 21, 2010
Messages
188
Motherboard
Gigabyte Z370 Gaming 7
CPU
i7-8700K
Graphics
Radeon VII
Hi @iosonofigo

I have the 56 Vega, and I can actually use it just fine with IGP turned off in Final Cut Pro X (10.3.4). The fans, are running high RPM. Altough just fine with some files, we are not quite there yet.

I would like to test your solution with renaming if you can try something for me, to see if your FCP X is fully able to run as a real mac. Below is tested on my work iMac and runs stabilization perfectly - but I haven't heard 1 hackintosh with Vega cards, that can run this without freeze/crash.

Just import the file (link below from dropbox), and once done, try and use stabilization - try turning it on and off - if it doesn't crash at first).

Link to video clip (101mb) - 1080p H.264
https://www.dropbox.com/s/3jwbdkqvwvj71s3/test.mov?dl=0
 
Joined
Jun 11, 2012
Messages
14
Motherboard
High Sierra 10.13.1
CPU
i7 3960x
Graphics
Vega 56
Mac
  1. MacBook Air
  2. Mac mini
Mobile Phone
  1. iOS
I have the same GPU Fan problem on Vega 56 with the 10.13.2, but with no app lauch, the simply desktop is enough to make the GPU Fan in high speed all the time.

I don't know what to do.
 
Joined
Jul 18, 2014
Messages
3
Motherboard
Gigabyte H170N-Wifi
CPU
6700k
Graphics
RX Vega 64
I have the same GPU Fan problem on Vega 56 with the 10.13.2, but with no app lauch, the simply desktop is enough to make the GPU Fan in high speed all the time.

I don't know what to do.

The issue with RX Vegas fans spinning up is present even in normal Macs using an eGPU solution. Hopefully Apple fix it in 10.13.3.
 
Joined
Feb 4, 2013
Messages
10
Motherboard
Gigabyte z170X
CPU
Intel i7 7700K
Graphics
NVIDIA GTX 980Ti
Mac
  1. iMac
Hi @iosonofigo

I have the 56 Vega, and I can actually use it just fine with IGP turned off in Final Cut Pro X (10.3.4). The fans, are running high RPM. Altough just fine with some files, we are not quite there yet.

I would like to test your solution with renaming if you can try something for me, to see if your FCP X is fully able to run as a real mac. Below is tested on my work iMac and runs stabilization perfectly - but I haven't heard 1 hackintosh with Vega cards, that can run this without freeze/crash.

Just import the file (link below from dropbox), and once done, try and use stabilization - try turning it on and off - if it doesn't crash at first).

Link to video clip (101mb) - 1080p H.264
https://www.dropbox.com/s/3jwbdkqvwvj71s3/test.mov?dl=0

I just tried to run stabilization on that clip with FCPX 10.13.4 and the whole system becomes unstable, it lags and eventually crashes!
Is there any solution to that? Didn’t find anything online...
 
Joined
Aug 21, 2010
Messages
188
Motherboard
Gigabyte Z370 Gaming 7
CPU
i7-8700K
Graphics
Radeon VII
I just tried to run stabilization on that clip with FCPX 10.13.4 and the whole system becomes unstable, it lags and eventually crashes!
Is there any solution to that? Didn’t find anything online...

Thanks for trying.

We can only wait to see if 10.13.3 fixes it (beta 1 is out, and that doesn't fix the fan issue).

Also Final Cut Pro X 10.4 should be released "soon" - that might be more "Vega" friendly with H.264 Files.

Just have to play the waiting game for now.

(PS: the file works with stabalization on Hackintoshes with RX580, and real iMacs with R9 M395)
 
Joined
Mar 13, 2016
Messages
17
Motherboard
Gigabyte GA-Z170MX-Gaming 5
CPU
i7-6700K
Graphics
Vega 56
Mac
  1. Mac Pro
Mobile Phone
  1. Android
Hi @iosonofigo

I have the 56 Vega, and I can actually use it just fine with IGP turned off in Final Cut Pro X (10.3.4). The fans, are running high RPM. Altough just fine with some files, we are not quite there yet.

I would like to test your solution with renaming if you can try something for me, to see if your FCP X is fully able to run as a real mac. Below is tested on my work iMac and runs stabilization perfectly - but I haven't heard 1 hackintosh with Vega cards, that can run this without freeze/crash.

Just import the file (link below from dropbox), and once done, try and use stabilization - try turning it on and off - if it doesn't crash at first).

Link to video clip (101mb) - 1080p H.264
https://www.dropbox.com/s/3jwbdkqvwvj71s3/test.mov?dl=0

I have also a Sapphire Vega 56 with 10.13.2 and max out fans.I clicked on your link out of curiosity ( I don't have FCP ) and my fan reduce speed at minimum.Not hearing it anymore, like it should be when idle . At this moment I have two tabs open in Safari ,one with the text I'm writing and one with your video. When I switch back to the text fan goes at max , switch back to your video back to normal. Specialists can pull some conclusions here.
Semaca
 
Joined
Jan 1, 2011
Messages
166
Motherboard
ASUS Prime X299 Deluxe
CPU
Intel Core i9 7960X
Graphics
AMD Vega Frontier Edition LCS
Mobile Phone
  1. iOS
Its seems to be 10.13.2 is buggy with Vega.
I use a Threadripper 1950X System with Vega Frontier LC on 10.13.0... all is running fine. Final Cut works perfect and Fans are very quiet.
then i use 10.13.2. Just look on your GPU Meter, even on Desktop in Idle you have every few seconds a 100% usage. (all is Idle). That's why the Fan is loud.

We have to wait until iMac Pro with Vega is released, then we should have the perfect card and all bugs are fixed.

P.S. In GeekBench GPU Benchmark and 10.13.0, I got 122000 Points; with 10.13.2,I got 154000. So Apple did optimize something for Vega.
 
Last edited by a moderator:
Joined
Feb 4, 2013
Messages
10
Motherboard
Gigabyte z170X
CPU
Intel i7 7700K
Graphics
NVIDIA GTX 980Ti
Mac
  1. iMac
UPDATE:

I tried the new Final Cut 10.4 for macOS High Sierra and it opens up fine and creates projects without crashing (without having to rename system KBL kexts, so at least this major issue has been fixed).
The issue with clip stabilization is still here tho...

Haven't tried on macOS High Sierra 10.13.3 beta.
 
Joined
Aug 21, 2010
Messages
188
Motherboard
Gigabyte Z370 Gaming 7
CPU
i7-8700K
Graphics
Radeon VII
Thanks for updating iosonofigo. I think you had something corrupt with your old Final Cut Pro X version, as I haven't heard of your trouble with just opening/creating new projects.

I am curious if Vega works 100% in FCP X as eGPU on a real mac (besides the fan is still not fixed) - with the latest beta of 10.13.3.

Perhaps if someone with access to iMac Pro can test if it's the same results, as we get with stabilization on "certain" files.
 
Top