Contribute
Register

FileVault and Sierra guide for noobs like me

Status
Not open for further replies.
Joined
Aug 6, 2018
Messages
14
Motherboard
ASUS Prime H370M-Plus/CSM
CPU
i7-8700
Graphics
RX 580 Pulse
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
That's correct. I tested it and it works fine.
I have not yet FV'ed the internal drive because I'd be hard pressed to get at another mac if the machine breaks.

So I take it your clone has hackintosh driver kext files as other components as well? And with those custom files, FV2 works with no issues correct?
 
Joined
Sep 27, 2015
Messages
39
Motherboard
HP Probook 4740s, 4540s
CPU
i5-3210M/HM76
Graphics
HD 4000
So I take it your clone has hackintosh driver kext files as other components as well? And with those custom files, FV2 works with no issues correct?

That's right. The cloned external disk has its own EFI with all the necessary clover/Rehabman hotpatch stuff.

in /EFI/CLOVER/drivers64UEFI:
-rwxrwxrwx 1 Me staff 12128 10 Okt 21:27 ApfsDriverLoader-64.efi
-rwxrwxrwx 1 Me staff 17280 10 Okt 21:27 AppleImageCodec-64.efi
-rwxrwxrwx 1 Me staff 1732 10 Okt 21:27 AppleImageLoader-64.efi
-rwxrwxrwx 1 Me staff 5376 10 Okt 21:27 AppleKeyAggregator-64.efi
-rwxrwxrwx 1 Me staff 5440 10 Okt 21:27 AppleKeyFeeder-64.efi
-rwxrwxrwx 1 Me staff 2400 10 Okt 21:27 AppleUITheme-64.efi
-rwxrwxrwx 1 Me staff 14656 10 Okt 21:27 AptioInputFix-64.efi
-rwxrwxrwx 1 Me staff 25440 10 Okt 21:27 AptioMemoryFix-64.efi
-rwxrwxrwx 1 Me staff 5696 10 Okt 21:27 DataHubDxe-64.efi
-rwxrwxrwx 1 Me staff 21952 10 Okt 21:27 FSInject-64.efi
-rwxrwxrwx 1 Me staff 7232 10 Okt 21:27 FirmwareVolume-64.efi
-rwxrwxrwx@ 1 Me staff 24900 2 Feb 12:05 HFSPlus.efi
-rwxrwxrwx 1 Me staff 16512 3 Feb 20:05 HPFanReset.efi
-rwxrwxrwx 1 Me staff 13888 10 Okt 21:27 HashServiceFix-64.efi
-rwxrwxrwx 1 Me staff 4480 10 Okt 21:27 SMCHelper-64.efi

in /EFI/CLOVER/kexts/Other:
drwxrwxrwx@ 1 Me staff 512 3 Feb 20:05 AppleALC.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 19:52 AppleBacklightFixup.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 19:52 CodecCommander.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 20:05 FakePCIID.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 20:05 FakePCIID_Intel_HDMI_Audio.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 19:52 FakeSMC.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 19:52 IntelMausiEthernet.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 19:52 Lilu.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 20:05 ProBookAtheros.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 19:52 RealtekRTL8111.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 19:52 SATA-unsupported.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 20:05 USBInjectAll.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 19:52 VoodooPS2Controller.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 19:52 WhateverGreen.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 20:05 XHCI-unsupported.kext

I boot into this EFI/Clover and from there into the FV'ed volume. No issues so far (except that an external HD with encryption really taxes your patience...).
 
Joined
Aug 6, 2018
Messages
14
Motherboard
ASUS Prime H370M-Plus/CSM
CPU
i7-8700
Graphics
RX 580 Pulse
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
That's right. The cloned external disk has its own EFI with all the necessary clover/Rehabman hotpatch stuff.

in /EFI/CLOVER/drivers64UEFI:
-rwxrwxrwx 1 Me staff 12128 10 Okt 21:27 ApfsDriverLoader-64.efi
-rwxrwxrwx 1 Me staff 17280 10 Okt 21:27 AppleImageCodec-64.efi
-rwxrwxrwx 1 Me staff 1732 10 Okt 21:27 AppleImageLoader-64.efi
-rwxrwxrwx 1 Me staff 5376 10 Okt 21:27 AppleKeyAggregator-64.efi
-rwxrwxrwx 1 Me staff 5440 10 Okt 21:27 AppleKeyFeeder-64.efi
-rwxrwxrwx 1 Me staff 2400 10 Okt 21:27 AppleUITheme-64.efi
-rwxrwxrwx 1 Me staff 14656 10 Okt 21:27 AptioInputFix-64.efi
-rwxrwxrwx 1 Me staff 25440 10 Okt 21:27 AptioMemoryFix-64.efi
-rwxrwxrwx 1 Me staff 5696 10 Okt 21:27 DataHubDxe-64.efi
-rwxrwxrwx 1 Me staff 21952 10 Okt 21:27 FSInject-64.efi
-rwxrwxrwx 1 Me staff 7232 10 Okt 21:27 FirmwareVolume-64.efi
-rwxrwxrwx@ 1 Me staff 24900 2 Feb 12:05 HFSPlus.efi
-rwxrwxrwx 1 Me staff 16512 3 Feb 20:05 HPFanReset.efi
-rwxrwxrwx 1 Me staff 13888 10 Okt 21:27 HashServiceFix-64.efi
-rwxrwxrwx 1 Me staff 4480 10 Okt 21:27 SMCHelper-64.efi

in /EFI/CLOVER/kexts/Other:
drwxrwxrwx@ 1 Me staff 512 3 Feb 20:05 AppleALC.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 19:52 AppleBacklightFixup.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 19:52 CodecCommander.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 20:05 FakePCIID.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 20:05 FakePCIID_Intel_HDMI_Audio.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 19:52 FakeSMC.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 19:52 IntelMausiEthernet.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 19:52 Lilu.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 20:05 ProBookAtheros.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 19:52 RealtekRTL8111.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 19:52 SATA-unsupported.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 20:05 USBInjectAll.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 19:52 VoodooPS2Controller.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 19:52 WhateverGreen.kext
drwxrwxrwx@ 1 Me staff 512 3 Feb 20:05 XHCI-unsupported.kext

I boot into this EFI/Clover and from there into the FV'ed volume. No issues so far (except that an external HD with encryption really taxes your patience...).

Very promising information...

Is the external hard-drive a traditional spinning drive? "Since you talk about it taxing your patience"...
 
Joined
Aug 6, 2018
Messages
14
Motherboard
ASUS Prime H370M-Plus/CSM
CPU
i7-8700
Graphics
RX 580 Pulse
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
@sharkoon

Thnx for the update. Might just attempt my build after & hope I have no issues enabling FV2
 
Joined
Mar 30, 2018
Messages
38
Motherboard
Dell Inspiron 7737
CPU
i7-4500U
Graphics
HD 4600
Mac
  1. MacBook Pro
I enables FV on Mojave and added the driver, when I try and boot from the preboot partition I just get a black screen.

When running with -v I see some sort of error relating to graphics and UI.

The last line was:
error!!! unlocking core storage volume (0xe)

I don’t even get to the preboot login screen... any ideas?

Update:

I manually unencrypted the disk from terminal recovery. I am able to boot into the OS using the HDD or PREBOOT partition in Clove without issue.

What could be causing the black screen when FV is enabled?
 
Last edited:

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,363
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I enables FV on Mojave and added the driver, when I try and boot from the preboot partition I just get a black screen.

When running with -v I see some sort of error relating to graphics and UI.

The last line was:
error!!! unlocking core storage volume (0xe)

I don’t even get to the preboot login screen... any ideas?

As per forum rules, please update your profile with your CPU, motherboard, and GPU info.

What graphics are you using? Are you injecting kexts or are kexts installed to /Library/Extensions/?
 
Joined
Mar 30, 2018
Messages
38
Motherboard
Dell Inspiron 7737
CPU
i7-4500U
Graphics
HD 4600
Mac
  1. MacBook Pro
I thought I put my specs in my profile? Did I miss something?

I am injecting some kexts (which I probably shouldn’t have), I am going to check now. I just removed some from EFI related to Intel Graphics. Going to try again and will let you know. It must be a kext as it should just go in at least to the login screen I would imagine.

Right now I’m using:

AppleALC
AppleHda_ALC283
Apple2PS2SmartTouchPad
Codeccommander
FakePCIID
FAKESMC
LILU
NoTouchID
Realtek8111
USBInjectAll
Whatevergreen

Any suggestions on anything to take out?

I already removed 2 FakePCIID for Intel-HD_Graphics/HDMI Audio

System is booting fine with these changes.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
18,363
Motherboard
Asus Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
RX 6600 XT
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I thought I put my specs in my profile? Did I miss something?

I am injecting some kexts (which I probably shouldn’t have), I am going to check now. I just removed some from EFI related to Intel Graphics. Going to try again and will let you know. It must be a kext as it should just go in at least to the login screen I would imagine.

Right now I’m using:

AppleALC
AppleHda_ALC283
Apple2PS2SmartTouchPad
Codeccommander
FakePCIID
FAKESMC
LILU
NoTouchID
Realtek8111
USBInjectAll
Whatevergreen

Any suggestions on anything to take out?

I already removed 2 FakePCIID for Intel-HD_Graphics/HDMI Audio

System is booting fine with these changes.
I thought I put my specs in my profile? Did I miss something?

I am injecting some kexts (which I probably shouldn’t have), I am going to check now. I just removed some from EFI related to Intel Graphics. Going to try again and will let you know. It must be a kext as it should just go in at least to the login screen I would imagine.

Right now I’m using:

AppleALC
AppleHda_ALC283
Apple2PS2SmartTouchPad
Codeccommander
FakePCIID
FAKESMC
LILU
NoTouchID
Realtek8111
USBInjectAll
Whatevergreen

Any suggestions on anything to take out?

I already removed 2 FakePCIID for Intel-HD_Graphics/HDMI Audio

System is booting fine with these changes.

Please click here:
Screen Shot 2019-04-13 at 6.06.52 PM.png
Then select "Account details" to fill in your CPU, motherboard, and GPU info.

When done, the following should be populated:
Screen Shot 2019-04-13 at 6.09.04 PM.png



To be honest, I suspect that you will have better luck with graphics working at the login screen with injected kext. But that's just a guess on my part.

Which Clover drivers are you using to enable FileVault?
 
Joined
Mar 30, 2018
Messages
38
Motherboard
Dell Inspiron 7737
CPU
i7-4500U
Graphics
HD 4600
Mac
  1. MacBook Pro
Hi,

This is what's installed currently.

Driver 64 Bit EFI:
XhciDxe-64​
ApfsDriverLoader-64​
AppleImageloader-64​

Drivers UEFI 64 Bit:
AppleKeyAggregator-64​
DataHibDxe-64​
ApfsDriverLoader-64​
AppleImageLoader-64​
AptioMemoryFix-64​
NvmExpressDxe-64​
PartitionDxe-64​
HFSPlus-64​
 
Status
Not open for further replies.
Top