Contribute
Register

FileVault and Sierra guide for noobs like me

Joined
Sep 29, 2015
Messages
14
CPU
Intel Core i7-6820HQ
Graphics
Nvidia Quadro M2000m
Mac
iMac, MacBook Pro
Mobile Phone
iOS
I've tried searching the forums and google to figure out how to get around this, but since I'm not even sure how to phrase what I need, I haven't been very successful. Do you know, or have any suggestions on where I could look to try to figure this out?
Maybe https://derflounder.wordpress.com/2011/11/23/using-the-command-line-to-unlock-or-decrypt-your-filevault-2-encrypted-boot-drive/

Same site. I know I've seen at least one or two other threads on here of people accidentally enabling FileVault and decrypting from the command line. I think I just linked you to the wrong one.

Also definitely some threads on here: https://www.tonymacx86.com/threads/solved-enabled-filevault-and-cannot-boot.195343/
 
Joined
Jun 24, 2017
Messages
10
Motherboard
ASUS MAXIMUS VIII GENE Micro ATX LGA1151
CPU
Intel Core i7-6700K 4.0 GHz Quad-Core Processor
Graphics
EVGA GeForce GTX 1080 FTW2
Maybe https://derflounder.wordpress.com/2011/11/23/using-the-command-line-to-unlock-or-decrypt-your-filevault-2-encrypted-boot-drive/

Same site. I know I've seen at least one or two other threads on here of people accidentally enabling FileVault and decrypting from the command line. I think I just linked you to the wrong one.

Also definitely some threads on here: https://www.tonymacx86.com/threads/solved-enabled-filevault-and-cannot-boot.195343/
You are the best, KernelPan1c! The first of those links worked perfectly :D

Now to back up all the data that I almost lost...
 
Joined
Feb 22, 2014
Messages
24
Motherboard
PowerMac i7
CPU
i7-4770k @ 4.3Ghz
Graphics
EVGA Geforce GTX 980Ti
Mac
iMac
Mobile Phone
iOS
For everyone else wondering the same thing as posted a couple of months ago:

What keyboard driver works best with Apple USB keyboard? I'm a little comfused about the keyboard step.
I had to use AptioInputFix for my Apple USB Keyboard. Driver was needed since no input worked when booting without it. Other one worked as well but had to reconnect the keyboard when booting. This one does work without reconnecting.
 
Joined
Feb 28, 2014
Messages
27
Motherboard
MSI Z97S SLI Krait Edition
CPU
i5-4570
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
Hi guys,

Any idea why there is no second stage boot logo and transparent background when FileVault is enabled?

I only have the loading bar on a black background for this case. First stage is ok (transparent background + user logo & input filed).

Card is a GTX 650, no Nvidia drivers (none needed anyway). This occurs with both Sierra and High Sierra.

When FileVault is disabled, I don't have a transparent background (which is intended), but I do have the second stage Apple logo and loading bar. Everything looks ok for this case. So it's just when FileVault is enabled.
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,679
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
GTX 970
@arsradu, please update your profile (personal details) with your Motherboard or Make/Model, CPU and Graphics Card.
The Rules said:
Profiles need to contain at least your primary system to assist others with helping you.
 
Joined
Aug 25, 2017
Messages
1
Motherboard
GA-Z97N-WIFI (rev. 1.0)
CPU
Intel Core i7-4790K 4.0GHz
For an OptiPlex 3020 (proprietary BIOS I guess), running Sierra, UEFI mode, with wireless USB keyboard and mouse what should I use?



I tried UsbKbDxe (in EFI/CLOVER/drivers64UEFI) but can't type the password. If I disconnect/reconnect the USB dongle, I'm able so select which partition to boot in Clover, but can't type the password.



The keyboard works in BIOS.
 
Joined
Mar 6, 2016
Messages
93
Motherboard
Asus Maximus VIII Gene
CPU
6700K
Graphics
GTX 1070
Mobile Phone
iOS
This might just be an apple bug. I noticed that when FileVault was enabled the logo and progress bar were really ugly (like placed against the wrong color background), so I just turned on verbose mode instead and it looks fine. This might be different than your issue but I wanted to mention that I'd had some issues with bizarre looking boot logos too.

Hi guys,

Any idea why there is no second stage boot logo and transparent background when FileVault is enabled?

I only have the loading bar on a black background for this case. First stage is ok (transparent background + user logo & input filed).

Card is a GTX 650, no Nvidia drivers (none needed anyway). This occurs with both Sierra and High Sierra.

When FileVault is disabled, I don't have a transparent background (which is intended), but I do have the second stage Apple logo and loading bar. Everything looks ok for this case. So it's just when FileVault is enabled.
 
Joined
Mar 6, 2016
Messages
93
Motherboard
Asus Maximus VIII Gene
CPU
6700K
Graphics
GTX 1070
Mobile Phone
iOS
For an OptiPlex 3020 (proprietary BIOS I guess), running Sierra, UEFI mode, with wireless USB keyboard and mouse what should I use?



I tried UsbKbDxe (in EFI/CLOVER/drivers64UEFI) but can't type the password. If I disconnect/reconnect the USB dongle, I'm able so select which partition to boot in Clover, but can't type the password.



The keyboard works in BIOS.
I'd try the other driver. there are only two, and the exact failure of not loading one (maybe also loading the wrong one) is that you can't type in your password at that screen. Working in BIOS is actually something else. my apple bt keyboard and trackpad work in the bios because I'm using the native Broadcom stuff, but this driver is still necessary because (I think) in that decryption screen the system doesn't have access to the normal working keyboard drivers. Let us know if the other driver works!
 
Joined
Feb 28, 2014
Messages
27
Motherboard
MSI Z97S SLI Krait Edition
CPU
i5-4570
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
This might just be an apple bug. I noticed that when FileVault was enabled the logo and progress bar were really ugly (like placed against the wrong color background), so I just turned on verbose mode instead and it looks fine. This might be different than your issue but I wanted to mention that I'd had some issues with bizarre looking boot logos too.
Thank you very much for your reply. :)

Thing is...this doesn't occur on real macs. Truth be told, I haven't tried that on a mac running a dedicated video card. But it doesn't occur on the ones running on intel GPUs. Basically the transitions between stages is smooth and there is no change in background.

But for the hack, when the background is not black (such as for the second stage boot), I've got a black background.. Could be a bug. But somehow I doubt it. Verbose more didn't do anything in my case (aside from a bunch of text scrolling on my screen before reaching the second stage boot). But once there, it was still black background, no logo, only loading bar.
 
Top