Contribute
Register

[FAIL & HELP] - MSI Z97 Gaming 5 / i5 4690k = Should have 4 threads, but only found 5 for Die 0

Joined
Feb 13, 2013
Messages
22
Motherboard
MSI Z97 Gaming 7
CPU
i5 4690k
Graphics
MSI GTX 980 4G
Mac
Classic Mac
Mobile Phone
Hey all :)
So after installing successfully Yosemite 10.10.2 ( even upgraded to 10.10.3 without hassle ) on a i7 860 i'm trying to make it run on the following system

- i5 4690k
- MSI z97 Gaming 5
- 16Gb ( 2x8 ) Kingston Savage
- GTX 980

So, bios is set to optimised defaults ... with Vt-D and CFG Lock disabled ;
GTX 980 is not installed ;
Only 1 stick of memory;
Only the SSD where the system is going to be installed

The big problem is that when i try to enter the install screen, right after booting from USB and choosing the USB install ... the second the gray screen with the apple logo shows up ... i get a Kernel Panic with the following:

Should have 4 threads, but only found 5 for Die 0

ACPI and IOPCIFamily are showing on the Kernel Extensions in backtrace.

I've tried several bootflags with no success ( cpus=1 ... -x ... npci=0x2000 ... )


So my question is ... do any of you guys know a way or why this type of kp shows up ? Any possible fixes?

Thank you all
Pedro.
 
Joined
May 9, 2011
Messages
5,939
Motherboard
GA-Z170X-Gaming 3
CPU
i7-6700
Graphics
Gigabyte GTX 970 WINDFORCE / Intel HD Graphics 530
Mac
iMac
Mobile Phone
iOS
Check in BIOS for Limit CPUID, if it is enabled then disable it.

Also update BIOS to the latest firmware.
 
Joined
Feb 13, 2013
Messages
22
Motherboard
MSI Z97 Gaming 7
CPU
i5 4690k
Graphics
MSI GTX 980 4G
Mac
Classic Mac
Mobile Phone
Hmmm i saw that options in the Bios and was looking at it for 10 seconds thinking if i should enable it or disable it ( don't remember if it was on or off ) :) but i'll try that :p

Thank you So much and i'll keep you informed of the progress :)
 
Joined
Feb 13, 2013
Messages
22
Motherboard
MSI Z97 Gaming 7
CPU
i5 4690k
Graphics
MSI GTX 980 4G
Mac
Classic Mac
Mobile Phone
[FAIL & HELP] - MSI Z97 Gaming 5/7 / i5 4690k = Should have 4 threads, but only found 5 for Die 0

So ... as for updates.

The CMOS on my Gaming 5 died or something similar. That was the the cause for the errors in the title.
I got a Gaming 7 to replace and sent the 5 to RMA.

I finally was able to install yosemite and ... everything is working! :) Almost no pain ... almost.

I had some troubles getting past the install. No boot flags were needed to start the install but i was getting crashes around 9 min left ...

So, the rule of thumb about using "only one ram stick" was one of the causes.
Basically i had to install both ram sticks and activate the XMP profile.

Other thing i had to do ... i don't know why, the installer didn't like my 850 EVO SSD. At least with only 1 partition. So i created 2 partitions or it would give me some weird freezes.

And the other problem, was my install giving the Essentials.pkg error ... i don't know if it was from a corrupted download ... but downloaded Yosemite again and created new bootable USB and worked fine.


Multibeast went fine ... but i tried to changed smbios from Mac Pro 3,1 to iMac 14,2 ... and ... no luck ... no sound and the system was kind of slow ... so i reinstalled everything and left Mac Pro 3,1 smbios.

Other problem i had after multibeast install was ... shutdowns and restarts. Restart was really really slow and shutdown was not working. I tried to filter everything it could be the problem source and at the end, i found out that was the genericUSB kext that was messing everything. So... a delete and repair permissions and voilá :)

I didn't have time to test everything as i wanted yet. Tonight i'm going to install Windows 10 and set a dual boot. During the weekend i will try to do more testing.

Installing GTX 980 was painless. Basically did all the install on the IGP ... installed the nvdia drvs ... and bammm :)

So, at the end of the day, it was a "difficult birth" but the system is really quick and ready for some testing. I got a freeze yesterday during a app install but it was before i removed the usbGeneric kext, so i guess it could be from that.
 
Top