Contribute
Register

EX58-UD5 Clover 10.10 Success (except sleep)

Joined
Jun 10, 2011
Messages
94
Motherboard
Gigabyte EX58-UD5
CPU
Intel i7 920
Graphics
Nvidia 9800GT
Mac
iMac, MacBook Air
Classic Mac
PowerBook
Mobile Phone
iOS
I was able to get clover to work on an EX58-UD5 board and here's my stuff:

GA-EX58-UD5 Mobo
9800GT Video card
i7-950

I got everything working with Unibeast (easy, just remember that you'll need the boot flags -x PCIRootUID=1 GraphicsEnabler=Yes IGPEnabler=no )

Once you've run mutlitbeast everything should be solid except I noticed that I had to keep fixing bios to have AHCI mode and 64 bit power.... I don't have that problem in clover so I didn't worry about a permanent fix for it.

Then I installed clover with the settings in Tony's guide for post install on a legacy system (see attachment clover settings)

Then I used the attached config and dsdt and the 3 kexts from Tony's Clover guide + replacing the vbox file he says to get rid with the HFSPlus-64.efi

Then it's really important to go into clover configurator before rebooting and changing your Graphics section to inject Nvidia. I banged my head against the wall for quite a while because it was injecting intel by default. (see screenshot for what you want to see).

Reboot into the OS X drive (I set the timeout in cover configurator to 0 so that I don't see the clover screen) and now you will need to get sound working for clover... IF YOU TRY TO USE MULTIBEAST AT THIS POINT FOR SOUND YOU WILL BREAK IT :) Trust me, I know... (you'll get the circle with a line though it-- or the "no symbol" where the apple would be during boot) ha ha so the deal is that you have a ALC889a sound codec which apparently is the same as 885... so here's what you do:

Go here:
http://www.tonymacx86.com/audio/143757-audio-realtek-alc-applehda-guide.html

And follow the instructions that start a little way down the page (BOLD SECTION 3) starting with
"3. cloverALC/Clover patched: automatically detects codec and installs all audio files and patches for ALC onboard audio. Audio persists after most Software Updates. Install once and done. Credit: abxite"

Your system may identify your codec as ALC885-- mine did and that's totally ok. Follow the few steps and you'll have a pretty bulletproof system from head to toe...

I made sure to generate my simbios stuff while I was in clover configurator too, but that's it! Hopefully that helps someone!

I really wish I could get sleep to work right, I just don't know what to do there...
 

Attachments

Last edited:
Joined
May 22, 2011
Messages
133
Motherboard
ASUS ROG MAXIMUS VIII GENE LGA 1151 Intel Z170
CPU
Intel i7 6700
Graphics
MSI GTX 1070 Gaming X
Mobile Phone
iOS
I have same setup as yours, i got it through proper boot only problem is no audio, I'm running the script but after stating 885 it tell script doesn't support it.any suggestions?
 
Joined
Jun 10, 2011
Messages
94
Motherboard
Gigabyte EX58-UD5
CPU
Intel i7 920
Graphics
Nvidia 9800GT
Mac
iMac, MacBook Air
Classic Mac
PowerBook
Mobile Phone
iOS
I have same setup as yours, i got it through proper boot only problem is no audio, I'm running the script but after stating 885 it tell script doesn't support it.any suggestions?
Hmmm I don't know enough to give you any advice except that it worked like a charm for me. Perhaps leave a comment on that thread?
 
Joined
May 22, 2011
Messages
133
Motherboard
ASUS ROG MAXIMUS VIII GENE LGA 1151 Intel Z170
CPU
Intel i7 6700
Graphics
MSI GTX 1070 Gaming X
Mobile Phone
iOS
Hey it would be of great help if you could post screenshots of your clover configurator s acpi and boot options , I'll try to cross check my side ,and enable accordingly
Thank in advance
 
Joined
May 22, 2011
Messages
133
Motherboard
ASUS ROG MAXIMUS VIII GENE LGA 1151 Intel Z170
CPU
Intel i7 6700
Graphics
MSI GTX 1070 Gaming X
Mobile Phone
iOS
Hmmm I don't know enough to give you any advice except that it worked like a charm for me. Perhaps leave a comment on that thread?
actually leave the screenshots, i finally got it working xD! i kinda used your dsdt and config since our systems were similar don't seem to be having any issues now :D!!! will work on the sleep part too, if anything comes up will let you know
and thnx again , actually cz of your method only i could get through clover since i was having trouble finding a guide for legacy bios specially this one mob!
 
Joined
Jun 10, 2011
Messages
94
Motherboard
Gigabyte EX58-UD5
CPU
Intel i7 920
Graphics
Nvidia 9800GT
Mac
iMac, MacBook Air
Classic Mac
PowerBook
Mobile Phone
iOS
actually leave the screenshots, i finally got it working xD! i kinda used your dsdt and config since our systems were similar don't seem to be having any issues now :D!!! will work on the sleep part too, if anything comes up will let you know
and thnx again , actually cz of your method only i could get through clover since i was having trouble finding a guide for legacy bios specially this one mob!
Cool, glad you got it!

I blew up like 2 long days getting it going with lots of trial and error, so I am SO glad it helped you. I struggled like crazy, but it's incredibly solid now-- except sleep-- so I'm really happy.
 
Joined
Jun 6, 2012
Messages
55
Motherboard
GA Z87X UD7 TH
CPU
i7 4790k
Graphics
Gigabyte Gtx 760
Mac
MacBook Pro
Classic Mac
Portable, Power Mac
Mobile Phone
Android
@5star,
I try to make my installation (Mavericks 10.9.5) but i have some difficult to configure the system (with clover configurator)
i have the same Mobo and i ask you if you can post the screenset of your configuration

My System is :

CPU- INTEL i7 930

GPU- NVIDIA GTS 250

MOBO - GA EX58 UD5 bios F13

RAM - CORSAIR 12 GB

please let me know
thank you in advance
Fabio
 
Joined
Jun 10, 2011
Messages
94
Motherboard
Gigabyte EX58-UD5
CPU
Intel i7 920
Graphics
Nvidia 9800GT
Mac
iMac, MacBook Air
Classic Mac
PowerBook
Mobile Phone
iOS
Joined
Jun 10, 2011
Messages
94
Motherboard
Gigabyte EX58-UD5
CPU
Intel i7 920
Graphics
Nvidia 9800GT
Mac
iMac, MacBook Air
Classic Mac
PowerBook
Mobile Phone
iOS
Hi Fabio,

I started to make a screencast video for you, but I'm really not sure what you are looking for. With the screenshots provided and the outline above, I am not clear on what trouble you are having. I think there would be some value to making a "start to finish" video, but since the machine is remote as a backup machine being used at a friend's house, I don't really have the ability to tear the machine down to nothing and start over. I wouldn't really have the time to do that even if it was easily accessible.

But if you can outline the issue you're having, I would be happy to try to help you.
 
Top