Contribute
Register

Everything works, but only stable with UseKernelCache=No

Joined
Jul 23, 2011
Messages
35
Motherboard
ASRock Z270 Pro4
CPU
Intel Core i5 7600k
Graphics
ASUS Vega 64 Strix OC
Mac
MacBook Air, Mac mini
Classic Mac
Classic
Mobile Phone
iOS
Hi all,

I got Mountain Lion working on my setup but there are graphical and audio stutters if I have UseKernelCache=Yes in my org.chameleon.Boot.plist. Setting this to "No" fixes all the stuttering but I have a feeling this is a band-aid fix and not getting at the root of the problem. Any ideas? My basic installation process was as follows:

1. Create bootable ML USB key using UniBeast
2. Boot to installer no problem and format my OCZ Summit 120GB SSD to GUID, HFS+ Journaled, complete setup
3. Install 10.8.2, reboot
4. Install using MultiBeast:
-Chameleon
-3rd Party SATA
-3rd Party eSATA
-TRIM Enabler (10.8.x)
-FakeSMC
-Realtek - Lnx2Mac's RealtekRTL81xx

I then copied the DSDT for my motherboard to /Extra as "DSDT.aml"

Installed seperately:
VoodooHDA 2.7.4 from here: http://www.tonymacx86.com/audio/63663-asus-p7p55d-enable-via-vt1828s-sound-10-8-a.html
I found this version was the most stable / recognized the ports most accurately.

org.chameleon.Boot.plist:
Code:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>EthernetBuiltIn</key>
	<string>Yes</string>
	<key>GenerateCStates</key>
	<string>Yes</string>
	<key>GeneratePStates</key>
	<string>Yes</string>
	<key>GraphicsEnabler</key>
	<string>Yes</string>
	<key>AtiConfig</key>
	<string>Uakari</string>
	<key>Kernel</key>
	<string>mach_kernel</string>
	<key>Kernel Flags</key>
	<string>darkwake=0 npci=0x3000</string>
	<key>Legacy Logo</key>
	<string>Yes</string>
	<key>Timeout</key>
	<string>2</string>
	<key>UseKernelCache</key>
	<string>No</string>
	<key>Graphics Mode</key>
	<string>2048x1152x32</string>
</dict>
My setup in case you don't want to check out my profile :D:
ASUS P7P55D PRO (not the newer -E revision)
Intel Core i7 860 @2.8 GHz
Radeon HD 5870
OCZ Summit 120 Gb SSD

I have done a clean install 3 times now and I can confirm the problem does not lie with the kexts. Simply booting with a fresh Chameleon install and no org.chameleon.Boot.plist, and no third party kexts, works. As soon as I introduce UseKernelCache=Yes, the problem happens.
 
Joined
Jul 23, 2011
Messages
35
Motherboard
ASRock Z270 Pro4
CPU
Intel Core i5 7600k
Graphics
ASUS Vega 64 Strix OC
Mac
MacBook Air, Mac mini
Classic Mac
Classic
Mobile Phone
iOS
I also seem to have a problem with sleep - when I hit Sleep it tries for a few seconds (screen turns off) but then bounces back to the login screen without powering anything down.
 
Joined
Dec 19, 2011
Messages
151
Motherboard
Gigabyte GA-Z77-UD5H rev. 1.1
CPU
i5 3570k 3.4ghz (OC 4.3)
Graphics
Nvidia GeForce GTX 660, 2GB; HD4000 both using HDMI Audio
Mac
iMac
Classic Mac
Mobile Phone
iOS
Why not automatically have Multibeast install DSDT.aml and requisite Keats by choosing DSDT install method? Just make sure your DSDT.aml file is on your desktop. You may need NUllCPUPowermanagement.kext to help with issues. Install audio and graphics drivers the same as before as well as trim and sata and esata. Also did you install the i7 SSDT.aml from customizations?

Good luck!
 
Joined
Jul 23, 2011
Messages
35
Motherboard
ASRock Z270 Pro4
CPU
Intel Core i5 7600k
Graphics
ASUS Vega 64 Strix OC
Mac
MacBook Air, Mac mini
Classic Mac
Classic
Mobile Phone
iOS
That is how I did it the first time I installed, but because of the issues I decided to do each install manually to see after which install the problem appeared.

I have not heard about SSDT.aml, but I will check it out! Thanks.

UPDATE: Oh, I didn't realize this was to enable SpeedStep. I have it disabled in my BIOS anyway, so this shouldn't be a problem.
 
Joined
Dec 19, 2012
Messages
8
Motherboard
P55
CPU
I5 760
Graphics
4870 x2
Mac
Classic Mac
Mobile Phone
I'm having a similar problem with my audio, i have a P7P55D mobo which I believe has the same audio chipset as the OP's, which works fine when I disable usekernelcache, but is unusable (although produces some crackly sound) when it is enabled. So I was wondering whether the cache had rebuilt properly. I tried the command
Code:
sudo kextcache -system-prelinked-kernel
And recieved the error
Code:
Kernel file /mach_kernel does not contain requested arch: i386
Which may or may not have anything to do with it, but is it possible that its something to do with ML being x64 and this kext not?

Update: This is not the case, as I still get this error even after removing VoodooHDA.kext
 
Joined
Jul 23, 2011
Messages
35
Motherboard
ASRock Z270 Pro4
CPU
Intel Core i5 7600k
Graphics
ASUS Vega 64 Strix OC
Mac
MacBook Air, Mac mini
Classic Mac
Classic
Mobile Phone
iOS
Which may or may not have anything to do with it, but is it possible that its something to do with ML being x64 and this kext not?
Perhaps this a normal message, as the command probably tries to cache both 32-bit and 64-bit extensions but your system is running 64-bit only?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,949
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I'm having a similar problem with my audio, i have a P7P55D mobo which I believe has the same audio chipset as the OP's, which works fine when I disable usekernelcache, but is unusable (although produces some crackly sound) when it is enabled. So I was wondering whether the cache had rebuilt properly. I tried the command
Code:
sudo kextcache -system-prelinked-kernel
And recieved the error
Code:
Kernel file /mach_kernel does not contain requested arch: i386
Which may or may not have anything to do with it, but is it possible that its something to do with ML being x64 and this kext not?

Update: This is not the case, as I still get this error even after removing VoodooHDA.kext
On ML, you can use:

Code:
sudo kextcache --system-prelinked-kernel -arch x86_64
And then you won't get the warning...
 
Joined
Dec 19, 2012
Messages
8
Motherboard
P55
CPU
I5 760
Graphics
4870 x2
Mac
Classic Mac
Mobile Phone
Yeah, you guys are right. However, aside from enlightening me, we haven't really progressed. Which kind of just bothers me, as it seems to make no sense. (Although I'm extremely new to osx so not a great deal does)
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,949
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Yeah, you guys are right. However, aside from enlightening me, we haven't really progressed. Which kind of just bothers me, as it seems to make no sense. (Although I'm extremely new to osx so not a great deal does)
If you're using VoodooHDA, don't forget to remove AppleHDA.kext. The two cannot co-exist.
 
Top