Contribute
Register

Everything was fine until I made a ****

Joined
May 5, 2017
Messages
62
Motherboard
GA-Z170-HD3P
CPU
i7-6700K
Graphics
RX 570
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Hello everyone, first of all I apologize if I had previously published this post in the wrong place :( I apologize

I was updating my High Sierra in Mojave, I'll explain what I did and what my problems were.

  1. I started Clover on my High sierra
  2. In the left sidebar I selected the SSD where I installed my OS and then I clicked on mount partition
  3. I went to the /EFI/CLOVER/kexts/Other/ path to insert the FakeSMC.kext file downloaded on the site
  4. Then at this point I started the installer downloaded of Mojave from apple store
It was a very long process, it took a long time and after a reboot I got this message



At this point I restarted the mac and it worked properly

I do not know for what stupid reason I did not stop trying to understand the problem and stupidly I downloaded and installed Clover EFI bootloader - https://sourceforge.net/projects/cloverefiboot/

After the installation I had to restart the computer and here the drama !!


When I tried to turn on the computer I came out this screen, and any mode launch between these 3 nothing happens,
I get only a black screen and nothing else :(



I sincerely hope that some of you help me to restore the computer and understand the initial error I had to what it was due to and how I can update it.

Thank you so much for your help, hello friends.
 
Joined
May 5, 2017
Messages
62
Motherboard
GA-Z170-HD3P
CPU
i7-6700K
Graphics
RX 570
Mac
iMac, MacBook Pro
Mobile Phone
iOS
I had stored the USB memory with high sierra boot above created with Unibest hoping to insert it and launch the operating system as a boot from USB but this also gives me a black screen without going forward.

I think at the moment my problem is this Clover boot loader that I installed by mistake ... I'm a fool
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
17,397
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
Are you using the 750 Ti or the integrated CPU graphics ? There are no Mojave drivers for the Nvidia cards yet. No metal 2 support in the older HS drivers.
 
Joined
May 5, 2017
Messages
62
Motherboard
GA-Z170-HD3P
CPU
i7-6700K
Graphics
RX 570
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Are you using the 750 Ti or the integrated CPU graphics ? There are no Mojave drivers for the Nvidia cards yet. No metal 2 support in the older HS drivers.
This is my external graphics card
Gigabyte GV-N75TOC-2GI GeForce GTX 750 Ti 2GB
 
Joined
May 5, 2017
Messages
62
Motherboard
GA-Z170-HD3P
CPU
i7-6700K
Graphics
RX 570
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Ok, I just read this


If using a GeForce GTX 1050, 1050 Ti, 1060, 1070, 1070 Ti, 1080, 1080 Ti, TITAN Pascal, and TITAN Xp 'Pascal' graphics card or NVIDIA GeForce GTX 750, 750 Ti, 950, 960, 970, 980, 980 Ti, and TITAN X 'Maxwell' graphics card, macOS Mojave graphics drivers are not natively supported. Alternate NVIDIA drivers are required.

Note: Alternate NVIDIA Graphics Drivers are not available yet- if you have a Maxwell or Pascal based NVIDIA card, stay on High Sierra for now.
So does that mean you have to wait again since I have this video card?
If only I had read before :(
And now can I solve my situation?
 
Joined
Jul 25, 2012
Messages
6,899
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Ok, I just read this




So does that mean you have to wait again since I have this video card?
If only I had read before :(
And now can I solve my situation?
  • First, please browse to your Personal Details and edit Motherboard and change the confusing "My First Hackintosh" and type in the real Motherboard name you have used in your Build Signature.

  • If you really want to use Mojave now, this is what you can do:
    • Use your Intel® HD Graphics 530 to connect digitally (HDMI/DVI/DP) to your Monitor after Disabling your Nvidia PCIE in BIOS and Enabling IGFX with DVMT Pre-Allocated Memory set at 128M with Intel Processor Graphics(Integrated Graphics) : set as ENABLED.
    • Make sure to add to CLOVER/kexts/Other the required Graphics Support kexts (latest Lilu and Whatevergreen.kext) and
      • config.plist edited to use Intel HD Graphics 530 with
        • Devices_Fake ID _IntelGfx=19128086 and
        • Graphics_ [√]InjectIntel [ ig-platform id] 19120000 or 19120003,
    • If the above does not work, you may have to physically remove the PCIE card after making the BIOS steps listed above and rebooting and force shutting down before the Boot Disk reaches the Clover Boot Manager(CBM) screen and connecting the Video Cable to IGFX.
    • In my case that is what I did instead of relying solely on the BIOS to Disable PCIE GFX (PEG).
 
Joined
Dec 11, 2013
Messages
90
Motherboard
Asus Maximus VI Extreme
CPU
i7-4770K
Graphics
GTX 780
Mac
iMac
Classic Mac
iMac
Mobile Phone
iOS
if you can make a Unibeast USB for Mojave install, then try to boot using it,
then copy the files from the USB EFI's, "EFI/clover/drivers64UEFI" to your SSD EFI's folder

I had a similar problem before when I updated my clover I wasn't able to boot to my system, I got a black screen
then I booted using the Unibeast USB and copied OsxAptioFix2Drv-64.efi from my USB EFI's to system EFI's and this solved my problem
 
Joined
May 5, 2017
Messages
62
Motherboard
GA-Z170-HD3P
CPU
i7-6700K
Graphics
RX 570
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Ok @Mr-E4GLE today I try to make a USB with Mojave using Unibeast.

I hope that when I insert the USB into the computer and turn on, in the Clover screen (the one that comes out in the picture above) I can start the system as you say, without having the same black screen
 
Joined
May 5, 2017
Messages
62
Motherboard
GA-Z170-HD3P
CPU
i7-6700K
Graphics
RX 570
Mac
iMac, MacBook Pro
Mobile Phone
iOS
@cmn699 I do not have to fix the problem of the black screen that comes out of me first?

Before doing all this is not better to fix everything or do you advise me to follow your guide and will also fix the problem of the black screen that I currently have?

I'm confused, I do not know what to do before ...:crazy:
 
Joined
Jul 25, 2012
Messages
6,899
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
iMac, MacBook Pro
Mobile Phone
iOS
@cmn699 I do not have to fix the problem of the black screen that comes out of me first?

Before doing all this is not better to fix everything or do you advise me to follow your guide and will also fix the problem of the black screen that I currently have?

I'm confused, I do not know what to do before ...:crazy:
  • Before you can fix a problem you got to identify the real cause of the problem or the most likely cause of the problem, if you think there could be more than one issue.

  • Reading your post, I could surmise that you could not login to reach your Desktop to fix any issues through MacOS Mojave because of a "black screen" preventing it in the existing system nor could you use the macOS High Sierra USB Installer to fix the problem because eventually you end up with a black screen.

  • As trs96 stated in #3 you were trying to install Mojave with a Video card (Nvidia GeForce GTX 750 Ti) that has no support in Mojave.

  • That itself can cause a Black Display screen
In your initial installation you said, toward the end of your post at #1
At this point I restarted the mac and it worked properly
You might have got a 'normal looking' desktop screen. But you did not upload the "About This Mac">"Overview" screen shot or "System Report...">"Hardware> Graphics and Displays" screen to confirm your Video was performing OK.
  • Taking into consideration all theses factors and to avoid a marathon Troubleshoot with no end in sight, my suggestion is to tackle the root cause using the working hardware in your system (MoBo+CPU+Intel HD 530) to set up the system
  • Later you can try for a PCIE Graphics that will work in Mojave.
  • Does it make sense?
 
Top