Contribute
Register

Ethernet Problem (Self-assigned IP) - Dell T5400+PCI Ethernet Card+High Sierra

Joined
Apr 5, 2019
Messages
1
Motherboard
Dell T5400
CPU
Xeon 54xx
Graphics
nVidia Quadro
I've just installed High Sierra on my old Dell T5400 Workstation, and everything runs well except the Ethernet connection. The on-board ethernet was faulty (BIOS cannot load it and reported error on it) many years ago, and I bought a PCI Ethernet card to substitute for it.

My T5400 configuration:

Motherboard: Dell Precision T5400
Memory: 6GB FB-DIMM (2GB*2 + 1GB*2)
Graphic Card: nVidia Quadro FX580
Ethernet: Planex Communications Inc. GN-1200TC (w/RTL 8169s)
HD: Hitachi Deskstar 160G SATA
BIOS: A011(the latest)

Pretty much the original configuration except the Ethernet card. I use the DSL modem provided by the DSL company, and all other computers connect directly to it using DHCP perfectly (Windows 7, Ubuntu 18.0.4 LTS, Ubuntu Server 14.0.4 LTS). My T5400 used to run Ubuntu 18.0.4 LTS as well and no ethernet issue had ever occurred.

I followed this post to install Hight Sierra: High Sierra works great on old Dell T5400, and I used Multibeast to create necessary files in EFI partition. The RTL drivers in Multibeast didn't work at all (system couldn't even detect the card) so I downloaded the AppleRTL8169Ethernet.kext, and the system could correctly detect the card and the MAC address.

However, I just couldn't connect to the internet and got the "Self-assigned IP address" problem... I tried many approaches found on the web but none of these worked:

1. Deleted certain files in Library/Preferences like this article I found
2. Renew DHCP Lease (System Preferences>Network, select "Ethernet" on the left and click "Advanced...")
3. Renew DHCP Lease after typing random numbers in "DHCP client ID" (System Preferences>Network, select "Ethernet" on the left and click "Advanced...")
4. Manually changed the speed to 10baseT (System Preferences>Network, select "Ethernet" on the left and click "Advanced...>Hardware")
5. Assigned IP address manually (using my other computers' dhcp ip)
6. Checked if there's any duplication of kext in the S/L/E and L/E folders (actually I didn't find any)
7. Re-installed the card and trid different slots
8. Turned off and on the DSL modem
9. Reset the BIOS battery of T5400 mother board (I then actually changed a new one)
10. Tried PPPoe but couldn't connect to the sever
......
.....
...
..

I also found that the System Preference won't notice anything even I unplug the cable, and kept showing the same self-assigned ip. But when I changed the connecting speed to 10baseT I did see the LED lights on the PCI card changed accordingly (means the card being controlled by the system).

If I swapped back the Ubuntu HD, everything run prefectly. Therefore I don't think this is a hardware issue.

Any suggestion? I am almost giving up....
 
Last edited:
Top