Contribute
Register

<< Solved >> Ethernet Not Working High Sierra Z97-G45 GAMING - Killer E2205 Gigabit

Status
Not open for further replies.
Joined
Jan 4, 2019
Messages
7
Motherboard
ASUS TUF B360-PLUS
CPU
i7-9700F 3.0GHZ
Graphics
AMD Radeon RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Hi Everyone I'm new on the Hackitosh world, and I've spent 2 full days trying to make the latests versions of MacOS on My Computer.

Specs:
Mother Board: MSI Z97-G45 GAMING
CPU: i7-4790k
Graphics: GTX 1080
Attached the Clover Config.plist

I'm using the AtherosE2200Ethernet.kext, pretty sure this is the one.
Also tried others Like RealtekRTL8111.kext and IntelMausiEthernet, none of those worked.
When I do the
Code:
kextat | grep "Atheros"
Basically everything shows as normal... Not sure what else to do.. I pretty much did all the steps everyone proposed here in the forum.
There is a bunch of places stating that this Ethernet Card does not work but it's old (2013), I believe the AtherosE2200Ethernet.kext works for this ethernet hardware.

https://www.tonymacx86.com/threads/msi-z97-gaming-5-cant-find-ethernet-connection.184925/ (tried this one)

PS:
First I started with the Mojave version, and it worked, but the Video driver don't have the acceleration and I could not stand how everything was looking without it, anyways it took me a long time to make the Ethernet Work on the Mojave... and after a lot of tweaking and about 6 hours, I got the Ethernet to work on Mojave.
Now I need help with the High Sierra, I did all the steps I did on the Mojave Installations and still does not work
Any help is very much appreciated!

Kind Regards
 

Attachments

  • config.plist
    7.6 KB · Views: 156
Joined
Jan 4, 2019
Messages
7
Motherboard
ASUS TUF B360-PLUS
CPU
i7-9700F 3.0GHZ
Graphics
AMD Radeon RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Anyone can shed a little light please?
 
Joined
Jan 4, 2019
Messages
7
Motherboard
ASUS TUF B360-PLUS
CPU
i7-9700F 3.0GHZ
Graphics
AMD Radeon RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Hi everyone.
Just wanted to let you guys know about the solution i found.
This Ethernet thing was a pain in my but....

I Installed MacOS High Sierra using Unibeast and Post install with MultiBeast
The Uibeast when generating the USB creates the EFI Partition with Varius Ethernet kext (at least on my case it did)
I removed all the Ethernet .kext's this is important

On the Post install i ran Multibeast selecting with the following informations (note the version of the AtherosE2200Ethernet )

Simple, but did the trick for me... but took me many many tries to get to this point
 
Joined
Jan 4, 2019
Messages
7
Motherboard
ASUS TUF B360-PLUS
CPU
i7-9700F 3.0GHZ
Graphics
AMD Radeon RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Screen Shot 2019-01-10 at 17.47.47.png

Forgot to insert the config
Agian note the Version of the AtherosE2200Ethernet v2.1.0 to run on my Z97-G45 GAMING - Killer E2205
 
Joined
Jul 17, 2014
Messages
15
Motherboard
AsRock Z370-ITX/ac
CPU
i7-8770K
Graphics
GTX 1050 Ti
View attachment 378157
Forgot to insert the config
Agian note the Version of the AtherosE2200Ethernet v2.1.0 to run on my Z97-G45 GAMING - Killer E2205

AMAZING!!! I was having trouble with this for days! Even bought a USB Ethernet adapter!! My problem was that I was using the AtherosE2200Ethernet v2.2.2 driver (latest, and the only one available in the GitHub releases), and it is NOT backwards compatible!!!!

THANK YOU!!!
 
Joined
Jul 17, 2014
Messages
15
Motherboard
AsRock Z370-ITX/ac
CPU
i7-8770K
Graphics
GTX 1050 Ti
View attachment 378157
Forgot to insert the config
Agian note the Version of the AtherosE2200Ethernet v2.1.0 to run on my Z97-G45 GAMING - Killer E2205

r4t40, I got it working with the latest AtherosE2200Ethernet v2.2.2 kext. See my repo:
 
Status
Not open for further replies.
Top