Contribute
Register

Ethernet cable connected, no internet

Joined
Mar 20, 2016
Messages
9
Motherboard
HP Pavilion 15-ab215nd
CPU
Intel i3-5020u 9-series
Graphics
Intel HD Graphics 5500 & AMD Radeon R7 M360
Hello,

After reading the FAQ and doing a successful install of MacOS Sierra on my HP laptop, I tried to get the ethernet working.
I installed the RealtekRTL8100.kext from mieze (from the FAQ). It recognises the ethernet cable but there is no connection to the internet. I've read every forum post with the same ethernet card and people that have the same problem. And I installed some other kexts but those didn't work at all.
Name: Realtek PCIe FE Family Controller
Hardware id: PCI\VEN_10EC&DEV_8136&SUBSYS_8099103C&REV_0A
It should be a RTL8101e.
I've a dual boot with Windows 10 and everything is working fine there.
Can someone please help me?

Screen Shot 2017-02-22 at 08.36.41.png Screen Shot 2017-02-22 at 08.37.03.png Screen Shot 2017-02-22 at 08.37.19.png Screen Shot 2017-02-22 at 08.38.05.png
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
189,206
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hello,

After reading the FAQ and doing a successful install of MacOS Sierra on my HP laptop, I tried to get the ethernet working.
I installed the RealtekRTL8100.kext from mieze (from the FAQ). It recognises the ethernet cable but there is no connection to the internet. I've read every forum post with the same ethernet card and people that have the same problem. And I installed some other kexts but those didn't work at all.
Name: Realtek PCIe FE Family Controller
Hardware id: PCI\VEN_10EC&DEV_8136&SUBSYS_8099103C&REV_0A
It should be a RTL8101e.
I've a dual boot with Windows 10 and everything is working fine there.
Can someone please help me?

View attachment 237628 View attachment 237629 View attachment 237630 View attachment 237631
Make sure any BIOS options for "network boot" or "network stack" are disabled.
Otherwise, read FAQ, "Problem Reporting".
 
Joined
Mar 20, 2016
Messages
9
Motherboard
HP Pavilion 15-ab215nd
CPU
Intel i3-5020u 9-series
Graphics
Intel HD Graphics 5500 & AMD Radeon R7 M360
Thank you for replying

I've checked the BIOS and booting from my network card is disabled.
I've also an option to choose the network protocol:
  • IPv4 (UEFI)
  • IPv6 (UEFI)
  • IPv4 + IPv6 (UEFI)
I tried them al, didn't work. By default, it is IPv4 + IPv6 (UEFI).

I read the FAQ and attached the files.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
189,206
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Thank you for replying

I've checked the BIOS and booting from my network card is disabled.
I've also an option to choose the network protocol:
  • IPv4 (UEFI)
  • IPv6 (UEFI)
  • IPv4 + IPv6 (UEFI)
I tried them al, didn't work. By default, it is IPv4 + IPv6 (UEFI).

I read the FAQ and attached the files.
Network stack options must be disabled in BIOS.
ACPI is not patched. Read FAQ for link.
 
Top