Contribute
Register

error validating the installer data [Mojave]

Status
Not open for further replies.
Joined
Sep 15, 2018
Messages
6
Motherboard
hp pavilion g6 1066se
CPU
i5 2410m
Graphics
hd 3000 + hd 6740m
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
so I changed the SMBIOS of my existing build to MacBook Air using clover configurator and went to the app store, started and cancelled the download of macOS Mojave several times until I managed to get it to download the full 6.03GB installer. I then followed the guide in https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093 and used createinstallmedia command:
Code:
sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/install_macos --nointeraction
this one made the installer fail
I then used the command:
Code:
sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/install_macos --nointeraction --downloadassets
to download any missing assets required by the installer, it then downloaded ~250MB files and proceeded as usual. but it also made the installer fail with the following error:
An error occurred validating the installer data. The download is either damaged or incomplete.
Redownload the installer and try again.

note: this error happened when I used both commands mentioned above.

I also tried to format my drive as APFS and JHFS+ which seemed to have no effect whatsoever. I really don't know what is the problem here and could use some help!

my build is:
  • hp pavilion g6 1066se
  • intel core i5 2450m
  • intel hd 3000 + amd radeon hd 6470m 1366x1768
  • 8gb of ram
I attached my clover configuration since I couldn't boot to the OS to use the automatic PR tool.
 

Attachments

  • clover.zip
    3.9 MB · Views: 80

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,466
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
so I changed the SMBIOS of my existing build to MacBook Air using clover configurator and went to the app store, started and cancelled the download of macOS Mojave several times until I managed to get it to download the full 6.03GB installer. I then followed the guide in https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093 and used createinstallmedia command:
Code:
sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/install_macos --nointeraction
this one made the installer fail
I then used the command:
Code:
sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/install_macos --nointeraction --downloadassets
to download any missing assets required by the installer, it then downloaded ~250MB files and proceeded as usual. but it also made the installer fail with the following error:


note: this error happened when I used both commands mentioned above.

I also tried to format my drive as APFS and JHFS+ which seemed to have no effect whatsoever. I really don't know what is the problem here and could use some help!

my build is:
  • hp pavilion g6 1066se
  • intel core i5 2450m
  • intel hd 3000 + amd radeon hd 6470m 1366x1768
  • 8gb of ram
I attached my clover configuration since I couldn't boot to the OS to use the automatic PR tool.

MacBookPro14,1 is a bit of a stretch on Sandy Bridge hardware.
Maybe SMBIOS of Ivy Bridge would make more sense.
 
Joined
Sep 15, 2018
Messages
6
Motherboard
hp pavilion g6 1066se
CPU
i5 2410m
Graphics
hd 3000 + hd 6740m
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
I re-downloaded the full installer again from another mac and with MacBookPro14,1 SMBIOS and it now works fine but with no QE/CI acceleration, I copied the AppleIntelHD3000* kexts from High Sierra but it kernel panics, so I reverted back to High Sierra until I find a solution to the problem
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,466
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I re-downloaded the full installer again from another mac and with MacBookPro14,1 SMBIOS and it now works fine but with no QE/CI acceleration, I copied the AppleIntelHD3000* kexts from High Sierra but it kernel panics, so I reverted back to High Sierra until I find a solution to the problem

I would not bother with old kexts. Just plan on sticking with 10.13 as you would on a real HD3000 Mac.
 
Status
Not open for further replies.
Top