Contribute
Register

Error -12912 when exporting in h264 in FCPX

Joined
Oct 15, 2011
Messages
798
Motherboard
ASUS Gryphon z87
CPU
i7-4770K
Graphics
HD4600 & RX580
Mac
MacBook Pro
Classic Mac
Apple
Joined
Oct 26, 2013
Messages
928
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
what is teh best way to do this ?
For HD4600, use ig-platform-id 0x04120004 to enable IQSV, need Clover/ACPI rename patches, like GFX0-> IGPU, PEGP-> GFX0, MEI / HECI-> IMEI for both IGPU/DGPU functional properly.
 
Joined
Sep 9, 2018
Messages
5
Motherboard
Gigabyte H370M D3H
CPU
i7-8700K
Graphics
RX 580
Mmm I tried but I've only modified the product name and the bios version… Is that supposed to be enough ?

edit : Hurray ! It seems to have worked !
Howdy! I am very new to the Hackintosh scene. I just got my first system up and running (i7 8700K, AMD 580) and I was running into the same issue as you. I enabled the iGPU and that did the trick, but now of course my AMD GPU isn't getting used at all, and the export times are less than stellar.

Might I ask, how did you go about changing the System Definition? And what exactly did you change it to?

Sorry if this is a really stupid question, but I've been trying to figure it out for a couple of hours now and I'm having no luck.
 
Joined
Feb 12, 2013
Messages
58
Motherboard
GA-Z77X-UD5H rev. 1.1, BIOS F14
CPU
i7-3770K
Graphics
GTX 1050 TI
Mac
MacBook Pro, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
For HD4600, use ig-platform-id 0x04120004 to enable IQSV, need Clover/ACPI rename patches, like GFX0-> IGPU, PEGP-> GFX0, MEI / HECI-> IMEI for both IGPU/DGPU functional properly.

I have an i7 3770k which I believe uses the HD4000... and a GTX 1050-TI 4 GB
How would I get both to work properly together?
-I regularly use Premiere Pro and am having stability issues with the NVRESMAN kext crashing when I put a lot of filters on a 4k video clip.

Turn on the iGHPU in the Bios?
And then do what...? in Clover?

TIA
 
Joined
Oct 26, 2013
Messages
928
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
I have an i7 3770k which I believe uses the HD4000... and a GTX 1050-TI 4 GB
How would I get both to work properly together?
-I regularly use Premiere Pro and am having stability issues with the NVRESMAN kext crashing when I put a lot of filters on a 4k video clip.

Turn on the iGHPU in the Bios?
And then do what...? in Clover?

TIA
Download latest lilu + whatevergreen and place into /EFI/Clover/kexts/other folder, it should auto rename IGPU/GFX0/IMEI and inject correct ig-platform-id, does not need Clover rename patches any more.

For HD4000, use ig-platform-id 0x01620007 to enable IQSV, if whatevergreen does not inject ig-platform-id correctly.
 
Joined
Feb 23, 2018
Messages
13
Motherboard
GA-Z270P-D3
CPU
i7 7700K
Graphics
GeForce Titan 1050i Pascal
Mac
MacBook Air
Mobile Phone
Android
Howdy! I am very new to the Hackintosh scene. I just got my first system up and running (i7 8700K, AMD 580) and I was running into the same issue as you. I enabled the iGPU and that did the trick, but now of course my AMD GPU isn't getting used at all, and the export times are less than stellar.

Might I ask, how did you go about changing the System Definition? And what exactly did you change it to?

Sorry if this is a really stupid question, but I've been trying to figure it out for a couple of hours now and I'm having no luck.
Hello! I'm in the position you where some months ago... Did you manage to solve it?
 
Joined
Dec 4, 2014
Messages
156
Motherboard
GA-Z170X Ultra Gaming
CPU
i7-7700K
Graphics
Vega 56
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
Android
Hello! I'm in the position you where some months ago... Did you manage to solve it?
Please describe your positions and your wantings.
 
Joined
May 15, 2019
Messages
7
Motherboard
Asus Maximus IV Extreme
CPU
i7 2700K
Graphics
Sapphire Radeon RX Vega 64
Please help!!! Did everything as you wrote but it did not help. Still error 12912. What else can be done? Maybe change something with my clover configuration?
Снимок экрана 2019-05-15 в 20.22.14.png
Снимок экрана 2019-05-15 в 20.25.07.png
 
Last edited:
Joined
Dec 4, 2014
Messages
156
Motherboard
GA-Z170X Ultra Gaming
CPU
i7-7700K
Graphics
Vega 56
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
Android
What model of CPU do you have?
 
Joined
May 15, 2019
Messages
7
Motherboard
Asus Maximus IV Extreme
CPU
i7 2700K
Graphics
Sapphire Radeon RX Vega 64
I7 2700k sandy bridge
 
Top