Contribute
Register

erik's "Tiny But Mighty" HTPC: ASRock Z370M-ITX/ac - i5-8400 - UHD 630 Graphics - High Sierra

Joined
May 19, 2018
Messages
40
Motherboard
ASRock Z370M-ITX/ac
CPU
i5-8400
Graphics
UHD 630
Mobile Phone
  1. Android
  2. iOS
Thanks much. Just tried that and now it sleeps if I move the cursor to the hot screen, but if I walk away the screen saver comes on but the display does not sleep.
How long do you have to be idle for before your screen saver starts, and when does the display turn off?
Have you tried unticking "Prevent computer from sleeping automatically when the display is off"?
 
Joined
Jul 7, 2010
Messages
295
Motherboard
GA-P55A-UD4P
CPU
i7-860
Graphics
5870
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Mobile Phone
  1. iOS
I have the screen saver set to start after 5 min but the display does not turn off (should at 15 min).

I'll have to check that last item when I return from traveling. Thanks much for your suggestions.
 
Joined
Nov 5, 2011
Messages
22
Motherboard
ASRock Z370M-ITX/ac
CPU
i5-8400
Graphics
UHD 630
Mac
  1. Mac Pro
Mobile Phone
  1. Android
Hi, friend. I'm problem whit this configuration and Catalina 10.5.2, after sleep restart and go in kernel panic. I read around that it depends on the AppleALC audio kext. Do any of you have the same problem? If so, how did you solve it?
 
Joined
Nov 5, 2011
Messages
22
Motherboard
ASRock Z370M-ITX/ac
CPU
i5-8400
Graphics
UHD 630
Mac
  1. Mac Pro
Mobile Phone
  1. Android
Try the most recent AppleALC dev build 1.4.5.
I try to update with this kext, but from the same problem, as soon as it wakes up from the stop it restarts and goes into the kernel panik, I attach my efi I hope someone can help me.
 

Attachments

  • EFI.zip
    8.6 MB · Views: 69
Joined
Nov 5, 2011
Messages
22
Motherboard
ASRock Z370M-ITX/ac
CPU
i5-8400
Graphics
UHD 630
Mac
  1. Mac Pro
Mobile Phone
  1. Android
Did you try removing the AppleALC.kext completely to see if that is indeed causing the issue?

Remember AppleALC.kext needs to be installed simultaneously with the latest Lilu.kext using kext installer to L/E in order to function properly.

You have a lot of unnecessary kexts in your Clover/Kexts folder. Only Clover/Kexts/Other folder should exist - all other folders - 10.11, 10.12, 10.13, etc - should be deleted. Once you install all kexts to Library/Extensions using kext installer, only essential kexts (FakeSMC/VirtualSMC, Lilu, Whatevergreen, usbinjectall, etc) should be kept in Clover/kexts/other and in config.plist "System Parameters" - "Inject Kexts" should be set to "Detect".

Also most users report having more success using VirtualSMC in Catalina instead of FakeSMC.

Hi and thanks for your help.
First of all I removed AppleAlc from the kext folder and the restart problem is not there.
So I did as you said, in the meantime I tried to delete all the extra folders and then to install lilu.kext and applealc together, with Hackingtool, but it hasn't changed I always have the kernel panic after the stop. I also tried to remove fakesmc and install Virtualsmc but I have the same problem.
 
Joined
Feb 22, 2020
Messages
26
Motherboard
MSI M5
CPU
Core i5 7600K
Graphics
NVIDIA GTX 1080
better performance than most of the PCs. Still in tiny box. Impressive.
 
Joined
Aug 11, 2012
Messages
279
Motherboard
ASRock Z370M-ITX/ac
CPU
i7-8700K
Graphics
Intel Graphics 630
Hi and thanks for your help.
First of all I removed AppleAlc from the kext folder and the restart problem is not there.
So I did as you said, in the meantime I tried to delete all the extra folders and then to install lilu.kext and applealc together, with Hackingtool, but it hasn't changed I always have the kernel panic after the stop. I also tried to remove fakesmc and install Virtualsmc but I have the same problem.
Now that I am using iMacPro 1,1 things are great. I have attached my working EFI for you to try. You will of course need your own serial number stuff.
 

Attachments

  • EFI.zip
    29.5 MB · Views: 75
Joined
Nov 5, 2011
Messages
22
Motherboard
ASRock Z370M-ITX/ac
CPU
i5-8400
Graphics
UHD 630
Mac
  1. Mac Pro
Mobile Phone
  1. Android
Now that I am using iMacPro 1,1 things are great. I have attached my working EFI for you to try. You will of course need your own serial number stuff.
Thanks, you were very kind. But, unfortunately, your EFI did not solve my problem. I purchased a USB audio bundle, and I solved the problem :-D
 
Joined
Jul 7, 2010
Messages
295
Motherboard
GA-P55A-UD4P
CPU
i7-860
Graphics
5870
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Mobile Phone
  1. iOS
OK, I'm needing a little help after upgrading to Catalina. The first issue is that when the computer goes to sleep, the LED backlights on my Philips Brilliance 272P display do not shut off. Second, the fonts look really bad - I've tried enabling/disabling aliasing, and changing the smoothing using the terminal command, but they do not work. Really frustrating. I did not have this experience with El Capitan (skipped Mojave because of the font issue). Any ideas how to work around these two issues? TIA.
 
Top