Contribute
Register

erik's 5ghz Coffee Lake Build: i7-8700k - Asrock Z370 Extreme 4 - GTX 960 - 64gb RAM

Joined
Aug 17, 2017
Messages
33
Motherboard
Asrock Z370 Extreme4
CPU
i5 8400
Graphics
UHD 630
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
Power Mac, PowerBook
Mobile Phone
Android, iOS
Hi erik, Nice build mate.
Have you tested the broadcom wifi + bt m2 chip with this mobo?
Is this working alright? I would like to order mine if it's ok
Cheers
I ordered "https://www.aliexpress.com/item/Original-A1465-A1466-Wifi-Airport-Bluetooth-Card-For-Macbook-Air-11-13-Laptop-2013-Years/32637520988.html?spm=a2g0s.9042311.0.0.582a4c4dr6pKbZ". But sadly it dose not fit in this motherboard. card is larger. So i ordered "https://www.aliexpress.com/item/antennas-802-11-Bluetooth-4-1-Broadcom-BCM943602CS-wireless-wifi-Card-For-Desktops-with-mini-pci/32788764375.html?spm=a2g0s.9042311.0.0.582a4c4dr6pKbZ". This is working OFB.
 

Attachments

Joined
Jun 8, 2018
Messages
7
Motherboard
ASRock Z370 Extreme 4
CPU
Intel i5-8600
Graphics
Integrated
Mac
iMac, MacBook Air, MacBook Pro, Mac mini
Mobile Phone
iOS
I have the same motherboard but Im having an issue when the install page shows up for High Sierra where my keyboard and mouse dont work. Any thoughts or anyone have a similar issue?
 
Joined
Jul 10, 2018
Messages
5
Motherboard
ASRock Z370 Extreme4
CPU
i7-8700
Graphics
Sapphire Radeon Pulse RX 580 8GB
I have the same motherboard but Im having an issue when the install page shows up for High Sierra where my keyboard and mouse dont work. Any thoughts or anyone have a similar issue?
I'm having the same problem with this motherboard. Tried my own vanilla install
I have the same motherboard but Im having an issue when the install page shows up for High Sierra where my keyboard and mouse dont work. Any thoughts or anyone have a similar issue?
I have the same motherboard and am having the same problem. I can boot to the screen where you select a language to setup OSX, but none of my USB ports appear to work so I can't use my mouse or keyboard. I've tried USB 2.0 and 3.0, all ports. I've tried copying the EFI folder from this thread exactly, which you would think would work, but didn't. I've tried vanilla install with clover with only the 15 USB fix as well, many different BIOS settings. I just don't understand why no USB ports are working.
 
Joined
Jul 10, 2018
Messages
5
Motherboard
ASRock Z370 Extreme4
CPU
i7-8700
Graphics
Sapphire Radeon Pulse RX 580 8GB
So I realized the zip attached to OP in this thread has the kexts for USBInjectAll and XHCI-200-series-injector in the wrong folder (not in clover/kexts/other). I also moved the SSDT files to clover/ACPI/patched (not sure if this was crucial or not). Now I have almost all my USB ports working.
 
Joined
Jun 8, 2018
Messages
7
Motherboard
ASRock Z370 Extreme 4
CPU
Intel i5-8600
Graphics
Integrated
Mac
iMac, MacBook Air, MacBook Pro, Mac mini
Mobile Phone
iOS
So I realized the zip attached to OP in this thread has the kexts for USBInjectAll and XHCI-200-series-injector in the wrong folder (not in clover/kexts/other). I also moved the SSDT files to clover/ACPI/patched (not sure if this was crucial or not). Now I have almost all my USB ports working.
Happy to hear thats working. Do you have integrated graphics working on your system? I have tried a number of different option with no luck.
 
Joined
Jul 10, 2018
Messages
5
Motherboard
ASRock Z370 Extreme4
CPU
i7-8700
Graphics
Sapphire Radeon Pulse RX 580 8GB
Happy to hear thats working. Do you have integrated graphics working on your system? I have tried a number of different option with no luck.
My i7-8700 integrated graphics booted fine, had some artifacts/wasn't very smooth but it booted and worked so I could update to 13.6 and then install my Radeon Pulse RX 580.
 
Joined
Jun 8, 2018
Messages
7
Motherboard
ASRock Z370 Extreme 4
CPU
Intel i5-8600
Graphics
Integrated
Mac
iMac, MacBook Air, MacBook Pro, Mac mini
Mobile Phone
iOS
My i7-8700 integrated graphics booted fine, had some artifacts/wasn't very smooth but it booted and worked so I could update to 13.6 and then install my Radeon Pulse RX 580.
How does to Hackintosh perform with the dedicated graphics card? Any artifacts?
 
Joined
Jul 10, 2018
Messages
5
Motherboard
ASRock Z370 Extreme4
CPU
i7-8700
Graphics
Sapphire Radeon Pulse RX 580 8GB
How does to Hackintosh perform with the dedicated graphics card? Any artifacts?
I bought my Sapphire Pulse RX 580 because it's one of Apple's recommended graphics cards for eGPUs. It hasn't disappointed. Flawless graphics with dual monitor setup (although 1080p only, haven't tried higher resolutions). Plus no extra configuration during setup, it was plug and play.
 
Joined
May 16, 2018
Messages
62
Motherboard
ASRock Extreme 4
CPU
i7-8700k
Graphics
RX 560
Hi Erik,
Can you write an detailed process of how you how got the overclocking to work stable with 5GHz, and how you patched SSDT files. Sorry I'm new to hackintoshing. LOL!
 
Top