Contribute
Register

erik's 5ghz Coffee Lake Build: i7-8700k - Asrock Z370 Extreme 4 - GTX 960 - 64gb RAM

Joined
Aug 21, 2011
Messages
214
Motherboard
ASRock Z77E-ITX
CPU
i5 3570K
Graphics
GTX 650
do you reckon i could use the same efi for the asrock z370 taichi?
 
Joined
Oct 15, 2012
Messages
36
Motherboard
ASUS x99 Deluxe Rev1
CPU
5960x at around 4-4.2ghz
Graphics
GTX 980 EVGA Reference
Mac
Classic Mac
Mobile Phone
Sounds like you have good taste :)

Yeah, I'd go with the 8700k. Motherboards are the same cost, the CPU is like $80 more at Newegg, and you get a better CPU. The Z370 chipset is basically identical to the Z270.

High Sierra has been seamless for me. But I booted my old install into Sierra and it loaded fine, so I wouldn't worry about it not working with Sierra.
Went ahead and built something very close to your build and it worked first try with High Sierra! Still a few bits to tinker with but most everything working, thank you for your guide once more!

One issue is overclocking. I've tried using the exact same BIOS settings you've posted but the CPU package multiplier never seems to go past 43 according th HWmonitor and Power Gadget. Is this likely down to the cascading individual core settings being applied? Just wondering if HWmonitor actually reports any frequencies higher than 4.3 on yours? Might have to install Windows at some point to confirm..

Only other issues have been a few USB ports not working and it also seems to eject all external drives when waking up from sleep (giving 'this disk was not ejected properly' messages). I read updating the BIOS has fixed this for some but it did not work for me.

Apart from that pretty much there!
 
Last edited:
Joined
Aug 11, 2013
Messages
7
Mac
Classic Mac
Mobile Phone
Thank you for this guide.. I was totally failing at getting to the MacOS install until I used your EFI folder in UniBeast


I'm struggling to get the machine usable though.

Everything looks nice 4k res with Nvidia graphics installed but I still have no sound devices, Quicktime won't work at all and playing any video in VLC is messed up and choppy and USB storage devices are not readable. can anyone advise please? I have haven't changed anything except put your EFI folder Items in mine. I previously tried running various MultiBeast patches but nothing sorted it

ASROCK z370 Extreme4
I7-8700k
MSI GTX1080 Ti
16GB RAM (single slot)
Samsung 850 EVO
 
Joined
Nov 14, 2016
Messages
2
Thank you for this guide.. I was totally failing at getting to the MacOS install until I used your EFI folder in UniBeast


I'm struggling to get the machine usable though.

Everything looks nice 4k res with Nvidia graphics installed but I still have no sound devices, Quicktime won't work at all and playing any video in VLC is messed up and choppy and USB storage devices are not readable. can anyone advise please? I have haven't changed anything except put your EFI folder Items in mine. I previously tried running various MultiBeast patches but nothing sorted it

ASROCK z370 Extreme4
I7-8700k
MSI GTX1080 Ti
16GB RAM (single slot)
Samsung 850 EVO
For my part, I did not copy over the same EFI folder as erik. In fact, when I did so, it would boot loop. I did a clean install and then used MultiBeast to inject USB ports (200 series), IntelMausiEthernet, fake SMC, iMac 18,3 definition, and Nvidia Web Drivers boot flag. My audio didn't work, as I recall I had injected the Realtek ALC1220 in MultiBeast. I followed the (yes, very time-consuming) guide to troubleshoot audio post-install, and it worked with a clean Apple ALC in the system extensions and the Lilu.kext and CodecCommander in the EFI>kexts>other folder. The only thing not working for me is the front panel audio port (case: fractal design define s windowed), which has issues with static, but I don't care because I use a USB audio interface anyway.
 
Joined
Jan 25, 2013
Messages
56
Motherboard
ASROCK Z370 Taichi-Clover
CPU
i7-8770K
Graphics
RX 580
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
Classic, LC, Quadra, SE
Mobile Phone
iOS
do you reckon i could use the same efi for the asrock z370 taichi?

I am purchasing parts for my second build. I am STILL using the GA-Z77X-UP5TH / GTX 680 and now have a stable High Sierra. The HS install was pretty straight forward. With help from this site I was able to make choices that have stood time. I hope I am in line with this thread when I ask along with this poster, opinion about thoughts of how close the Extreme 4 and the Taichi may be related? I was all over the Extreme 4 but like a few features of the Taichi like DP, Dual LAN, 2 3.1, and wifi. I am sorry if I am off topic.
 
Joined
Jan 25, 2013
Messages
56
Motherboard
ASROCK Z370 Taichi-Clover
CPU
i7-8770K
Graphics
RX 580
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
Classic, LC, Quadra, SE
Mobile Phone
iOS
What slots do you have your memory installed in?
 
Joined
Aug 17, 2017
Messages
33
Motherboard
Asrock Z370 Extreme4
CPU
i5 8400
Graphics
UHD 630
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
Power Mac, PowerBook
Mobile Phone
Android, iOS
erik's 5ghz High Sierra Coffee Lake Build:
i7-8700K - Asrock Z370 Extreme 4 - GTX 960 - 64GB RAM
Hi Erik, i follow your process and install mac successfully. Thanks for your attachment file. But i can not fix IGP. If you can help me, that would be appreciable.
 
Joined
Aug 17, 2017
Messages
33
Motherboard
Asrock Z370 Extreme4
CPU
i5 8400
Graphics
UHD 630
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
Power Mac, PowerBook
Mobile Phone
Android, iOS
Is there anybody can help me about internal graphics?
 
Joined
Aug 17, 2017
Messages
33
Motherboard
Asrock Z370 Extreme4
CPU
i5 8400
Graphics
UHD 630
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
Power Mac, PowerBook
Mobile Phone
Android, iOS
Please help. It was good in 10.13.3. But, after update to 10.13.4, internal graphics not work with Inject Intel.
 
Joined
Jan 28, 2013
Messages
16
Motherboard
Asrock x370 extreme4
CPU
i7-8700K
Graphics
ASUS ROG rx580
Mac
MacBook Pro
Mobile Phone
iOS
Wondering how anyone is getting on with sleep wake and USB disconnection. All the ports are fine, apart from the 3.1 port.
 
Top