Contribute
Register

EPC621D8A(asrock) can not patch CFG Lock.

Joined
Oct 11, 2015
Messages
67
Motherboard
ASRock EPC621D8A - 2.10
CPU
Xneo 6278
Graphics
RX 590
CPU always idle at 3.0GHz when I use clvoer, but opencore works well.

I try to use AppleIntelInfo.kext or Hackintool get some info, but get Fault Cpu panic.

There are no CFG option in my bios. I try to disable CFG Lock with this guide.(Patch CFG Lock)

Manual and Bios about my motherboard.

I found some CFG Lock labels in bios image.(0xB3, 0xB4, 0xB5, 0xB6)

For example:
Code:
0x59B2C         One Of: SAPMCTL_CFG LOCK, VarStoreInfo (VarOffset/VarName): 0xB3, VarStore: 0x5, QuestionId: 0x1835, Size: 1, Min: 0x0, Max 0x1, Step: 0x0 {05 91 DC 19 E4 19 35 18 05 00 B3 00 10 10 00 01 00}
0x59B3D             One Of Option: Disable, Value (8 bit): 0x0 {09 07 B5 00 00 00 00}
0x59B44             One Of Option: Enable, Value (8 bit): 0x1 (default) {09 07 90 0D 30 00 01}
0x59B4B         End One Of {29 02}

So, I get variable '0xB3' and value '0x5', but option is '0x0' or '0x1'.
'setup_var_3 0xB3' in GRUB shell get 0x06.
'setup_var_3 0xB4' in GRUB shell get 0x07.
'setup_var_3 0xB5' in GRUB shell get 0x08.
'setup_var_3 0xB6' in GRUB shell get 0x09.

It is so odd, I do not know what to do, any idea?
 

Attachments

  • C621D8A2.10.zip
    9.5 MB · Views: 47
Joined
Oct 11, 2015
Messages
67
Motherboard
ASRock EPC621D8A - 2.10
CPU
Xneo 6278
Graphics
RX 590
I try to set all variable to 0x00, still in lock mode.
 
Joined
Mar 29, 2011
Messages
855
Motherboard
ASRock X99 Extreme6
CPU
E5-2690 v4
Graphics
Radeon VII
Maybe the incorrect option values for those offsets are indicating that it's the wrong type of setup_var command? I'm not sure, because every EFI is a little different and there's a bunch of different techniques out there.

If setup_var commands can't do it, then you have to try a mod. If you go through the older versions of the UEFITool releases you can get the uefipatch command. It's worth trying that first, since it's simple. Post your output - as there could be errors, or the patches don't match or it doesn't find all the spots that need patching, etc.
 
Joined
Mar 29, 2011
Messages
855
Motherboard
ASRock X99 Extreme6
CPU
E5-2690 v4
Graphics
Radeon VII
I have hex pattern "81E10080000033C1" found, but I do not know how to do.

Get the header-offset and used in GRUB shell?

Those patterns are for patching init code, which is what you have to do if there are not CFG lock setup vars.
 
Joined
Oct 11, 2015
Messages
67
Motherboard
ASRock EPC621D8A - 2.10
CPU
Xneo 6278
Graphics
RX 590
Maybe the incorrect option values for those offsets are indicating that it's the wrong type of setup_var command? I'm not sure, because every EFI is a little different and there's a bunch of different techniques out there.

If setup_var commands can't do it, then you have to try a mod. If you go through the older versions of the UEFITool releases you can get the uefipatch command. It's worth trying that first, since it's simple. Post your output - as there could be errors, or the patches don't match or it doesn't find all the spots that need patching, etc.

I am sorry to bother u again.

I have try patch pattern.
UEFIPatch version 0.26.0.
Bash:
INPUT:
./UEFIPatch C621D8A2.10 patches.txt -o patched

OUTPUT:
parseFile: non-empty pad-file contents will be destroyed after volume modifications
No patches can be applied to input file


It seems that nothing happened.
Something wrong about what I did?
 
Joined
Mar 29, 2011
Messages
855
Motherboard
ASRock X99 Extreme6
CPU
E5-2690 v4
Graphics
Radeon VII
That's too bad. Okay, going back to those IFRs. What led you to choose setup_var3 - did setup_var give an error?

If you can't get those settings changed with EFI shell, there is also a way to do it in Linux. Let me know- I could search for more info on that.
 
Joined
Oct 11, 2015
Messages
67
Motherboard
ASRock EPC621D8A - 2.10
CPU
Xneo 6278
Graphics
RX 590
That's too bad. Okay, going back to those IFRs. What led you to choose setup_var3 - did setup_var give an error?

If you can't get those settings changed with EFI shell, there is also a way to do it in Linux. Let me know- I could search for more info on that.

It seems that there are no difference between setup_var_3 and setup_var. 3581577244931_.pic_hd.jpg

I also asked help here. https://github.com/LongSoft/UEFITool/issues/91
It seems that I have no CFG Lock(0xE2) in my bios.
 
Joined
Mar 29, 2011
Messages
855
Motherboard
ASRock X99 Extreme6
CPU
E5-2690 v4
Graphics
Radeon VII
Oh ok. I assumed you were checking in Windows because you reported, still locked.

You gotta use the RWeverything procedure to know if the mod is needed / working.
 
Top