EP45-UD3P Won't Sleep Running Lion

Discussion in 'General Help' started by matts, Mar 4, 2012.

  1. matts

    matts

    Joined:
    Nov 10, 2011
    Messages:
    24
    Mar 4, 2012 at 7:59 PM #1
    matts

    matts

    Joined:
    Nov 10, 2011
    Messages:
    24
    I built this machine back in Fall 2009 when Lifehacker did a Snow Leopard Hackintosh build. I used exactly the same components. I recently upgraded to Lion using MultiBeast. I have everything working perfectly except sleep. When tried to be put to sleep, the screens go blank, but the system doesn't sleep. I am then unable to wake from this state and have to hard reset.

    I'm looking for help as to what area I need to look at in order to get sleep working. Any thoughts, advice, threads you can point me to would be greatly appreciated.

    Thanks for reading.
     
  2. breiti3000

    breiti3000

    Joined:
    Feb 18, 2012
    Messages:
    458
    Mar 4, 2012 at 8:16 PM #2
    breiti3000

    breiti3000

    Joined:
    Feb 18, 2012
    Messages:
    458
    Do you have a NullCPUPowerManagement.kext sitting in your SLE?
     
  3. matts

    matts

    Joined:
    Nov 10, 2011
    Messages:
    24
    Mar 5, 2012 at 3:14 PM #3
    matts

    matts

    Joined:
    Nov 10, 2011
    Messages:
    24
    Thanks for your reply. Yes, I have NullCPUPowerManagement.kext in my System -> Library -> Extensions.

    I'm not entirely sure of the relation between BIOS and EFI, but my BIOS was giving me intermittent CMOS errors around the time I installed this. This caused intermittent problems with my optical drive. Just yesterday, I reflashed it and the BIOS seems is working fine after making the necessary changes. Are there any BIOS settings that could be interfering with sleep?

    Alternatively, are there any kexts that interfere with NullCPUPowerManagement?
     
  4. breiti3000

    breiti3000

    Joined:
    Feb 18, 2012
    Messages:
    458
    Mar 5, 2012 at 5:44 PM #4
    breiti3000

    breiti3000

    Joined:
    Feb 18, 2012
    Messages:
    458
    Well, in the bios it is advisable to really 'enable' all the sleep related things, not just letting them sit on "auto".

    I had finally success, when I installed all available disk drivers in Multibeast and the misc/USB3 - please check in you MB documentation, what is really available for your board.

    Then I was safe(?) to delete the NullCPUPowerManagement.kext and sleep was finally working :)
     

Share This Page