Contribute
Register

<< Solved >> Enabling hardware acceleration with Nvidia GT 710

Status
Not open for further replies.
Joined
Nov 5, 2011
Messages
14
Motherboard
ASUS Z270m-Plus
CPU
i7-7700K
Graphics
GT 710
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
My build works pretty much great, the only thing I can nitpick about is that I can't enable Apple vt h264 hardware in OBS.
I've set my SMBIOS to iMac 18,3 but it seems like GT 710 requires iMac 14,1
That wouldn't be the right CPU for me though, what kind of trouble am I setting myself up for if I change my SMBIOS?

Did I miss something and there's another way to enable hardware acceleration for my graphics card?
Cheers
 

Edhawk

Moderator
Joined
Aug 2, 2013
Messages
4,553
Motherboard
Asus TUF Z390 Gaming
CPU
i5-8500
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
You could try adding shikigva=40 boot argument to your config.plist. I believe this boot argument tricks the system in to thinking it is an iMac 14,2 without the need to change the SMBIOS. So your Nvidia card works better In macOS.

Not sure it will resolve your specific issue but easy to try out and undo if it doesn’t work.

I have assumed you are using WhateverGreen.kext, as the boot argument won’t work if you aren’t using that kext.
 
Joined
Jul 23, 2012
Messages
803
Motherboard
GA-Z77N-WIFI-F3-Clover
CPU
E3-1225 v2
Graphics
GT 640 | P4000
Mac
  1. Mac mini
macOS do not use Nvidia bulitin hardware H.264 decoder, no way you can use it

macOS can use Intel IGPU or AMD dGPU for hardware H.264 video decoding

the solution is setup the IGPU in headless mode
 
Joined
Nov 5, 2011
Messages
14
Motherboard
ASUS Z270m-Plus
CPU
i7-7700K
Graphics
GT 710
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
You could try adding shikigva=40 boot argument to your config.plist. I believe this boot argument tricks the system in to thinking it is an iMac 14,2 without the need to change the SMBIOS. So your Nvidia card works better In macOS.

Not sure it will resolve your specific issue but easy to try out and undo if it doesn’t work.

I have assumed you are using WhateverGreen.kext, as the boot argument won’t work if you aren’t using that kext.
Cheers mate, sounds simple enough. I'll try it out. Yeah I'm using WhateverGreen, I thought that was compulsory =D


macOS do not use Nvidia bulitin hardware H.264 decoder, no way you can use it

macOS can use Intel IGPU or AMD dGPU for hardware H.264 video decoding

the solution is setup the IGPU in headless mode
OK I'll research that if the boot argument doesn't work. Any tips on where to read up?
 

Edhawk

Moderator
Joined
Aug 2, 2013
Messages
4,553
Motherboard
Asus TUF Z390 Gaming
CPU
i5-8500
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
FYI. WhateverGreen.kext is not compulsory. Usually very helpful but not compulsory.

The only compulsory kexts are FakeSMC.kext or VirtualSMC.kext & Lilu.kext. All other kexts are system dependant.

Case in Point:
I have a HP Server Skylake system that I used a Quadro K4200 dGPU in. The Quadro K4200 is natively supported by macOS, but if I used WhateverGreen with this card in this system, the system kernel panicked and wouldn't boot. When I recently switched this Quadro card to a Gigabyte/Haswell System, the card worked with WhateverGreen without any issues.

This is the world of Hackintosh, nothing is written in stone, other than the use of one or the other of the SMC kexts listed above.
 
Joined
Jul 23, 2012
Messages
803
Motherboard
GA-Z77N-WIFI-F3-Clover
CPU
E3-1225 v2
Graphics
GT 640 | P4000
Mac
  1. Mac mini
Cheers mate, sounds simple enough. I'll try it out. Yeah I'm using WhateverGreen, I thought that was compulsory =D



OK I'll research that if the boot argument doesn't work. Any tips on where to read up?

If you are using WhateverGreen in Clover/OpenCore bootloader, read this guide

If you are not using WhateverGreen in Clover, you have to manually set the framebuffer-less platform-id
 
Joined
Nov 5, 2011
Messages
14
Motherboard
ASUS Z270m-Plus
CPU
i7-7700K
Graphics
GT 710
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
If you are using WhateverGreen in Clover/OpenCore bootloader, read this guide

If you are not using WhateverGreen in Clover, you have to manually set the framebuffer-less platform-id
OK I did read that back when I was going to make the build, but I guess I was too much of an idiot. I'll give it another go and hope I'm less of an idiot now. =D

I'll stick with Clover for now, I'm not up for learning OpenCore at the moment.

Thanks for all the pointers, I'll get back to you if and when I get results. =)
 
Joined
Aug 24, 2015
Messages
26
Motherboard
Asus Z490 TUF (WiFi)
CPU
i9-10850K
Graphics
RX 6900 XT
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Does Hardware DRM work in Big Sur with GT 710?
 
Joined
Nov 5, 2011
Messages
14
Motherboard
ASUS Z270m-Plus
CPU
i7-7700K
Graphics
GT 710
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I fixed it! The boot argument shikigva=40 didn't make any difference.
Didn't get very far into the Idiots Guide until I realized I had to double-check my BIOS settings.
Said and done, I went into the Graphics section and lo and behold, they were set to
Primary display: Auto
CPU graphics multi-monitor: Disabled

Set that to
Primary Display: PCI
CPU graphics multi-monitor: Enabled

And voilà!

So simple, so happy. =3

Thx alot peeps, have a good one!
 

Attachments

  • Screenshot 2021-03-16 at 12.57.53.png
    Screenshot 2021-03-16 at 12.57.53.png
    85.6 KB · Views: 614
Status
Not open for further replies.
Top