Contribute
Register

Enabling both Nvidia Pascal Graphics & Intel HD4600 for macOS Sierra 10.12.6

Joined
Dec 26, 2015
Messages
247
Motherboard
GA-Z97X-UD3H
CPU
i5-4690
Graphics
GTX 1050 Ti
Mobile Phone
Android
Hi everyone,

I recently brought MSI GTX 1050 Ti 4GT OC graphics card and installed macOS 10.12.6 on my machine. Everything went well except the graphics. Previously I was having EL Capitan 10.11.6 with Zotac GT 610 Graphics card.

I already installed the latest Nvidia web driver (378.05.05.25) but it only shows 256MB graphics memory. So I followed:

BIOS - Disable Integrated graphics - Set PEG as Primary
Use a digital connection - DVI or HDMI - VGA is not supported.
Boot with nv_disable=1
May need to update Clover
Install web drivers
Config.plist - Do not inject Intel or Nvidia graphics and no ig-platform-id
Config.plist - Disable SIP fully - CsrActiveConfig 0x67
Edit config.plist - NvidiaWeb = true as per Link
Will need to emulate native NVRAM - Problem 6
Remove nv_disable=1 from config.plist
May need to install Lilu.kext and NvidiaGraphicsFixup.kext to /Library/Extensions
From this I only used :

2. Use a digital connection - DVI or HDMI - VGA is not supported.
4. Install web drivers
5. Config.plist - Do not inject Intel or Nvidia graphics and no ig-platform-id
6. Config.plist - Disable SIP fully - CsrActiveConfig 0x67 (I don't know what SIP is or where is it in the config.plist)
7. Edit config.plist - NvidiaWeb = true as per Link
8. Will need to emulate native NVRAM - Problem 6

Number 8 actually helped though. And it gives me full Nvidia graphics acceleration (4095 MB) but I want Intel HD4600 also. So how do I enable both Nvidia pascal graphics & Intel HD graphics? Besides I'm getting glitches when I open Safari on the top bar apple icon & also safari icons (Sidebar, share, all tabs).

My Configuration is :
  • Motherboard: Gigabyte GA-Z97X-UD3H
  • CPU: Core i5-4690 with Intel HD4600
  • Corsair Vengeance DDR3 8GB RAM
  • GPU: MSI GTX 1050 Ti 4GT OC
  • OS: Sierra 10.12.6
  • System profile: iMac 14,2

Here are the all required files attached. Any help will be appreciated.
 

Attachments

Joined
Dec 26, 2015
Messages
247
Motherboard
GA-Z97X-UD3H
CPU
i5-4690
Graphics
GTX 1050 Ti
Mobile Phone
Android
Update:

I have solved the safari icon glitch problem by
Disable integrated graphics in your BIOS settings.
But I have to disable Integrated Graphics from BIOS :banghead:
 
Joined
Sep 19, 2012
Messages
37
Motherboard
GA-Z97X-UD3H-BK
CPU
i7-4790K
Graphics
GTX 770
Mac
iMac, MacBook, MacBook Air, MacBook Pro
Mobile Phone
iOS
Hi everyone,

I recently brought MSI GTX 1050 Ti 4GT OC graphics card and installed macOS 10.12.6 on my machine. Everything went well except the graphics. Previously I was having EL Capitan 10.11.6 with Zotac GT 610 Graphics card.

I already installed the latest Nvidia web driver (378.05.05.25) but it only shows 256MB graphics memory. So I followed:



From this I only used :

2. Use a digital connection - DVI or HDMI - VGA is not supported.
4. Install web drivers
5. Config.plist - Do not inject Intel or Nvidia graphics and no ig-platform-id
6. Config.plist - Disable SIP fully - CsrActiveConfig 0x67 (I don't know what SIP is or where is it in the config.plist)
7. Edit config.plist - NvidiaWeb = true as per Link
8. Will need to emulate native NVRAM - Problem 6

Number 8 actually helped though. And it gives me full Nvidia graphics acceleration (4095 MB) but I want Intel HD4600 also. So how do I enable both Nvidia pascal graphics & Intel HD graphics? Besides I'm getting glitches when I open Safari on the top bar apple icon & also safari icons (Sidebar, share, all tabs).

My Configuration is :
  • Motherboard: Gigabyte GA-Z97X-UD3H
  • CPU: Core i5-4690 with Intel HD4600
  • Corsair Vengeance DDR3 8GB RAM
  • GPU: MSI GTX 1050 Ti 4GT OC
  • OS: Sierra 10.12.6
  • System profile: iMac 14,2

Here are the all required files attached. Any help will be appreciated.




First thing you should do is learn how to configure your bios first. Search this website for info.

Learn how to patch your motherboard DSDT from Pjalms repository. there is a DSDT for GA-Z97X-UD3H. Search how to patch from this forum.

You should know your intentions first on how you going to use both discreet and integrated graphics because it has a purpose.

Since you have discreet graphics GTX 1050Ti with Intel HD4600 integrated check this link.

https://www.tonymacx86.com/threads/amd-nvidia-primary-display-with-airplay-mirroring.118662/

Learn how to configure your configlist check the wiki. Each and everyone of us have different set up so we are not all the same.

Do a lot of reading and research. I have the same motherboard as yours and I know the frustrations from the start since I do not have any idea on what to do.


When I started hackintoshing several years ago it was hard.

But thanks to Tonymac and this great forum it really improves a lot.


PS: You have a good motherboard so start working on it.
 
Joined
Nov 25, 2012
Messages
3
Motherboard
GA-Z97X-UD5H
CPU
Core I7 4790K
Graphics
Gigabyte GTX 970 G1 Gaming
Mac
Classic Mac
Mobile Phone
With MacOs 10.13.1 I have been able to use HD4600 and Geforce 970 at the same time.
With Clover I use Inject Intel + the correct ig-platform-id (0x0d220003 for my I7 4790k). I also have added IntelGraphicsFixup.kext
And now everything is working fine including Beats 1 radio and films in Itunes.
 
Top