Contribute
Register

Enabling Bluetooth for P8P67 * boards and BT-211

Status
Not open for further replies.
Joined
Mar 26, 2011
Messages
86
Mac
Classic Mac
Mobile Phone
Re: [Solved] Enabling Bluetooth on P8P67 * boards

mjgunn said:
I use a magic mouse and an apple keyboard with a best buy brand USB bluetooth adaptor, no lag or anything like that with it, so it's definitely the onboard BT causing the problem.
Can you show us which bluetooth dongle you have?

Also try side swiping with two fingers. Does that make your mouse freeze?
 
Joined
Jan 24, 2011
Messages
96
Mac
Classic Mac
Mobile Phone
Re: [Solved] Enabling Bluetooth on P8P67 * boards

Yeah I've been using it for a few days, no problem, swiping and everything. I did have a problem the other night when I had a bluetooth headset connected to it, the keyboard was acting funny (disconnecting), but I've used it with the magic mouse, the KB, and a phone connected to the computer without a problem. Here's my info from system info

Apple Bluetooth Software Version: 2.4.0f1
Hardware Settings:
Address: 00-02-76-24-7e-40
Manufacturer: Broadcom
Name: MacPro
Firmware Version: 14 (21147)
Bluetooth Power: On
Discoverable: Yes
Vendor ID: 0
Product ID: 0x1
HCI Version: 4 (0x4)
HCI Revision: 21147 (0x529b)
LMP Version: 4 (0x4)
LMP Subversion: 16910 (0x420e)
Device Type (Major): Computer
Device Type (Complete): Macintosh Desktop
Composite Class Of Device: 3670276 (0x380104)
Device Class (Major): 1 (0x1)
Device Class (Minor): 1 (0x1)
Service Class: 448 (0x1c0)
Requires Authentication: No
 
Joined
Mar 26, 2011
Messages
86
Mac
Classic Mac
Mobile Phone
Re: [Solved] Enabling Bluetooth on P8P67 * boards

Hmm..that's interesting. It's a Broadcom chip. I guess my Atheros chip doesn't like to play nice with the Magic Mouse. O well...I'm going to purchase another adapter than. It's only like $10 so w/e :p

Do you know the exact model of the bluetooth dongle you have?

Thanks for the response!

Apple Bluetooth Software Version: 2.4.0f1
Hardware Settings:
Address: 00-26-83-14-83-ed
Manufacturer: Unknown
Name: MacBook Pro
Firmware Version: 5.39321 (5.39321)
Bluetooth Power: On
Discoverable: Yes
Vendor ID: 0
Product ID: 0x1
HCI Version: 5 (0x5)
HCI Revision: 39321 (0x9999)
LMP Version: 5 (0x5)
LMP Subversion: 39321 (0x9999)
Device Type (Major): Computer
Device Type (Complete): Macintosh Desktop
Composite Class Of Device: 3670276 (0x380104)
Device Class (Major): 1 (0x1)
Device Class (Minor): 1 (0x1)
Service Class: 448 (0x1c0)
Requires Authentication: No
 
Joined
Apr 21, 2011
Messages
79
Mac
Classic Mac
Mobile Phone
Re: [Solved] Enabling Bluetooth on P8P67 * boards

Aznboy1993, do you have wifi? It may interfere with your BT. Try switch to different channel in your router.

I don't remember having mouse freezes in Windows, but I don't use it much either. In my case it happens like once in 10-20 mins, and not related to two-finger swipe, which I often use.
 
Joined
Mar 26, 2011
Messages
86
Mac
Classic Mac
Mobile Phone
Re: [Solved] Enabling Bluetooth on P8P67 * boards

drcrack said:
Aznboy1993, do you have wifi? It may interfere with your BT. Try switch to different channel in your router.

I don't remember having mouse freezes in Windows, but I don't use it much either. In my case it happens like once in 10-20 mins, and not related to two-finger swipe, which I often use.

Yes I have wifi. But there are no devices connected to it near my computer. I'm going to experiment with possible EMF interference. What channel should I set my router to? (It's currently on auto scan...using D-Link DGL-4500)
 
Joined
Apr 21, 2011
Messages
79
Mac
Classic Mac
Mobile Phone
Re: [Solved] Enabling Bluetooth on P8P67 * boards

Aznboy1993 said:
drcrack said:
Aznboy1993, do you have wifi? It may interfere with your BT. Try switch to different channel in your router.

I don't remember having mouse freezes in Windows, but I don't use it much either. In my case it happens like once in 10-20 mins, and not related to two-finger swipe, which I often use.

Yes I have wifi. But there are no devices connected to it near my computer. I'm going to experiment with possible EMF interference. What channel should I set my router to? (It's currently on auto scan...using D-Link DGL-4500)

First, try to simply switch your router off and see if it helps. If not, then it's not it :) If it helps, just try different channels until it gets better.
Also mind microwave ovens.
 
Joined
Apr 21, 2011
Messages
79
Mac
Classic Mac
Mobile Phone
Re: [Solved] Enabling Bluetooth on P8P67 * boards

I can confirm that my Magic Mouse works without freezes with that old Tekram controller being connected to front USB panel. I will now try it connected to the back panel, in case I've got an interference with inside electronics of my computer...
The other thing left is testing Magic Mouse in Windows with internal BT to see if with proper software support from Windows 7 drivers Atheros BT still can play well with Magic Mouse.
 
Joined
Feb 23, 2011
Messages
3
Mac
Classic Mac
Mobile Phone
Re: [Solved] Enabling Bluetooth on P8P67 * boards

I also have a lot of slow down with my magic mouse, it stops responding completely for a few seconds. I have both the magic mouse and apple bluetooth keyboard connected, the keyboard is fine.

I have tried using a cheap (£1) no brand USB Bluetooth adapter, I couldn't have both the keyboard and mouse connected at the same time as one of them (seemingly random which one) would slow down, the keyboard would only type 30 seconds after I had typed and the mouse would be very very slow.
Here is the identifier from system profile for it if that helps.

Apple Bluetooth Software Version: 2.4.0f1
Hardware Settings:
Address: 00-15-83-15-a3-10
Manufacturer: Cambridge Silicon Radio
Firmware Version: 3164
Bluetooth Power: On
Discoverable: Yes
Vendor ID: 0
Product ID: 0x1
HCI Version: 3 (0x3)
HCI Revision: 3164 (0xc5c)
LMP Version: 3 (0x3)
LMP Subversion: 3164 (0xc5c)
Device Type (Major): Computer
Device Type (Complete): Macintosh Desktop
Composite Class Of Device: 260 (0x104)
Device Class (Major): 1 (0x1)
Device Class (Minor): 1 (0x1)
Service Class: 0 (0)
Requires Authentication: No
 
Joined
Mar 26, 2011
Messages
86
Mac
Classic Mac
Mobile Phone
Re: [Solved] Enabling Bluetooth on P8P67 * boards

drcrack said:
I can confirm that my Magic Mouse works without freezes with that old Tekram controller being connected to front USB panel. I will now try it connected to the back panel, in case I've got an interference with inside electronics of my computer...
The other thing left is testing Magic Mouse in Windows with internal BT to see if with proper software support from Windows 7 drivers Atheros BT still can play well with Magic Mouse.
I just ordered this: http://cgi.ebay.com/ws/eBayISAPI.dll?Vi ... K:MEWAX:IT and I'm hoping that will fix the problem.

I've tried moving around my comp to have better signal to my mouse. Nothing. I've tried replacing the batteries and adding aluminum foil between the contacts. Nothing. I've tried using it in Windows and it's even worse. I'm really thinking it's either my mouse or the onboard BT and I'm hoping it's the latter. I will update you guys once I get the BT adapter in form the mail and my Apple Wireless Keyboard as well. Other than that and sleep my OS X installation works 100%. I even have triple monitors setup with my dual 6870 configuration and everything works!

And that'd be nice if you could try using it out back to see if it's EMF interference. For me Windows made it worse but I would also like a third party opinion other than me on this :p

Thanks again!
 
Joined
Dec 21, 2010
Messages
41
Mac
Classic Mac
Mobile Phone
Re: [Solved] Enabling Bluetooth on P8P67 * boards

hey drcrack,

Thanks for the making this. It doesn't work on my P8P67 M Pro's onboard USB, but I did get it working with a $2 USB nipple. I tried yours and then ajg0r's but no go. A note: I couldn't install over yours, I had to manually delete and then install.

Any ideas for me? This is a brand new install not 2 days old.

EDIT: Now after a reboot, Bluetooth will no longer load. I have deleted the three files and started over, with no success. Console gives me the following error:

local.ath3k-firmware-uploader[29] Atheros AR3011 not found
com.apple.launchd[1] (local.ath3k-firmware-uploader[29]) Exited with exit code: 1
 
Status
Not open for further replies.
Top