Contribute
Register

Enabling AMD RX 4XX cards in Sierra.

Joined
Jul 23, 2015
Messages
14
Motherboard
Asus Rog Strix Z270G
CPU
i7-7700K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
Hi guys
Sierra Update 10.12.4
Sapphire RX480
Final Cut Pro X (FCPX) 10.3.3

I've been trying to fix the issues with FCPX keep crashing when loading Library in the latest update of Sierra 10.12.4.
So I found this works for me after I updated the /system/Library/Extensions Kexts for RX 480. and Configured Clover as Below
Devices:
ATI:0x67DF1002
IntelGFX:0x19120003
Graphics:
FB Name: Dayman
IG-Platform-ID: 0a206080
Inject Intel: yes
Inject ATI: yes
SMBIOS: IMac 17.1

Note: you must unplug display cable from Motherboard.

Cinebench Marks:
CPU: 870
OpenGL: 120.02

I hope you some will benefit from this

Best Regards
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,452
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
Hi guys
Sierra Update 10.12.4
Sapphire RX480
Final Cut Pro X (FCPX) 10.3.3

I've been trying to fix the issues with FCPX keep crashing when loading Library in the latest update of Sierra 10.12.4.
So I found this works for me after I updated the /system/Library/Extensions Kexts for RX 480. and Configured Clover as Below
Devices:
ATI:0x67DF1002
IntelGFX:0x19120003
Graphics:
FB Name: Dayman
IG-Platform-ID: 0a206080
Inject Intel: yes
Inject ATI: yes
SMBIOS: IMac 17.1

Note: you must unplug display cable from Motherboard.

Cinebench Marks:
CPU: 870
OpenGL: 120.02

I hope you some will benefit from this

Best Regards

SKL CRB graphics, these are the native Skylake graphics for Apple. Using HD 530 fixes can cause bugs in open CL apps. I recommend these settings on a fresh install for use with RX cards. If you try to do them after you have set HD 530 fixes you need to remove the kext patches for the 530 in clover or they may not work right. Just let the apple drivers do all the work and apps tend to do better.

Did you have HD 530 graphics fixes installed before the crashes?
 
Joined
Feb 9, 2017
Messages
14
Motherboard
Gigabyte GA-Z170X-UD5
CPU
Intel Core i7-6700K
Graphics
Sapphire Radeon NITRO+ Rx 480 8GB GDDR5
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I have Sierra 10.12.4 running and my machines boots, this was huge for me to get this far... ;-).
Mac info.JPG

I have a Radeon Sapphire 480 8gb - I tried following the procdure at https://www.theitsage.com/install-radeon-rx-480-gpu-macos-sierra/ but I have several issues

1. I do not have a systems/extentensions folder for the kexts, I do have a Library/Extensions
2. I cannot get into Recovery mode even if I hold command R....any suggestions?
 
Joined
Jan 28, 2017
Messages
59
Motherboard
msi z77a gd55
CPU
I5 3570k
Graphics
MSI GTX 970 Gaming
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
1. Probably you don't see hidden files. Check this first.
2. You should have the flash drive which you have prepared with unibeast to install sierra. insert it and restart. after bios screen pass, in clover menu you should choose recovery.
 
Joined
Oct 5, 2013
Messages
505
Mac
Classic Mac
Mobile Phone
I have Sierra 10.12.4 running and my machines boots, this was huge for me to get this far... ;-).
View attachment 252000

I have a Radeon Sapphire 480 8gb - I tried following the procdure at https://www.theitsage.com/install-radeon-rx-480-gpu-macos-sierra/ but I have several issues

1. I do not have a systems/extentensions folder for the kexts, I do have a Library/Extensions
...

Take a look inside of the System/Library folder and you should have the missing Extensions folder in there. That location is often referred to as S/L/E or SLE. [In the Finder, select the Go menu option and down at the bottom of the dropdown list is the 'Go to Folder...' choice. You can use it as well to get there.]
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,452
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
I have Sierra 10.12.4 running and my machines boots, this was huge for me to get this far... ;-).
View attachment 252000

I have a Radeon Sapphire 480 8gb - I tried following the procedure at https://www.theitsage.com/install-radeon-rx-480-gpu-macos-sierra/ but I have several issues

1. I do not have a System/Extensions folder for the kexts, I do have a Library/Extensions
2. I cannot get into Recovery mode even if I hold command R....any suggestions?

There is a Terminal command to show hidden folder. I had the same problem with UniBeast instal, I use Cover method now. If you have a spare disk you can run a new install from your hack by downloading and using App Store app. Just select proper disk and load it; when it restarts, make sure to check you clover menu screen because it loads an Apple EFI folder and automatically selects boot form EFI. So you have to manually use cursor arrows to select the new install disk. Total time for a new install is around 20-30 minutes. With a fresh install you should get the proper folders visible.

Before you do that check your config.plist you want CSRactive configuration (in System preferences using Xcode) to be 0x67 not 0x30 which I think UniBeast defaults to. Try that first and reboot to see if it shows up.

If you search the installing sierra with Clover bootloader, you should get the Clover bootloader method which is a little harder than using UniBeast it is worth it to learn. If you learn Clover install, you have many more options available to you.
 
Joined
Feb 9, 2017
Messages
14
Motherboard
Gigabyte GA-Z170X-UD5
CPU
Intel Core i7-6700K
Graphics
Sapphire Radeon NITRO+ Rx 480 8GB GDDR5
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Ok thanks for that, I have the hidden files showing by doing the following
  1. In Terminal, type or paste the following: defaults write com.apple.finder AppleShowAllFiles YES
  2. Press return after that.
  3. Hold the ‘Option/alt’ key, then right click on the Finder icon in the dock and click Relaunch.
Now I am trying to boot in recovery mode, but the boot stalls about 3/4 of the way on the status bar... how can I get into recovery mode..
 

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,452
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
Ok thanks for that, I have the hidden files showing by doing the following
  1. In Terminal, type or paste the following: defaults write com.apple.finder AppleShowAllFiles YES
  2. Press return after that.
  3. Hold the ‘Option/alt’ key, then right click on the Finder icon in the dock and click Relaunch.
Now I am trying to boot in recovery mode, but the boot stalls about 3/4 of the way on the status bar... how can I get into recovery mode..

Can you boot normally and then use time machine then try recovery. You may not have backed up your system while it was functional.
 
Joined
Feb 9, 2017
Messages
14
Motherboard
Gigabyte GA-Z170X-UD5
CPU
Intel Core i7-6700K
Graphics
Sapphire Radeon NITRO+ Rx 480 8GB GDDR5
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi guys
Sierra Update 10.12.4
Sapphire RX480
Final Cut Pro X (FCPX) 10.3.3

I've been trying to fix the issues with FCPX keep crashing when loading Library in the latest update of Sierra 10.12.4.
So I found this works for me after I updated the /system/Library/Extensions Kexts for RX 480. and Configured Clover as Below
Devices:
ATI:0x67DF1002
IntelGFX:0x19120003
Graphics:
FB Name: Dayman
IG-Platform-ID: 0a206080
Inject Intel: yes
Inject ATI: yes
SMBIOS: IMac 17.1

Note: you must unplug display cable from Motherboard.

Cinebench Marks:
CPU: 870
OpenGL: 120.02

I hope you some will benefit from this

Best Regards


Can you explain how you when in the process of making these changes "unplug display cable" and when do you plug it back" ??
 
Joined
Feb 9, 2017
Messages
14
Motherboard
Gigabyte GA-Z170X-UD5
CPU
Intel Core i7-6700K
Graphics
Sapphire Radeon NITRO+ Rx 480 8GB GDDR5
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I did the kext edits on the 4100 and 9510... and this caused my hackintosh to be unable to boot...spent many frustrating hours , even undoing the change, but still had problems..almost ready to bail, many hours & $ spent, but cannot get a working version...not giving up yet but getting
weary...

Now I have started over and erase my Samsung SSD and rebooted to my Carbon Copy clone of my Macbook Pro with Sierra 10.12.4...

I am cloning that working installtion/OS to my SSD on my Hackintosh...

So question is: Is this a viable strategy?
Can I then boot the "cloned" drive on my hacintosh and make the required changes so that it reads my Sapphire Nitro 480??
 
Top