Contribute
Register

Enabling AMD RX 4XX cards in Sierra.

Joined
Sep 28, 2018
Messages
29
Motherboard
Ga h61m s1
CPU
i5 3340
Graphics
Sapphire rx 460 2gb
Mobile Phone
iOS
A
Which version of software are you in?
This is an old thread and now High Sierra 13.6 doesn’t need IGPU. If Your in Sierra you can use a recent clover version and clover graphics setting rad de init or lilu kext and whatevergreenkext. Both are here in the downloads section. You can disable IGPU.
Should I put any boot flag like graphic enabler or inject and or fake id or something like that?
 
Joined
Sep 28, 2018
Messages
29
Motherboard
Ga h61m s1
CPU
i5 3340
Graphics
Sapphire rx 460 2gb
Mobile Phone
iOS
Hey I've installed a new version of clover but I had a black screen so I downgrade to 4173 and I've put lilu and whatever green in 10.12 and in others in the efi partitions and all stays like before, am I doing something wrong?
 
Joined
May 15, 2016
Messages
4,507
Motherboard
GIGABYTE Z170M D3H
CPU
i5-6500
Graphics
RX 480
Mac
iMac
Hey I've installed a new version of clover but I had a black screen so I downgrade to 4173 and I've put lilu and whatever green in 10.12 and in others in the efi partitions and all stays like before, am I doing something wrong?
Sierra 12.3? Have you updated to 12.6?
 
Joined
Sep 28, 2018
Messages
29
Motherboard
Ga h61m s1
CPU
i5 3340
Graphics
Sapphire rx 460 2gb
Mobile Phone
iOS
Sierra 12.3? Have you updated to 12.6?
No i havent tomorrow i will do it and i ll see but i have installed a lot of versions of clover and i ever have black screen except in those that doesnt have radeondeinit i dont know what happens
 
Joined
Sep 28, 2018
Messages
29
Motherboard
Ga h61m s1
CPU
i5 3340
Graphics
Sapphire rx 460 2gb
Mobile Phone
iOS
Sierra 12.3? Have you updated to 12.6?
If i update to 12.6, will stop the black screen?
No i havent tomorrow i will do it and i ll see but i have installed a lot of versions of clover and i ever have black screen except in those that doesnt have radeondeinit i dont know what happens
ll
 
Joined
Sep 28, 2018
Messages
2
Motherboard
HP Z800 WORKSTATION MOTHERBOARD 460838-003 591182-001
CPU
2 x5650
Graphics
gtx 650 visiontek rx480
HI Im trying to get my visiontek rx480 to work with my hp z800 machine with 10.12.6 . those dont have igpu but i have the gtx 650 card that i can use to boot. under system report my card is being recognized unfortunately with no vram . i already changed the info in the 2 kexts files and i installed lilu and whatever green. what could i possibly do now? its a good card but Im at the end of my rope here. thanks
 
Joined
Sep 28, 2018
Messages
29
Motherboard
Ga h61m s1
CPU
i5 3340
Graphics
Sapphire rx 460 2gb
Mobile Phone
iOS
Sierra 12.3? Have you updated to 12.6?
Hi i finally of a lot of problems and reinstalling sierra i updated from sierra to high sierra and now the graphic card work perfectly thanks for all the help
 
Top