Contribute
Register

Enabling AMD RX 4XX cards in Sierra.

Status
Not open for further replies.
Joined
Jul 8, 2017
Messages
4
Motherboard
Gigabyte EX-58-UD5 (X58)
CPU
Intel i7 920
Graphics
Asus RX 480 8GB
Mobile Phone
  1. iOS

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,558
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
I've tested Nvidia gt210, gt710, Nvidia 8400gts and GT730. They all run around $30-40 US and only require inject Nvidia in clover settings to operate and give RX cards acceleration. You get better performance with CPU graphics though so there is a 15-20% performance loss with helper cards in general terms.

On the Bright side there is a user on High Sierra developer beta with a Vega Frontier card using dedicated graphics with a 6900k so the future for RX 480-580 may improve and we may be able to use them normally soon.
 
Joined
May 28, 2012
Messages
58
Motherboard
X99 > Need manufacturer & full model # > See Rules!
CPU
i9 > need model # > See Rules!
Graphics
RX 5700
View attachment 266190 View attachment 266191

Can you run Valley Extreme HD and Heaven at Eztreme settings? These are the GPU standard test many go by. RX 480 runs around 1850-1950 in Valley and Heaven 1100-1300. It would be nice to see well above those for the extreme and extreme hd settings.

Not very good result running in Extreme HD. I have not run the STRIX 980TI in that mode, so won't be able to provide cooperative numbers until I get more water-cooling fluids to install back in system. I'll post those in a few days, along side the STRIX 1080TI. Would also like to test the STRIX RX580, which I have not been able to run at all.

Screen Shot 2017-07-12 at 2.38.55 PM.png
 
Joined
Jul 13, 2015
Messages
4
Motherboard
GA Z68X-UD3-B3
CPU
i5K Sandy Bridge
Graphics
Sapphire RX 480 Nitro
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi!
Please help. After Sierra 10.12.3 update to 10.12.5 no acceleration (no Metal support). Just modified AMD9510Controller and AMDRadeonX4100.
Sapphire RX480 Nitro 8 GB.View attachment 257391View attachment 257392

Hi, Im just trying figure out, what have I done wrong. After I updated those kext files, I got everything alright till Login, at that moment I get Black Screen on both displays... If it boot up in Safe mode, I can see full 8gb memory, but without Metal and with two displays. Originaly did work only one.
I have just one GPU, no internal, so its set to auto or PCIe. Using HDMI and DVI. System 10.12.5

Did I miss any important topic with solution?
 
Joined
Nov 7, 2015
Messages
12
Motherboard
ASUS STRIX ROG Z390-F GAMING
CPU
i5-9600KF
Graphics
Sapphire Pulse RX 5700 XT 8GB
Mobile Phone
  1. Android
  2. Other
Finally..
After update to 10.12.6 RX 470 full working without edit kext, just fake ID 0x67DF1002 but display graphic keep AMD R9 xxx 8192 whereas i already edit AMD9520Controller, R9 xxx replace RX 480 with HEX but the result same

Screen Shot 2017-07-22 at 11.05.02 AM.png
 
Joined
May 28, 2012
Messages
58
Motherboard
X99 > Need manufacturer & full model # > See Rules!
CPU
i9 > need model # > See Rules!
Graphics
RX 5700
If I inject FB and FakeID on x99 with the AMD Vega card, would it have a negative effect? I still can't get the RX580 going :(
 
Joined
Jun 28, 2016
Messages
47
Motherboard
ASUS ROG Strix Z390-E
CPU
i7-8700K
Graphics
RX 580
Mac
  1. Mac mini
Does the RX480 need a piggyback GPU? I’ve tried installing this new updated Sierra I can get into the installation area but when it reboots at the Apple logo the monitor flashes at 75% load and freezes
 
Joined
Jul 16, 2017
Messages
7
Motherboard
GA B150M-D3H
CPU
Core i3-7100 3.9 GHz
Graphics
HD 630
Mac
  1. iMac
Mobile Phone
  1. iOS
Please help me !
I don't see the "AMD9510ControllerKext" on Extensions folder though i ran terminal to unhide. My card is HIS RX 460 2GB
Thanks
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,373
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
HD 4600 / RX 580
I don't see the "AMD9510ControllerKext" on Extensions folder though i ran terminal to unhide.
The AMD9510Controller.kext is located in the System/Library/Extensions folder.

If your System folder is hidden
In Terminal:
Code:
sudo chflags -R nohidden /System
 
Joined
May 28, 2012
Messages
58
Motherboard
X99 > Need manufacturer & full model # > See Rules!
CPU
i9 > need model # > See Rules!
Graphics
RX 5700
I'm still struggling getting RX580 working with Vega as IGPU for an X99 platform on High Sierra. I tried injecting different FB through the clover startup menu, specifically for the RX580 without any luck. Is there anything needed on the clover config for IGPU on x99? As I'm troubleshooting, I was thinking about PCI-E assignment for MacOS.

On my standard setup, I have the main GPU on the 16/X8_1 slot, and the secondary (RX580) on the 16/X8_3 slot. On this configuration it boots to black screen. No changes even if apply different FB names (Guariba, Orinoco, Dayman). When I look at the IOREG output, the VEGA card is on slot BR3A@3

When I swap cards and install the main GPU on the 16/X8_3 slot, and the secondary (RX580) on the 16/X8_1 slot. I get reboots @ gioscreenlockstate. No changes even if apply different FB names (Guariba, Orinoco, Dayman). When I look at the IOREG output, the VEGA card is on slot BR2A@2

I figured that because the OS sees 16/X8_3 slot as BR2A@2, maybe the VEGA needs to be in this slot? How can I get it to stop rebooting?

Screen Shot 2017-07-24 at 8.21.30 AM.png
 
Status
Not open for further replies.
Top