Contribute
Register

El capitan USB issues - possible fix.

Status
Not open for further replies.
Joined
Oct 7, 2011
Messages
140
Motherboard
ASUS ProArt Z490 Creator 10G
CPU
i7-10700K
Graphics
Integrated Graphics Processor
Find Method XWAK in your DSDT...

Code:
Method(XWAK, ...
{
   ..some code...
}

Change it:
Code:
Method(XWAK, ...
{
   Return(0)
   ..some code...
}

What do you do if your DSDT doesn't have XWAK specified in it? I just have WAK in mine in two instances.

Method (WAK, 1, NotSerialized)
{
\_SB.PCI0.LPCB.SWAK (Arg0)
\_SB.PCI0.NWAK (Arg0)
\_SB.PCI0.VGA.OWAK (Arg0)
\WMI0.GENW (Arg0)
OEMW (Arg0)
\_SB.PCI0.RP00.VGA.OPTW (Arg0)
}

Method (_WAK, 1, Serialized) // _WAK: Wake
{
P8XH (One, 0xAB)
WAK (Arg0)
If (LOr (LEqual (Arg0, 0x03), LEqual (Arg0, 0x04)))
{
If (LAnd (DTSE, LGreater (TCNT, One)))
{
TRAP (TRTD, 0x14)
}
}

Return (Package (0x02)
{
Zero,
Zero
})
}
 
Joined
Oct 7, 2011
Messages
140
Motherboard
ASUS ProArt Z490 Creator 10G
CPU
i7-10700K
Graphics
Integrated Graphics Processor
For what hardware?

i5 3210M / Pegatron A35YA (Aptio) / Intel HD 4000 / 8GB 1600MHz DDR3 / 10.11.4 / Clover 3354.

I had my ports working and then they stopped working one at a time. Display won't come on after sleep either.
 
Joined
Apr 3, 2012
Messages
100
Motherboard
GA-Z68X-UD3H-B3
CPU
i5 2500k
Graphics
GTX 650 TI Boost
I have a GA-Z68X-UD3H-B3 running legacy bios. In order to get usb 3 working i had to get the Inateck PCI-E usb 3.0 board. Now I have usb 3 working but my system wakes from sleep. It doesn't go down for a while and wake up, it wakes immediately, fans never shut down. In addition, I was reading...

Problem: System wakes up straight away when USB3 device plugged in.

Fix: Disable wake on USB in your bios.

...that does not apply to me since the system wakes if devices are attached or not.

Since installing El Cap a few weeks ago from Mavericks I have not messed around with kext or injections or any of that. It just seemed to work out of the box (save USB3). Any help would be much appreciated.
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,805
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I have a GA-Z68X-UD3H-B3 running legacy bios. In order to get usb 3 working i had to get the Inateck PCI-E usb 3.0 board. Now I have usb 3 working but my system wakes from sleep. It doesn't go down for a while and wake up, it wakes immediately, fans never shut down. In addition, I was reading...



...that does not apply to me since the system wakes if devices are attached or not.

Since installing El Cap a few weeks ago from Mavericks I have not messed around with kext or injections or any of that. It just seemed to work out of the box (save USB3). Any help would be much appreciated.

Check for "Wake reason" in system.log.
 
Joined
Jun 9, 2013
Messages
10,681
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. Android
The log says Wake reason:?

Sleep would be broken if youve got USB 3 disabled in the BIOS. You're motherboard has Etron EJ168 which probably have problems in 10.11. You will be better off disabling it in a DSDT. If you're motherboard is similar to my H61N-USB3 build then USB 3 will come under HUB0 in the DSDT.
 
Joined
Apr 3, 2012
Messages
100
Motherboard
GA-Z68X-UD3H-B3
CPU
i5 2500k
Graphics
GTX 650 TI Boost
Sleep would be broken if youve got USB 3 disabled in the BIOS.

USB3 has been disabled in bios since I upgraded to El Capitan, but I never had issues with sleep until I installed the USB3 card mentioned in my original post.

It is the addition of the Inateck card that caused this problem.
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,805
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
The log says Wake reason:?

I would add an ACPI identity for the Inatek PCIe USB3 card... that way you can see if it is the cause.
 
Status
Not open for further replies.
Top