Contribute
Register

El capitan USB issues - possible fix.

Status
Not open for further replies.
Joined
Jan 10, 2012
Messages
126
Motherboard
AsRock Z97E-ITX/AC
CPU
i5-5675C
Graphics
HD 6200
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Just did a test install, the USB 3 chip in my Z68X-UD3H-B3 (Etron EJ168) does indeed seem to work natively in El Capitan !

I reenabled mine (onboard) in BIOS, and it does not show up. Anything I need to install? Did you install any kexts (possibly earlier)?
 
Joined
Apr 20, 2015
Messages
169
Motherboard
Gigabyte Z97M-D3H
CPU
i7-4790K
Graphics
GTX 960
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
So, if I follow this below from post #1, what happens to all of the other DSDT stuff I did originally to fix USB 3.0 when I installed El Capitan? Will this effectively overwrite everything else or do I need to do something with the other DSDT.aml fixes/patches, etc.?

Rename your EHC1 to EH01 and your ECH2 to EH02 using clover dsdt patching. Using the same method i explained originally for the _OSI to XOSI patch.

Code:
Item 1:
Comment: change EHC1 to EH01
Find: <45484331>
Replace: <45483031>

Item 2:
Comment: change EHC2 to EH02
Find: <45484332>
Replace: <45483032>


This will effectively disable the Apple port injectors. Then install
FakePCIID.kext and FakePCIID_XHCIMux.kext and reboot.
 

ydp

Joined
Jul 24, 2013
Messages
22
Mac
Classic Mac
Mobile Phone
Hope this helps and its a bit clearer now.

Matt

It definitely helped! I had looked around at solutions for a bit, but seeing that you got yours to work without having to do so many other things inspired me to attempt it. And it worked. I did the DSDT patches and installed those two kexts and it all works beautifully.

I didn't even know anything was wrong until my keyboard stopped working when clover loaded. I had just swapped it from a USB2 port to a USB3 port that was seemingly working. My office mate came in and asked if my ports were working, then I knew it wasn't just some weirdness with my setup alone. Anyway, thank you very much! I'm glad I didn't have to make my own injector too. I didn't have time for that.
 
Joined
Nov 20, 2013
Messages
114
Motherboard
Asrock X299 TAICHI XE
CPU
i9 7940x
Graphics
Nvidia GTX 1080 TI FE
Mac
  1. iMac
  2. Mac Pro
Classic Mac
  1. iMac
Mobile Phone
  1. Android
AFAIK, no solution for Renasas USB3 on 10.11.

Hi all,

Any update on this_NEC / Renesas USB 3.0 EL Capitan support. I am stuck with Z87 UD3H and Maverick.

Want seriously to update to El Capitan. Cant go without USB 3.0 at full speed since I do a lot of data transfer to external USB drives. ( Cards from different cameras to backup drive, and converted to Pro Res Movie for editing. If any possible fix please update here.

Mcity
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,968
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi all,

Any update on this_NEC / Renesas USB 3.0 EL Capitan support. I am stuck with Z87 UD3H and Maverick.

Want seriously to update to El Capitan. Cant go without USB 3.0 at full speed since I do a lot of data transfer to external USB drives. ( Cards from different cameras to backup drive, and converted to Pro Res Movie for editing. If any possible fix please update here.

Rajiv

I simply installed a FL1100 based PCIe card (disabled NEC/Renasas in BIOS). Works OOB.
 
Joined
Jul 4, 2013
Messages
1
Motherboard
Gigabyte GA-Z97-D3HM
CPU
i5-4590
Graphics
HD 4600
many thanks matt77303 & RehabMan, now my ports are listed correctly and also no wake & sleep problems .
 
Joined
Nov 20, 2013
Messages
114
Motherboard
Asrock X299 TAICHI XE
CPU
i9 7940x
Graphics
Nvidia GTX 1080 TI FE
Mac
  1. iMac
  2. Mac Pro
Classic Mac
  1. iMac
Mobile Phone
  1. Android
I simply installed a FL1100 based PCIe card (disabled NEC/Renasas in BIOS). Works OOB.

Hi,

this is a bit difficult work around. still I tried to get one, unfortunately I couldn't find one locally, tried online also including amazon.in (I am in India) still unlucky. what to do? I am in wait and see mod.

mcity
 
Joined
Nov 11, 2011
Messages
104
Motherboard
Z97X-UD3H
CPU
i7 4790k
Graphics
RX 580
I confirm that USB3 patch involving FakePCIID_XHCIMux and FakePCIID works on my GA-Z97X-UD3H. BUT I lost sleep after that immediately. When I put my system to sleep it wakes up all by itself 2 seconds after going to sleep. If i remove those two kexts and clover patch the sleep works again, but no more usb3...

any idea what to do?
 
Status
Not open for further replies.
Top