Contribute
Register

El Capitan on Intel DX58SO

Joined
Jan 24, 2011
Messages
3
Motherboard
Gigabyte Z170X-UD3
CPU
Intel 6700K i7
Graphics
nVidia GTX 760
Hi, setting up El Capitan as a fresh install via UEFI/Clover, I am unable to get audio up.

Specs:

Intel i7 920
Intel DX58SO motherboard with latest BIOS
Nvidia GTX 760

I used the tolled ALC-110 script, which shows 4 audio devices, Headphone, Line Out, Line Out, and Digital Out.
Front panel audio works with Line Out #2, but none to the motherboard ports are working.

Attached are the appropriate files.

Any help would be appreciated.
 

Attachments

Joined
Jan 24, 2011
Messages
3
Motherboard
Gigabyte Z170X-UD3
CPU
Intel 6700K i7
Graphics
nVidia GTX 760
If you mean physically remove headphones, it causes no change, I discovered the from panel jacks worked by plugging them in. If you refer to removing them from sound devices, I am not sure how to accomplish that. Thank you for the reply
 
Joined
Oct 29, 2011
Messages
7
Motherboard
Gigabyte Z170X-Gaming 3
CPU
i7-6700K
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
Hi, could you please tell me the process that you use to install the El Capitan in DX58SO? I managed to successfully install to the HD, but after install I can only boot from the USB, with the HD it does not boot.

Thank you,
 
Joined
Dec 3, 2014
Messages
26
Mac
Classic Mac
Mobile Phone
can you fully define ... 'working like a charm'?

any features of the board not working

have you customized the clover boot loader... what changes did you make

what settings did you use for the post install

thanks
 
Joined
Oct 29, 2011
Messages
7
Motherboard
Gigabyte Z170X-Gaming 3
CPU
i7-6700K
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
can you fully define ... 'working like a charm'?

any features of the board not working

have you customized the clover boot loader... what changes did you make

what settings did you use for the post install

thanks

Ok, I mean that everything is running smoothly: video, audio, ethernet, USB ports etc.

Summarized steps that I used in the installation:

1. Update BIOS with the latest update (year 2013, ver. 5600) from Intel web site (use Windows to run Express Bios Update);
2. Create a Bootable USB stick with UniBeast but partition USB stick with MBR instead GUID, set Legacy Boot Mode and copy DSDT file to EFI folder in USB stick after creation;
3. Boot from USB stick, format HD with DiskUtility as GUID, HFS journaled and install El Capitan;
4. Reboot, complete El Capitan setup and when reach desktop, download Nvidia Web Drivers and install;
5. Run MultiBeast, select Clover with UEFI Boot Mode, ALC 889, machine as MacPro 5,1;
6. Copy DSDT to EFI partition and run Clover Configurator with nv_drv=1, graphics enabler = no, boot in hires, quick boot, FixHPET, AddDTGP, AddMCHC, FixDarwin, FixIPIC and FixUSB;
7. Reboot and done.

My hardware:
MoBo Intel DX58SO (ALC 889, USB ports, FireWire and ethernet working), 3 x 4Gb Tripple Channel DDR3 RAM (12Gb), Intel i7 920 processor, 3 x 1Tb HDD, Nvidia GTX 970 graphics card, 2 x 23" LCD monitors (both working in OS X), DLink DWA-125 wireless USB (working with Bear Extender Driver), a cheap USB Bluetooth stick (working with native OS support), LG BluRay recorder (working with native OS support), USB 3 PCI Ex board (with native OS support), USB Microsoft wireless mouse and a wired USB keyboard. Running Mac OS X El Capitan ver. 10.11.3.
 
Joined
Dec 3, 2014
Messages
26
Mac
Classic Mac
Mobile Phone
thanks for the update...

did you customize your own DSDT or did you download it?

I have my DX58SO still running USL on 10.6.x and USL is so good it looks like a real mac even to apple but that project is all but dead.

This is my goto machine for photoshop and well everything so I am hesitant to upgrade.. it uses an older bios and not sure if it will work with 5600 or not.. I guess I could downgrade back to the original bios but if I remember the USL method actually injeced serial numbers into the bios .. not sure if I still have that backup file..

keep us posted..
 
Joined
Oct 29, 2011
Messages
7
Motherboard
Gigabyte Z170X-Gaming 3
CPU
i7-6700K
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
thanks for the update...

did you customize your own DSDT or did you download it?

I have my DX58SO still running USL on 10.6.x and USL is so good it looks like a real mac even to apple but that project is all but dead.

This is my goto machine for photoshop and well everything so I am hesitant to upgrade.. it uses an older bios and not sure if it will work with 5600 or not.. I guess I could downgrade back to the original bios but if I remember the USL method actually injeced serial numbers into the bios .. not sure if I still have that backup file..

keep us posted..

The performance is great with El Capitan. This is my first time with Clover but I'm enjoying it a lot. Much better than Chimera.

I am using a DSDT downloaded a long time ago when I installed Snow Leopard and I have been using it until now in all my upgrades of Mac OS X.

Cheers,
 
Joined
Feb 6, 2012
Messages
1
Motherboard
Intel DX58SO
CPU
Core i7 965 extreme edition 3.2 GHz
Graphics
NVIDIA GeForce GTX 650 1024 MB
Mac
MacBook Air
Classic Mac
Mobile Phone
Android, iOS
2. Create a Bootable USB stick with UniBeast but partition USB stick with MBR instead GUID, set Legacy Boot Mode and copy DSDT file to EFI folder in USB stick after creation;

Which DSDT are you talking about?
Is it available somewhere ?

Thank you in advance
 
Top